summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-03 20:44:59 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-03 20:44:59 +0000
commit911b154cd91318d266c49d2168cc5e07498f1d8c (patch)
treec5f313ea44c79090c7ec6b86835a728f51f9f9bd /sys-cluster/native-mpi
parentversion bump (diff)
downloadgentoo-2-911b154cd91318d266c49d2168cc5e07498f1d8c.tar.gz
gentoo-2-911b154cd91318d266c49d2168cc5e07498f1d8c.tar.bz2
gentoo-2-911b154cd91318d266c49d2168cc5e07498f1d8c.zip
[sys-cluster/native-mpi] Add stub for prefix
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/native-mpi')
-rw-r--r--sys-cluster/native-mpi/ChangeLog10
-rw-r--r--sys-cluster/native-mpi/metadata.xml9
-rw-r--r--sys-cluster/native-mpi/native-mpi-0.ebuild35
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-cluster/native-mpi/ChangeLog b/sys-cluster/native-mpi/ChangeLog
new file mode 100644
index 000000000000..138c863d760d
--- /dev/null
+++ b/sys-cluster/native-mpi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/native-mpi
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/native-mpi/ChangeLog,v 1.1 2011/03/03 20:44:59 alexxy Exp $
+
+*native-mpi-0 (03 Mar 2011)
+
+ 03 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +native-mpi-0.ebuild,
+ +metadata.xml:
+ Add native mpi stub for prefix
+
diff --git a/sys-cluster/native-mpi/metadata.xml b/sys-cluster/native-mpi/metadata.xml
new file mode 100644
index 000000000000..a70357e10dd8
--- /dev/null
+++ b/sys-cluster/native-mpi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+ <maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/native-mpi/native-mpi-0.ebuild b/sys-cluster/native-mpi/native-mpi-0.ebuild
new file mode 100644
index 000000000000..bc37c9077f14
--- /dev/null
+++ b/sys-cluster/native-mpi/native-mpi-0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/native-mpi/native-mpi-0.ebuild,v 1.1 2011/03/03 20:44:59 alexxy Exp $
+
+EAPI=3
+
+DESCRIPTION="Use native os mpi in prefix envirement"
+HOMEPAGE="http://prefix.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cat >> "${T}"/99mpi <<- EOF
+ MPI_CC=gcc
+ MPI_CXX=g++
+ MPI_FC=gfortran
+ MPI_F90=gfortran
+ HPMPI_F77=gfortran
+ EOF
+ doenvd "${T}"/99mpi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and edit ${EPREFIX}/etc/env.d/99mpi"
+ einfo "to add needed values for your os-mpi implentation"
+ einfo
+}