summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-02-24 09:25:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-02-24 09:25:11 +0000
commitafd10828e82bd760c9b3d76e691510c94a6af8eb (patch)
treeb403d2466651f404ae72491094ffb24019c476e4 /sys-boot
parentProvide advanced option for hanno to help with system rescues. (diff)
downloadgentoo-2-afd10828e82bd760c9b3d76e691510c94a6af8eb.tar.gz
gentoo-2-afd10828e82bd760c9b3d76e691510c94a6af8eb.tar.bz2
gentoo-2-afd10828e82bd760c9b3d76e691510c94a6af8eb.zip
One more bit for hanno. I_KNOW_WHAT_IM_DOING=1 will now enable you to install an unusable grub on amd64 systems without IA32_EMULATION, for specific rescue situations.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub-static/ChangeLog8
-rw-r--r--sys-boot/grub-static/grub-static-0.97-r10.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/sys-boot/grub-static/ChangeLog b/sys-boot/grub-static/ChangeLog
index 5c8d477d0a80..b56582b021f2 100644
--- a/sys-boot/grub-static/ChangeLog
+++ b/sys-boot/grub-static/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/grub-static
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/ChangeLog,v 1.29 2011/02/24 09:22:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/ChangeLog,v 1.30 2011/02/24 09:25:11 robbat2 Exp $
+
+ 24 Feb 2011; Robin H. Johnson <robbat2@gentoo.org>
+ grub-static-0.97-r10.ebuild:
+ One more bit for hanno. I_KNOW_WHAT_IM_DOING=1 will now enable you to install
+ an unusable grub on amd64 systems without IA32_EMULATION, for specific rescue
+ situations.
24 Feb 2011; Robin H. Johnson <robbat2@gentoo.org>
grub-static-0.97-r10.ebuild:
diff --git a/sys-boot/grub-static/grub-static-0.97-r10.ebuild b/sys-boot/grub-static/grub-static-0.97-r10.ebuild
index f30297bec9c8..00bbf2ebe902 100644
--- a/sys-boot/grub-static/grub-static-0.97-r10.ebuild
+++ b/sys-boot/grub-static/grub-static-0.97-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/grub-static-0.97-r10.ebuild,v 1.5 2011/02/24 09:22:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/grub-static-0.97-r10.ebuild,v 1.6 2011/02/24 09:25:11 robbat2 Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -64,7 +64,9 @@ setup_boot_dir() {
local boot_dir=$1
local dir=${boot_dir}
- run_test_grub /sbin/grub
+ if [[ -z "${I_KNOW_WHAT_I_AM_DOING}" ]]; then
+ run_test_grub /sbin/grub
+ fi
mkdir -p "${dir}"
[[ ! -L ${dir}/boot ]] && ln -s . "${dir}/boot"