summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-12 20:38:39 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-12 20:38:39 +0000
commitec9aacc80622ae21df8e44578ab9abf7414321ea (patch)
tree158552ce66ebd0248f1bdb622785f155040ff762 /sys-auth/pam_chroot
parent* bump (diff)
downloadgentoo-2-ec9aacc80622ae21df8e44578ab9abf7414321ea.tar.gz
gentoo-2-ec9aacc80622ae21df8e44578ab9abf7414321ea.tar.bz2
gentoo-2-ec9aacc80622ae21df8e44578ab9abf7414321ea.zip
Respect $LD and $LDFLAGS (bug #185050)
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-auth/pam_chroot')
-rw-r--r--sys-auth/pam_chroot/ChangeLog6
-rw-r--r--sys-auth/pam_chroot/files/pam_chroot-0.9.1-makefile.patch21
-rw-r--r--sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild15
3 files changed, 37 insertions, 5 deletions
diff --git a/sys-auth/pam_chroot/ChangeLog b/sys-auth/pam_chroot/ChangeLog
index 7c0bacf57951..47723a06de08 100644
--- a/sys-auth/pam_chroot/ChangeLog
+++ b/sys-auth/pam_chroot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/pam_chroot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/ChangeLog,v 1.2 2007/07/12 09:29:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/ChangeLog,v 1.3 2007/07/12 20:38:39 hawking Exp $
+
+ 12 Jul 2007; Ali Polatel <hawking@gentoo.org>
+ +files/pam_chroot-0.9.1-makefile.patch, pam_chroot-0.9.1.ebuild:
+ Respect $LD and $LDFLAGS (bug #185050)
12 Jul 2007; Diego Pettenò <flameeyes@gentoo.org>
pam_chroot-0.9.1.ebuild:
diff --git a/sys-auth/pam_chroot/files/pam_chroot-0.9.1-makefile.patch b/sys-auth/pam_chroot/files/pam_chroot-0.9.1-makefile.patch
new file mode 100644
index 000000000000..7f9d194e3243
--- /dev/null
+++ b/sys-auth/pam_chroot/files/pam_chroot-0.9.1-makefile.patch
@@ -0,0 +1,21 @@
+--- Makefile.orig 2004-05-05 03:07:47.000000000 +0300
++++ Makefile 2007-07-12 22:57:23.000000000 +0300
+@@ -1,16 +1,15 @@
+ # $Id: pam_chroot-0.9.1-makefile.patch,v 1.1 2007/07/12 20:38:39 hawking Exp $
+
+ CC=gcc
+-CFLAGS=-fPIC -O2 -Wall -Werror -pedantic
++CFLAGS:=-fPIC -Wall -Werror -pedantic $(CFLAGS)
+ CPPFLAGS=-I.
+-LDFLAGS=-x --shared -lpam
+
+ OUT=pam_chroot.so
+
+ all: $(OUT)
+
+ %.so: %.o
+- ld $(LDFLAGS) -o $@ $<
++ $(LD) -x --shared $(LDFLAGS) -o $@ $< -lpam
+
+ clean:
+ rm -f *.o $(OUT)
diff --git a/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild b/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
index 0ff4f90fcbc8..f9bc53f3158b 100644
--- a/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
+++ b/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild,v 1.2 2007/07/12 09:29:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild,v 1.3 2007/07/12 20:38:39 hawking Exp $
-inherit toolchain-funcs pam flag-o-matic
+inherit toolchain-funcs pam flag-o-matic eutils
DESCRIPTION="Linux-PAM module that allows a user to be chrooted in auth, account, or session."
HOMEPAGE="http://sourceforge.net/projects/pam-chroot/"
@@ -17,9 +17,16 @@ DEPEND="virtual/pam
!<sys-libs/pam-0.99"
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
src_compile() {
- append-flags "-fPIC"
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ LDFLAGS="$(raw-ldflags)" || die "emake failed"
}
src_install() {