summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-16 20:03:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-16 20:03:08 +0000
commit362ab9a22a64251061c062decc428c3b868c57a8 (patch)
tree481834d571956d76a6477fd5d50f189561c4ba91 /sys-apps/usbredir
parentStable for amd64, wrt bug #412097 (diff)
downloadgentoo-2-362ab9a22a64251061c062decc428c3b868c57a8.tar.gz
gentoo-2-362ab9a22a64251061c062decc428c3b868c57a8.tar.bz2
gentoo-2-362ab9a22a64251061c062decc428c3b868c57a8.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/usbredir')
-rw-r--r--sys-apps/usbredir/ChangeLog7
-rw-r--r--sys-apps/usbredir/usbredir-0.4.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-apps/usbredir/ChangeLog b/sys-apps/usbredir/ChangeLog
index 537778a76180..d11322031c76 100644
--- a/sys-apps/usbredir/ChangeLog
+++ b/sys-apps/usbredir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/usbredir
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbredir/ChangeLog,v 1.8 2012/03/06 18:30:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbredir/ChangeLog,v 1.9 2012/04/16 20:03:08 ssuominen Exp $
+
+*usbredir-0.4.3 (16 Apr 2012)
+
+ 16 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +usbredir-0.4.3.ebuild:
+ Version bump.
*usbredir-0.4.2 (06 Mar 2012)
diff --git a/sys-apps/usbredir/usbredir-0.4.3.ebuild b/sys-apps/usbredir/usbredir-0.4.3.ebuild
new file mode 100644
index 000000000000..19e99f6bbd7f
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbredir/usbredir-0.4.3.ebuild,v 1.1 2012/04/16 20:03:08 ssuominen Exp $
+
+EAPI=4
+
+DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="http://spice-space.org/page/UsbRedir"
+SRC_URI="http://spice-space.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+#Force 1.0.9_rc here until virtual/libusb:1 has been updated to 1.0.9_rc
+RDEPEND=">=dev-libs/libusb-1.0.9_rc
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_prepare() {
+ sed -i -e 's:-Werror::' configure || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/lib/*/lib*.la
+}