summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-25 11:38:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-25 11:38:12 +0000
commit13e3b361badb8542e2e23cb37aeef6af1d2f2b25 (patch)
treedfe004c4a038c4702211a126a10b8bc042dfebba /sys-apps/usbredir/usbredir-0.5.1.ebuild
parentDrop old (diff)
downloadgentoo-2-13e3b361badb8542e2e23cb37aeef6af1d2f2b25.tar.gz
gentoo-2-13e3b361badb8542e2e23cb37aeef6af1d2f2b25.tar.bz2
gentoo-2-13e3b361badb8542e2e23cb37aeef6af1d2f2b25.zip
Version bump.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/usbredir/usbredir-0.5.1.ebuild')
-rw-r--r--sys-apps/usbredir/usbredir-0.5.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/usbredir/usbredir-0.5.1.ebuild b/sys-apps/usbredir/usbredir-0.5.1.ebuild
new file mode 100644
index 000000000000..c8620998d75e
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbredir/usbredir-0.5.1.ebuild,v 1.1 2012/09/25 11:38:12 ssuominen Exp $
+
+EAPI=4
+inherit eutils flag-o-matic
+
+DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="http://spice-space.org/page/UsbRedir"
+SRC_URI="http://spice-space.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_configure() {
+ # http://bugs.freedesktop.org/show_bug.cgi?id=54643
+ append-cflags -Wno-error
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # noinst_PROGRAMS
+ dobin usbredirtestclient/usbredirtestclient
+
+ prune_libtool_files
+}