summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-03-22 23:14:39 +0000
committerJason Wever <weeve@gentoo.org>2003-03-22 23:14:39 +0000
commit7b6d6115b305554da79dd19268b53f5fe3b8adc7 (patch)
tree8f91343be0e39e88b7409f51d716fc59ee508850 /sys-apps/sparc-utils
parentadd ARM patches for strace (diff)
downloadgentoo-2-7b6d6115b305554da79dd19268b53f5fe3b8adc7.tar.gz
gentoo-2-7b6d6115b305554da79dd19268b53f5fe3b8adc7.tar.bz2
gentoo-2-7b6d6115b305554da79dd19268b53f5fe3b8adc7.zip
Version bump, fixed up ebuild so man pages are now installed with software.
Diffstat (limited to 'sys-apps/sparc-utils')
-rw-r--r--sys-apps/sparc-utils/ChangeLog7
-rw-r--r--sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r12
-rw-r--r--sys-apps/sparc-utils/sparc-utils-1.9-r1.ebuild64
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-apps/sparc-utils/ChangeLog b/sys-apps/sparc-utils/ChangeLog
index 0b92e07a8688..dd8cfa780ce7 100644
--- a/sys-apps/sparc-utils/ChangeLog
+++ b/sys-apps/sparc-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sparc-utils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/ChangeLog,v 1.8 2003/03/11 05:58:58 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/ChangeLog,v 1.9 2003/03/22 23:14:39 weeve Exp $
+
+*sparc-utils-1.9-r1 (22 Mar 2003)
+
+ 22 Mar 2003; Jason Wever <weeve@gentoo.org> sparc-utils-1.9-r1.ebuild:
+ Version bump, fixed up ebuild so man pages are now installed with software.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r1 b/sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r1
new file mode 100644
index 000000000000..0366076fa938
--- /dev/null
+++ b/sys-apps/sparc-utils/files/digest-sparc-utils-1.9-r1
@@ -0,0 +1,2 @@
+MD5 08bf3f6d8433a1f4981a2afaa6b49a6c sparc-utils_1.9.orig.tar.gz 110080
+MD5 50bd3e4749473b3effdb00981220f09f sparc-utils_1.9-2.diff.bz2 7992
diff --git a/sys-apps/sparc-utils/sparc-utils-1.9-r1.ebuild b/sys-apps/sparc-utils/sparc-utils-1.9-r1.ebuild
new file mode 100644
index 000000000000..fe950785b6f0
--- /dev/null
+++ b/sys-apps/sparc-utils/sparc-utils-1.9-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sparc-utils/sparc-utils-1.9-r1.ebuild,v 1.1 2003/03/22 23:14:39 weeve Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}.orig
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI=" http://http.us.debian.org/debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://gentoo/${PN}_${PV}-2.diff.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="sparc -x86 -ppc -alpha -mips -hppa -arm"
+
+DEPEND="sys-kernel/linux-headers"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${WORKDIR}/${PN}_${PV}-2.diff
+}
+
+src_compile() {
+ CFLAGS="-O3"
+ emake -C elftoaout-2.3 CFLAGS="$CFLAGS" || die
+ emake -C src piggyback piggyback64 CFLAGS="$CFLAGS" || die
+ emake -C prtconf-1.3 all || die
+ # TODO: Fix compile issue
+ # Not compiling at this time, commented out
+ #emake -C sparc32-1.1
+ emake -C audioctl-1.3 || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /etc/init.d /etc/default
+ install -s elftoaout-2.3/elftoaout ${D}/usr/bin
+ install -s src/piggyback src/piggyback64 ${D}/usr/bin
+ #install -s sparc32-1.1/sparc32 ${D}/usr/bin
+
+ install -s prtconf-1.3/prtconf ${D}/usr/sbin/prtconf
+ install -s prtconf-1.3/eeprom ${D}/usr/sbin/eeprom
+ #ln -sf sparc32 ${D}/usr/bin/
+ install -s audioctl-1.3/audioctl ${D}/usr/bin
+ # install /etc/init.d script & /etc/default scripts
+ install -d -m 755 ${D}/etc ${D}/etc/init.d ${D}/etc/default
+ #install -m 755 debian/audioctl ${D}/etc/init.d
+ install -m 755 debian/audioctl.def ${D}/etc/default/audioctl
+ doman audioctl-1.3/audioctl.1
+ doman elftoaout-2.3/elftoaout.1
+ doman prtconf-1.3/prtconf.8
+ doman prtconf-1.3/eeprom.8
+ doman debian/piggyback.1
+ doman debian/piggyback64.1
+}
+
+pkg_postinst() {
+ # Todo: Somehow set this automatically
+ ewarn "Make sure /dev/openprom exists. If you're not using devfs and"
+ ewarn "/dev/openprom does not exist, run"
+ ewarn ""
+ ewarn "\tcd /dev ; mknod openprom c 10 139"
+}