summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-15 00:06:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-15 00:06:15 +0000
commit1ac5046c11a07cb045cbf85563c0f1f3e844ddaa (patch)
treeda89bcfd5d911d847bbbca14a78df2f3316c1924 /sys-apps/man
parentold (diff)
downloadgentoo-2-1ac5046c11a07cb045cbf85563c0f1f3e844ddaa.tar.gz
gentoo-2-1ac5046c11a07cb045cbf85563c0f1f3e844ddaa.tar.bz2
gentoo-2-1ac5046c11a07cb045cbf85563c0f1f3e844ddaa.zip
Search new xorg categories #112480 by Ryan Hill.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog8
-rw-r--r--sys-apps/man/files/digest-man-1.6b-r21
-rw-r--r--sys-apps/man/files/man-1.6b-more-sections.patch13
-rw-r--r--sys-apps/man/man-1.6b-r2.ebuild116
4 files changed, 137 insertions, 1 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index f42bcea391da..961f86ab4160 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.78 2005/11/13 04:04:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.79 2005/11/15 00:06:15 vapier Exp $
+
+*man-1.6b-r2 (15 Nov 2005)
+
+ 15 Nov 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/man-1.6b-more-sections.patch, +man-1.6b-r2.ebuild:
+ Search new xorg categories #112480 by Ryan Hill.
*man-1.6b-r1 (13 Nov 2005)
diff --git a/sys-apps/man/files/digest-man-1.6b-r2 b/sys-apps/man/files/digest-man-1.6b-r2
new file mode 100644
index 000000000000..d165bbd8d8a6
--- /dev/null
+++ b/sys-apps/man/files/digest-man-1.6b-r2
@@ -0,0 +1 @@
+MD5 81d96091482b6445cbfa248fadb422b8 man-1.6b.tar.gz 238993
diff --git a/sys-apps/man/files/man-1.6b-more-sections.patch b/sys-apps/man/files/man-1.6b-more-sections.patch
new file mode 100644
index 000000000000..9e13c09e8f4e
--- /dev/null
+++ b/sys-apps/man/files/man-1.6b-more-sections.patch
@@ -0,0 +1,13 @@
+[1-8]x are for xorg man-pages
+
+--- configure
++++ configure
+@@ -949,7 +949,7 @@
+
+ # What sections do we anticipate?
+
+-tmpsections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o"
++tmpsections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x"
+
+ if [ x$default = x ]; then
+ echo ""
diff --git a/sys-apps/man/man-1.6b-r2.ebuild b/sys-apps/man/man-1.6b-r2.ebuild
new file mode 100644
index 000000000000..f96f60149c5f
--- /dev/null
+++ b/sys-apps/man/man-1.6b-r2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6b-r2.ebuild,v 1.1 2005/11/15 00:06:15 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard commands to read man pages"
+HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
+SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=""
+RDEPEND="sys-process/cronbase
+ >=sys-apps/groff-1.18
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We love to cross-compile
+ epatch "${FILESDIR}"/man-1.6-cross-compile.patch
+ epatch "${FILESDIR}"/man-1.6b-build.patch
+
+ # Fix search order in man.conf so that system installed manpages
+ # will be found first ...
+ epatch "${FILESDIR}"/man-1.5p-search-order.patch
+
+ # For groff-1.18 or later we need to call nroff with '-c'
+ epatch "${FILESDIR}"/man-1.5m-groff-1.18.patch
+
+ # makewhatis traverses manpages twice, as default manpath
+ # contains two directories that are symlinked together
+ epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
+
+ # makewhatis should get section info from config, not hardcode it #86863
+ epatch "${FILESDIR}"/man-1.6a-makewhatis-config.patch
+
+ # add more sections to default search path
+ epatch "${FILESDIR}"/man-1.6b-more-sections.patch
+
+ # Fedora patches
+ epatch "${FILESDIR}"/man-1.5m2-apropos.patch
+ epatch "${FILESDIR}"/man-1.5p-man2html.patch
+ epatch "${FILESDIR}"/man-1.5p-mandirlist.patch
+
+ # use non-lazy binds for man
+ append-ldflags -Wl,-z,now
+
+ strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
+}
+
+src_compile() {
+ tc-export CC BUILD_CC
+
+ local mylang=
+ if use nls ; then
+ if [[ -z ${LINGUAS} ]] ; then
+ mylang="all"
+ else
+ mylang="${LINGUAS// /,}"
+ fi
+ else
+ mylang="none"
+ fi
+ ./configure \
+ -confdir=/etc \
+ +sgid +fhs \
+ +lang ${mylang} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make PREFIX="${D}" install || die "make install failed"
+ dosym man /usr/bin/manpath
+
+ dodoc LSM README* TODO
+
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/makewhatis.cron makewhatis
+
+ keepdir /var/cache/man
+ diropts -m0775 -g man
+ local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
+ for x in ${mansects//:/ } ; do
+ keepdir /var/cache/man/cat${x}
+ done
+}
+
+pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man "${ROOT}"/var/cache/man
+ chmod -R g+w "${ROOT}"/var/cache/man
+ [[ -e ${ROOT}/var/cache/man/whatis ]] \
+ && chown root:root "${ROOT}"/var/cache/man/whatis
+
+ echo
+
+ local files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ if [[ ${files/$'\n'} != ${files} ]] ; then
+ ewarn "You have multiple makewhatis cron files installed."
+ ewarn "You might want to delete all but one of these:"
+ echo ${files}
+ fi
+}