summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-09-26 13:18:25 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-09-26 13:18:25 +0000
commitd63bdc662329e5df97695474836b4d7ba936a543 (patch)
tree2c5f4ec8f167405c27e60b50e43435fe73bdd321 /sci-misc
parentMask unsupported video cards. (diff)
downloadgentoo-2-d63bdc662329e5df97695474836b4d7ba936a543.tar.gz
gentoo-2-d63bdc662329e5df97695474836b4d7ba936a543.tar.bz2
gentoo-2-d63bdc662329e5df97695474836b4d7ba936a543.zip
Version bump and cleanup (fixes bug #117288).
(Portage version: 2.2_rc9/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/qcad/ChangeLog9
-rw-r--r--sci-misc/qcad/files/qcad-2.0.5.0-doc.patch18
-rw-r--r--sci-misc/qcad/qcad-2.0.4.0-r1.ebuild87
-rw-r--r--sci-misc/qcad/qcad-2.0.4.0-r2.ebuild88
-rw-r--r--sci-misc/qcad/qcad-2.0.5.0.ebuild (renamed from sci-misc/qcad/qcad-2.0.4.0-r4.ebuild)66
5 files changed, 64 insertions, 204 deletions
diff --git a/sci-misc/qcad/ChangeLog b/sci-misc/qcad/ChangeLog
index 9f53502783c7..366b1907439e 100644
--- a/sci-misc/qcad/ChangeLog
+++ b/sci-misc/qcad/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-misc/qcad
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/qcad/ChangeLog,v 1.26 2008/04/27 12:54:27 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/qcad/ChangeLog,v 1.27 2008/09/26 13:18:25 markusle Exp $
+
+*qcad-2.0.5.0 (26 Sep 2008)
+
+ 26 Sep 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/qcad-2.0.5.0-doc.patch, -qcad-2.0.4.0-r1.ebuild,
+ -qcad-2.0.4.0-r2.ebuild, -qcad-2.0.4.0-r4.ebuild, +qcad-2.0.5.0.ebuild:
+ Version bump and cleanup (fixes bug #117288).
27 Apr 2008; Markus Dittrich <markusle@gentoo.org>
+files/qcad-2.0.4.0-gcc43.patch, qcad-2.0.4.0-r5.ebuild:
diff --git a/sci-misc/qcad/files/qcad-2.0.5.0-doc.patch b/sci-misc/qcad/files/qcad-2.0.5.0-doc.patch
new file mode 100644
index 000000000000..8feb6a6a0e85
--- /dev/null
+++ b/sci-misc/qcad/files/qcad-2.0.5.0-doc.patch
@@ -0,0 +1,18 @@
+diff -Naur qcad-2.0.5.0-1-community.src/qcad/src/qc_applicationwindow.cpp qcad-2.0.5.0-1-community.src.new/qcad/src/qc_applicationwindow.cpp
+--- qcad-2.0.5.0-1-community.src/qcad/src/qc_applicationwindow.cpp 2005-11-22 06:49:33.000000000 -0500
++++ qcad-2.0.5.0-1-community.src.new/qcad/src/qc_applicationwindow.cpp 2008-09-25 18:43:17.000000000 -0400
+@@ -2943,12 +2943,12 @@
+ RS_SYSTEM->getAppDir().latin1());
+ RS_DEBUG->print("QC_ApplicationWindow::slotHelpManual(): appdir: %s",
+ RS_SYSTEM->getAppDir().latin1());
+- assistant = new QAssistantClient(RS_SYSTEM->getAppDir()+"/bin", this);
++ assistant = new QAssistantClient("FULLASSISTANTPATH", this);
+ connect(assistant, SIGNAL(error(const QString&)),
+ this, SLOT(slotError(const QString&)));
+ QStringList args;
+ args << "-profile";
+- args << QDir::convertSeparators(RS_SYSTEM->getDocPath() + "/qcaddoc.adp");
++ args << QDir::convertSeparators("QCADDOCPATH/qcaddoc.adp");
+ // args << QString("doc") + QDir::separator() + QString("qcaddoc.adp");
+
+ #if QT_VERSION>=0x030200
diff --git a/sci-misc/qcad/qcad-2.0.4.0-r1.ebuild b/sci-misc/qcad/qcad-2.0.4.0-r1.ebuild
deleted file mode 100644
index 2299708a9c5f..000000000000
--- a/sci-misc/qcad/qcad-2.0.4.0-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/qcad/qcad-2.0.4.0-r1.ebuild,v 1.11 2007/12/31 19:24:55 je_fro Exp $
-
-inherit kde-functions eutils
-
-MY_PV=${PV}-1
-MY_P=${P}-1.src
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="A 2D CAD package based upon Qt."
-SRC_URI="http://www.ribbonsoft.com/archives/qcad/${MY_P}.tar.gz
- doc? ( mirror://gentoo/qcad-manual-200404.tar.bz2
- http://dev.gentoo.org/~phosphan/qcad-manual-200404.tar.bz2 )"
-HOMEPAGE="http://www.ribbonsoft.com/qcad.html"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-KEYWORDS="x86 ppc amd64"
-
-DEPEND=">=sys-apps/sed-4"
-need-qt 3.3
-
-src_unpack() {
- unpack ${A}
-# mv doc ${S}/qcad/
- cd "${S}"
- echo >> defs.pro "DEFINES += _REENTRANT QT_THREAD_SUPPORT"
- echo >> defs.pro "CONFIG += thread release"
- echo >> defs.pro "QMAKE_CFLAGS_RELEASE += ${CFLAGS}"
- echo >> defs.pro "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}"
- for file in */Makefile scripts/build_qcad.sh; do
- sed -i -e 's~qmake~${QTDIR}/bin/qmake~g' $file || \
- die "unable to correct path to qmake in $file"
- done
- epatch "${FILESDIR}"/${MY_P}-gentoo.patch
- epatch "${FILESDIR}"/manual.patch-r1
- cd "${S}"/scripts
- sed -i -e 's/^make/make ${MAKEOPTS}/' build_qcad.sh || \
- die "unable to add MAKEOPTS"
- sed -i -e 's/^\.\/configure/.\/configure --host=${CHOST}/' build_qcad.sh \
- || die "unable to set CHOST"
- cd "${S}"/qcad/src
- sed -i -e "s:FULLASSISTANTPATH:${QTDIR}/bin:" qc_applicationwindow.cpp \
- || die "sed failed on assistant path"
- sed -i -e "s:QCADDOCPATH:/usr/share/doc/${PF}:" \
- qc_applicationwindow.cpp || die "sed failed on manual path"
-
-}
-
-src_compile() {
- ### borrowed from kde.eclass #
- #
- # fix the sandbox errors "can't writ to .kde or .qt" problems.
- # this is a fake homedir that is writeable under the sandbox, so that the build process
- # can do anything it wants with it.
- REALHOME="$HOME"
- mkdir -p "$T"/fakehome/.kde
- mkdir -p "$T"/fakehome/.qt
- export HOME="$T/fakehome"
- # things that should access the real homedir
- [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
- cd scripts
- sh build_qcad.sh || die "build failed"
- if ! test -f "${S}"/qcad/qcad; then
- die "no binary created, build failed"
- fi
-}
-
-src_install () {
- cd qcad
- mv qcad qcad.bin
- dobin qcad.bin
- echo -e "#!/bin/sh\ncd /usr/share/${P}\nqcad.bin" > qcad
- chmod ugo+rx qcad
- dobin qcad
- dodir /usr/share/${P}
- cp -pPR patterns examples fonts qm "${D}"/usr/share/${P}
- cd ..
- dodoc README
- if use doc; then
- insinto /usr/share/doc/${PF}/
- cd "${WORKDIR}"
- cp -pPR qcaddoc.adp cad "${D}"usr/share/doc/${PF}
- fi
- make_desktop_entry ${PN} ${PN} ${PN} Office
-}
diff --git a/sci-misc/qcad/qcad-2.0.4.0-r2.ebuild b/sci-misc/qcad/qcad-2.0.4.0-r2.ebuild
deleted file mode 100644
index 9f8dfaff062b..000000000000
--- a/sci-misc/qcad/qcad-2.0.4.0-r2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/qcad/qcad-2.0.4.0-r2.ebuild,v 1.6 2007/12/31 19:24:55 je_fro Exp $
-
-inherit kde-functions eutils
-
-MY_PV=${PV}-1
-MY_P=${P}-1.src
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="A 2D CAD package based upon Qt."
-SRC_URI="http://www.ribbonsoft.com/archives/qcad/${MY_P}.tar.gz
- doc? ( mirror://gentoo/qcad-manual-200404.tar.bz2
- http://dev.gentoo.org/~phosphan/qcad-manual-200404.tar.bz2 )"
-HOMEPAGE="http://www.ribbonsoft.com/qcad.html"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-KEYWORDS="~x86 ~ppc ~amd64"
-
-DEPEND=">=sys-apps/sed-4"
-need-qt 3.3
-
-src_unpack() {
- unpack ${A}
- # Bug 112864 - fix dir unpack bug
- touch "${WORKDIR}"
- cd "${S}"
- echo >> defs.pro "DEFINES += _REENTRANT QT_THREAD_SUPPORT"
- echo >> defs.pro "CONFIG += thread release"
- echo >> defs.pro "QMAKE_CFLAGS_RELEASE += ${CFLAGS}"
- echo >> defs.pro "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}"
- for file in */Makefile scripts/build_qcad.sh; do
- sed -i -e 's~qmake~${QTDIR}/bin/qmake~g' $file || \
- die "unable to correct path to qmake in $file"
- done
- epatch "${FILESDIR}"/${MY_P}-gentoo.patch
- epatch "${FILESDIR}"/manual.patch-r1
- cd "${S}"/scripts
- sed -i -e 's/^make/make ${MAKEOPTS}/' build_qcad.sh || \
- die "unable to add MAKEOPTS"
- sed -i -e 's/^\.\/configure/.\/configure --host=${CHOST}/' build_qcad.sh \
- || die "unable to set CHOST"
- cd "${S}"/qcad/src
- sed -i -e "s:FULLASSISTANTPATH:${QTDIR}/bin:" qc_applicationwindow.cpp \
- || die "sed failed on assistant path"
- sed -i -e "s:QCADDOCPATH:/usr/share/doc/${PF}:" \
- qc_applicationwindow.cpp || die "sed failed on manual path"
-
-}
-
-src_compile() {
- ### borrowed from kde.eclass #
- #
- # fix the sandbox errors "can't writ to .kde or .qt" problems.
- # this is a fake homedir that is writeable under the sandbox, so that the build process
- # can do anything it wants with it.
- REALHOME="$HOME"
- mkdir -p "${T}"/fakehome/.kde
- mkdir -p "${T}"fakehome/.qt
- export HOME="${T}/fakehome"
- # things that should access the real homedir
- [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
- cd scripts
- sh build_qcad.sh || die "build failed"
- if ! test -f "${S}"/qcad/qcad; then
- die "no binary created, build failed"
- fi
-}
-
-src_install () {
- cd qcad
- mv qcad qcad.bin
- dobin qcad.bin
- echo -e "#!/bin/sh\ncd /usr/share/${P}\nqcad.bin \"\$@\"" > qcad
- chmod ugo+rx qcad
- dobin qcad
- dodir /usr/share/${P}
- cp -pPR patterns examples fonts qm "${D}"/usr/share/${P}
- cd ..
- dodoc README
- if use doc; then
- insinto /usr/share/doc/${PF}/
- cd "${WORKDIR}"
- cp -pPR qcaddoc.adp cad "${D}"usr/share/doc/${PF}
- fi
- make_desktop_entry ${PN} ${PN} ${PN} Office
-}
diff --git a/sci-misc/qcad/qcad-2.0.4.0-r4.ebuild b/sci-misc/qcad/qcad-2.0.5.0.ebuild
index c94ebf99b089..17aa78df5f4c 100644
--- a/sci-misc/qcad/qcad-2.0.4.0-r4.ebuild
+++ b/sci-misc/qcad/qcad-2.0.5.0.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/qcad/qcad-2.0.4.0-r4.ebuild,v 1.4 2007/12/31 19:24:55 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/qcad/qcad-2.0.5.0.ebuild,v 1.1 2008/09/26 13:18:25 markusle Exp $
inherit kde-functions eutils
-MY_PV=${PV}-1
-MY_P=${P}-1.src
+MY_P=${P}-1-community.src
+PATCH_V="2.0.4.0-1.src"
S=${WORKDIR}/${MY_P}
DESCRIPTION="A 2D CAD package based upon Qt."
SRC_URI="http://www.ribbonsoft.com/archives/qcad/${MY_P}.tar.gz
- doc? ( mirror://gentoo/qcad-manual-200404.tar.bz2
- http://dev.gentoo.org/~phosphan/qcad-manual-200404.tar.bz2 )"
+ doc? ( mirror://gentoo/qcad-manual-200404.tar.bz2 )"
HOMEPAGE="http://www.ribbonsoft.com/qcad.html"
LICENSE="GPL-2"
@@ -23,20 +22,28 @@ need-qt 3.3
src_unpack() {
unpack ${A}
- # Bug 112864 - fix dir unpack bug
- touch "${WORKDIR}"
cd "${S}"
- echo >> defs.pro "DEFINES += _REENTRANT QT_THREAD_SUPPORT"
- echo >> defs.pro "CONFIG += thread release"
- echo >> defs.pro "QMAKE_CFLAGS_RELEASE += ${CFLAGS}"
- echo >> defs.pro "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}"
+
+ epatch "${FILESDIR}"/${PN}-${PATCH_V}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-doc.patch
+ epatch "${FILESDIR}"/${PN}-${PATCH_V}-intptr.patch
+ epatch "${FILESDIR}"/${PN}-2.0.4.0-gcc43.patch
+
for file in */Makefile scripts/build_qcad.sh; do
sed -i -e 's~qmake~${QTDIR}/bin/qmake~g' $file || \
die "unable to correct path to qmake in $file"
done
- epatch "${FILESDIR}"/${MY_P}-gentoo.patch
- epatch "${FILESDIR}"/manual.patch-r1
- epatch "${FILESDIR}"/${MY_P}-intptr.patch
+
+ cd "${S}"/mkspecs
+ echo >> defs.pro "DEFINES += _REENTRANT QT_THREAD_SUPPORT"
+ echo >> defs.pro "CONFIG += thread release"
+ echo >> defs.pro "QMAKE_CFLAGS_RELEASE += ${CFLAGS}"
+ echo >> defs.pro "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}"
+
+ # code does not compile with -pedantic
+ sed -i -e "s:-pedantic::" defs.pro \
+ || die "failed to remove -pedantic flag"
+
cd "${S}"/scripts
sed -i -e 's/^make/make ${MAKEOPTS}/' build_qcad.sh || \
die "unable to add MAKEOPTS"
@@ -47,7 +54,6 @@ src_unpack() {
|| die "sed failed on assistant path"
sed -i -e "s:QCADDOCPATH:/usr/share/doc/${PF}:" \
qc_applicationwindow.cpp || die "sed failed on manual path"
-
}
src_compile() {
@@ -71,19 +77,23 @@ src_compile() {
src_install () {
cd qcad
- mv qcad qcad.bin
- dobin qcad.bin
- echo -e "#!/bin/sh\ncd /usr/share/${P}\nqcad.bin" > qcad
- chmod ugo+rx qcad
- dobin qcad
- dodir /usr/share/${P}
- cp -pPR patterns examples fonts qm "${D}"/usr/share/${P}
- cd ..
- dodoc README
+ dodoc README || die "Failed to install docs"
+ mv qcad qcad.bin || die "Failed to rename qcad binary"
+ dobin qcad.bin || die "Failed to install qcad binary"
+ echo -e "#!/bin/sh\ncd /usr/share/${P}\nqcad.bin" > qcad \
+ || die "Failed to create qcad wrapper script"
+ dobin qcad || die "Failed to install qcad wrapper"
+
+ insinto /usr/share/${P}
+ doins -r patterns examples fonts qm \
+ || die "Failed to install support files"
+
+ doicon src/xpm/${PN}.xpm
+ make_desktop_entry ${PN} QCad ${PN} Office
+
if use doc; then
- insinto /usr/share/doc/${PF}/
cd "${WORKDIR}"
- cp -pPR qcaddoc.adp cad "${D}"usr/share/doc/${PF}
+ insinto /usr/share/doc/${PF}/
+ doins -r qcaddoc.adp cad || die "Failed to install manual"
fi
- make_desktop_entry ${PN} ${PN} ${PN} Office
}