summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-09-15 12:38:36 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-09-15 12:38:36 +0000
commit9f2cb2ada699bc43a0725f5b50b1f51994a69be6 (patch)
treeb1737436d877df7ef2bf6c76663bd1182bc0851f /sci-mathematics/pari
parentRemoved entries for punted packages. (diff)
downloadgentoo-2-9f2cb2ada699bc43a0725f5b50b1f51994a69be6.tar.gz
gentoo-2-9f2cb2ada699bc43a0725f5b50b1f51994a69be6.tar.bz2
gentoo-2-9f2cb2ada699bc43a0725f5b50b1f51994a69be6.zip
Added fix to allow test routines to pass on sparc (see bug #141206).
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-mathematics/pari')
-rw-r--r--sci-mathematics/pari/ChangeLog6
-rw-r--r--sci-mathematics/pari/pari-2.3.2.ebuild4
2 files changed, 7 insertions, 3 deletions
diff --git a/sci-mathematics/pari/ChangeLog b/sci-mathematics/pari/ChangeLog
index 59be473aeb51..ab7c619e78ba 100644
--- a/sci-mathematics/pari/ChangeLog
+++ b/sci-mathematics/pari/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/pari
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.43 2007/07/22 06:59:26 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/ChangeLog,v 1.44 2007/09/15 12:38:36 markusle Exp $
+
+ 15 Sep 2007; Markus Dittrich <markusle@gentoo.org> pari-2.3.2.ebuild:
+ Added fix to allow test routines to pass on sparc (see bug #141206).
+ Thanks much to <fmccor@gentoo.org> for his patch.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; pari-2.3.0.ebuild,
pari-2.3.2.ebuild:
diff --git a/sci-mathematics/pari/pari-2.3.2.ebuild b/sci-mathematics/pari/pari-2.3.2.ebuild
index b0752ae98597..9f889e9f99f1 100644
--- a/sci-mathematics/pari/pari-2.3.2.ebuild
+++ b/sci-mathematics/pari/pari-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.2.ebuild,v 1.2 2007/07/22 06:59:26 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.3.2.ebuild,v 1.3 2007/09/15 12:38:36 markusle Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -29,7 +29,7 @@ src_unpack() {
src_compile() {
# Special handling for sparc
local myhost
- [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparc64-linux" \
+ [ "${PROFILE_ARCH}" == "sparc64" ] && myhost="sparcv9-linux" \
|| myhost="$(echo ${CHOST} | cut -f "1 3" -d '-')"
einfo "Building for ${myhost}"