summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2014-11-27 20:50:35 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2014-11-27 20:50:35 +0000
commit3570cb67188865c434e10d997759e7968710c571 (patch)
treef58e4cd07af3118923f5a44ddba0ab30a85454a4 /sci-libs
parentApply patches manually so they don't get applied twice. (diff)
downloadgentoo-2-3570cb67188865c434e10d997759e7968710c571.tar.gz
gentoo-2-3570cb67188865c434e10d997759e7968710c571.tar.bz2
gentoo-2-3570cb67188865c434e10d997759e7968710c571.zip
Prevent injection of -L{prefix}/lib to LDFLAGS. Fixes bug #530746 by Ulenrich <eulenreich@gmx.de>. Thanks to Jouni Kosonen <jouni.kosonen@tukesoft.com> for the hint
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog10
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.14-ldflags.patch20
-rw-r--r--sci-libs/hdf5/hdf5-1.8.14-r1.ebuild (renamed from sci-libs/hdf5/hdf5-1.8.14.ebuild)3
3 files changed, 31 insertions, 2 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index f1f83e4b6171..bd0d4ac073a6 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.119 2014/11/25 15:26:17 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.120 2014/11/27 20:50:35 xarthisius Exp $
+
+*hdf5-1.8.14-r1 (27 Nov 2014)
+
+ 27 Nov 2014; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.14-ldflags.patch, +hdf5-1.8.14-r1.ebuild, -hdf5-1.8.14.ebuild:
+ Prevent injection of -L{prefix}/lib to LDFLAGS. Fixes bug #530746 by Ulenrich
+ <eulenreich@gmx.de>. Thanks to Jouni Kosonen <jouni.kosonen@tukesoft.com> for
+ the hint
*hdf5-1.8.14 (25 Nov 2014)
diff --git a/sci-libs/hdf5/files/hdf5-1.8.14-ldflags.patch b/sci-libs/hdf5/files/hdf5-1.8.14-ldflags.patch
new file mode 100644
index 000000000000..c27800d9ce30
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.14-ldflags.patch
@@ -0,0 +1,20 @@
+Revert changes made to fix HDFFV-8944
+
+https://bugs.gentoo.org/show_bug.cgi?id=530746
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -115,12 +115,7 @@
+ AM_CXXFLAGS="${AM_CXXFLAGS}"
+ AM_FCFLAGS="${AM_FCFLAGS}"
+ AM_CPPFLAGS="${AM_CPPFLAGS}"
+-# Added to address HDFFV-8944
+-if test "x$prefix" = xNONE; then
+- AM_LDFLAGS="$AM_LDFLAGS -L$ac_default_prefix/lib"
+-else
+- AM_LDFLAGS="$AM_LDFLAGS -L$prefix/lib"
+-fi
++AM_LDFLAGS="${AM_LDFLAGS}"
+ CFLAGS="${CFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ FCFLAGS="${FCFLAGS}"
diff --git a/sci-libs/hdf5/hdf5-1.8.14.ebuild b/sci-libs/hdf5/hdf5-1.8.14-r1.ebuild
index 4a1816122120..0b98562a1a44 100644
--- a/sci-libs/hdf5/hdf5-1.8.14.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.14.ebuild,v 1.1 2014/11/25 15:26:17 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.14-r1.ebuild,v 1.1 2014/11/27 20:50:35 xarthisius Exp $
EAPI=5
@@ -41,6 +41,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
"${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
"${FILESDIR}"/${PN}-1.8.14-implicits.patch
+ "${FILESDIR}"/${PN}-1.8.14-ldflags.patch
)
pkg_setup() {