summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-21 10:06:59 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-21 10:06:59 +0000
commitf86d1f66fab0d7b577e7f451f2643d7392aabaa0 (patch)
tree7d672941a06f0949107cbc394f76d48d450fde34 /sci-libs/ccpn-data
parentnet-im/gajim: Backport upstream patch for servers without STARTTLS support, #... (diff)
downloadgentoo-2-f86d1f66fab0d7b577e7f451f2643d7392aabaa0.tar.gz
gentoo-2-f86d1f66fab0d7b577e7f451f2643d7392aabaa0.tar.bz2
gentoo-2-f86d1f66fab0d7b577e7f451f2643d7392aabaa0.zip
sci-libs/ccpn-data: Move to new python eclasses
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/ccpn-data')
-rw-r--r--sci-libs/ccpn-data/ChangeLog10
-rw-r--r--sci-libs/ccpn-data/ccpn-data-2.2.2_p121112-r1.ebuild63
-rw-r--r--sci-libs/ccpn-data/metadata.xml8
3 files changed, 75 insertions, 6 deletions
diff --git a/sci-libs/ccpn-data/ChangeLog b/sci-libs/ccpn-data/ChangeLog
index 0e17774b2a3e..d7fa48354293 100644
--- a/sci-libs/ccpn-data/ChangeLog
+++ b/sci-libs/ccpn-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/ccpn-data
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.12 2012/11/12 08:01:34 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ChangeLog,v 1.13 2013/03/21 10:06:59 jlec Exp $
+
+*ccpn-data-2.2.2_p121112-r1 (21 Mar 2013)
+
+ 21 Mar 2013; Justin Lecher <jlec@gentoo.org>
+ +ccpn-data-2.2.2_p121112-r1.ebuild, metadata.xml:
+ Move to new python eclasses
*ccpn-data-2.2.2_p121112 (12 Nov 2012)
diff --git a/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112-r1.ebuild b/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112-r1.ebuild
new file mode 100644
index 000000000000..c2f565137d5e
--- /dev/null
+++ b/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccpn-data/ccpn-data-2.2.2_p121112-r1.ebuild,v 1.1 2013/03/21 10:06:59 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils portability python-r1 versionator
+
+PATCHSET="${PV##*_p}"
+MY_PN="${PN/-data}mr"
+MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
+MY_MAJOR="$(get_version_component_range 1-3)"
+
+DESCRIPTION="The Collaborative Computing Project for NMR - Data"
+HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
+SRC_URI="http://www2.ccpn.ac.uk/download/${MY_PN}/analysis${MY_PV}.tar.gz"
+[[ -n ${PATCHSET} ]] && SRC_URI+=" http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch.xz"
+
+SLOT="0"
+LICENSE="|| ( CCPN LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="!<sci-chemistry/ccpn-${PVR}"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}"/ccpnmr/ccpnmr2.2
+
+src_prepare() {
+ [[ -n ${PATCHSET} ]] && \
+ epatch "${WORKDIR}"/ccpn-update-${MY_MAJOR}-${PATCHSET}.patch
+}
+
+src_install() {
+ local i pydocs in_path
+
+ dodir /usr/share/doc/${PF}/html
+ sed \
+ -e "s:../ccpnmr2.1:${EPREFIX}/usr/share/doc/${PF}/html:g" \
+ ../doc/index.html > "${ED}"/usr/share/doc/${PF}/html/index.html || die
+ treecopy $(find python/ -name doc -type d) "${ED}"/usr/share/doc/${PF}/html/
+
+ pydocs="$(find python -name doc -type d)"
+
+ linking() {
+ in_path=$(python_get_sitedir)/ccpn
+ dosym ../../../../share/doc/${PF}/html ${in_path}/doc
+ for i in ${pydocs}; do
+ dosym /usr/share/doc/${PF}/html/${i} ${in_path}/${i}
+ done
+ dosym /usr/share/ccpn/data ${in_path}/data
+ dosym /usr/share/ccpn/model ${in_path}/model
+ }
+ python_foreach_impl linking
+
+ dohtml -r doc/*
+ insinto /usr/share/ccpn
+ doins -r data model
+}
diff --git a/sci-libs/ccpn-data/metadata.xml b/sci-libs/ccpn-data/metadata.xml
index 1837bbc07a6e..ae9ec7c5f6a4 100644
--- a/sci-libs/ccpn-data/metadata.xml
+++ b/sci-libs/ccpn-data/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>