summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2012-02-04 23:41:54 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2012-02-04 23:41:54 +0000
commit5b74893dbd35634f0db536ceb31effe2c1724491 (patch)
tree39a381281317fcab50b7be96480e79808723dd15 /sci-biology/tophat
parentVersion bump. (diff)
downloadgentoo-2-5b74893dbd35634f0db536ceb31effe2c1724491.tar.gz
gentoo-2-5b74893dbd35634f0db536ceb31effe2c1724491.tar.bz2
gentoo-2-5b74893dbd35634f0db536ceb31effe2c1724491.zip
filter as-needed, version bump, fixes bug 401227
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/tophat')
-rw-r--r--sci-biology/tophat/ChangeLog14
-rw-r--r--sci-biology/tophat/tophat-1.3.3.ebuild (renamed from sci-biology/tophat/tophat-1.3.2.ebuild)10
-rw-r--r--sci-biology/tophat/tophat-1.4.1.ebuild37
3 files changed, 57 insertions, 4 deletions
diff --git a/sci-biology/tophat/ChangeLog b/sci-biology/tophat/ChangeLog
index b6637cee9485..1f97b01cad59 100644
--- a/sci-biology/tophat/ChangeLog
+++ b/sci-biology/tophat/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-biology/tophat
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.5 2011/09/26 15:33:22 weaver Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.6 2012/02/04 23:41:53 weaver Exp $
+
+*tophat-1.4.1 (04 Feb 2012)
+*tophat-1.3.3 (04 Feb 2012)
+
+ 04 Feb 2012; Andrey Kislyuk <weaver@gentoo.org> -tophat-1.3.2.ebuild,
+ +tophat-1.3.3.ebuild, +tophat-1.4.1.ebuild:
+ version bump
+
+ 04 Feb 2012; Andrey Kislyuk <weaver@gentoo.org> tophat-1.3.2.ebuild:
+ filter as-needed
*tophat-1.3.2 (26 Sep 2011)
diff --git a/sci-biology/tophat/tophat-1.3.2.ebuild b/sci-biology/tophat/tophat-1.3.3.ebuild
index ad53ba9f2233..8c1f181f35f9 100644
--- a/sci-biology/tophat/tophat-1.3.2.ebuild
+++ b/sci-biology/tophat/tophat-1.3.3.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.3.2.ebuild,v 1.1 2011/09/26 15:33:22 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.3.3.ebuild,v 1.1 2012/02/04 23:41:53 weaver Exp $
EAPI=4
+inherit flag-o-matic
+
DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
HOMEPAGE="http://tophat.cbcb.umd.edu/"
SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
@@ -19,6 +21,10 @@ RDEPEND="${DEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+}
+
src_configure() {
econf \
$(use_with bam) || die
diff --git a/sci-biology/tophat/tophat-1.4.1.ebuild b/sci-biology/tophat/tophat-1.4.1.ebuild
new file mode 100644
index 000000000000..af728afc0fdf
--- /dev/null
+++ b/sci-biology/tophat/tophat-1.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.4.1.ebuild,v 1.1 2012/02/04 23:41:54 weaver Exp $
+
+EAPI=4
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE="+bam"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="bam? ( sci-biology/samtools )"
+RDEPEND="${DEPEND}
+ sci-biology/bowtie"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with bam) || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS NEWS THANKS
+}