summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-11-23 17:29:15 +0000
committerTorsten Veller <tove@gentoo.org>2011-11-23 17:29:15 +0000
commit860b22d58a1d8c3f7ca5c83770c4c6afd981589c (patch)
tree3c16eccadc3ee94c605a7d79ebf4828c5101c994 /perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.43.0.ebuild
parentRemove mask for removed package app-emacs/rst, bug 384561. (diff)
downloadgentoo-2-860b22d58a1d8c3f7ca5c83770c4c6afd981589c.tar.gz
gentoo-2-860b22d58a1d8c3f7ca5c83770c4c6afd981589c.tar.bz2
gentoo-2-860b22d58a1d8c3f7ca5c83770c4c6afd981589c.zip
[bump] perl-core/Compress-Raw-Zlib-2.43.0
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.43.0.ebuild')
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.43.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.43.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.43.0.ebuild
new file mode 100644
index 000000000000..8b2b7f35342c
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.43.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.43.0.ebuild,v 1.1 2011/11/23 17:29:15 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.043
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=parallel
+
+src_prepare() {
+ perl-module_src_prepare
+
+ cat <<-EOF > "${S}/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = ${EPREFIX}/usr/include
+ LIB = ${EPREFIX}/usr/$(get_libdir)
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+}