summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-26 02:45:40 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-26 02:45:40 +0000
commit4e87c75ba3b0b85c970f6e32293acebb437b8c87 (patch)
treec64cf528affa5bb8433e280cd21c93f1424a9c03 /net-www
parentInitial revision. (diff)
downloadgentoo-2-4e87c75ba3b0b85c970f6e32293acebb437b8c87.tar.gz
gentoo-2-4e87c75ba3b0b85c970f6e32293acebb437b8c87.tar.bz2
gentoo-2-4e87c75ba3b0b85c970f6e32293acebb437b8c87.zip
add utf8 support for google smart bookmark
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon/ChangeLog8
-rw-r--r--net-www/galeon/files/digest-galeon-1.2.7-r11
-rw-r--r--net-www/galeon/files/galeon-1.2.7-google-UTF8.patch39
-rw-r--r--net-www/galeon/galeon-1.2.7-r1.ebuild118
-rw-r--r--net-www/galeon/galeon-1.2.7.ebuild6
5 files changed, 170 insertions, 2 deletions
diff --git a/net-www/galeon/ChangeLog b/net-www/galeon/ChangeLog
index e0f3cfd3b996..c039b864afb5 100644
--- a/net-www/galeon/ChangeLog
+++ b/net-www/galeon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/galeon
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.28 2002/12/24 17:27:06 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.29 2002/12/26 02:45:40 azarah Exp $
+
+*galeon-1.2.7-r1 (26 Dec 2002)
+
+ 26 Dec 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Add UTF8 support to the google smart bookmarks. Note that
+ it will probibly only work for a newly created bookmark ...
24 Dec 2002; Mark Guertin <gerk@gentoo.org> galeon-1.2.7.ebuild :
Added ~ppc to keywords
diff --git a/net-www/galeon/files/digest-galeon-1.2.7-r1 b/net-www/galeon/files/digest-galeon-1.2.7-r1
new file mode 100644
index 000000000000..99045e50a579
--- /dev/null
+++ b/net-www/galeon/files/digest-galeon-1.2.7-r1
@@ -0,0 +1 @@
+MD5 2408b7e6b1a2a2655f6720b41a391f4b galeon-1.2.7.tar.gz 4054986
diff --git a/net-www/galeon/files/galeon-1.2.7-google-UTF8.patch b/net-www/galeon/files/galeon-1.2.7-google-UTF8.patch
new file mode 100644
index 000000000000..1a09d0436197
--- /dev/null
+++ b/net-www/galeon/files/galeon-1.2.7-google-UTF8.patch
@@ -0,0 +1,39 @@
+--- galeon-1.2.7/src/mozilla_prefs.c.orig 2002-12-26 04:05:23.000000000 +0200
++++ galeon-1.2.7/src/mozilla_prefs.c 2002-12-26 04:06:39.000000000 +0200
+@@ -54,7 +54,7 @@
+ FALSE);
+
+ /* set default search engine */
+- mozilla_preference_set ("keyword.URL",_("http://www.google.com/search?q="));
++ mozilla_preference_set ("keyword.URL",_("http://www.google.com/search?ie=UTF-8&oe=UTF-8&q="));
+ mozilla_preference_set_boolean ("keyword.enabled", TRUE);
+ mozilla_preference_set_boolean ("security.checkloaduri", FALSE);
+
+--- galeon-1.2.7/src/newuser_callbacks.c.orig 2002-12-26 04:05:31.000000000 +0200
++++ galeon-1.2.7/src/newuser_callbacks.c 2002-12-26 04:08:04.000000000 +0200
+@@ -230,14 +230,14 @@
+ * the google homepage I think -- MattA) */
+ add_smart (toolbar, "Google", "google",
+ "http://www.google.com",
+- _("http://www.google.com/search?q=%s"),
++ _("http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=%s"),
+ SHARE_DIR "/google.png", NULL);
+ }
+ if (google_groups_checked)
+ {
+ add_smart (toolbar, "Usenet", "news",
+ "http://groups.google.com",
+- "http://groups.google.com/groups?q=%s"
++ "http://groups.google.com/groups?ie=UTF-8&oe=UTF-8&q=%s"
+ "&meta=site%3Dgroups",
+ SHARE_DIR "/google_groups.png", NULL);
+ }
+@@ -245,7 +245,7 @@
+ {
+ add_smart (toolbar, "Images", "img",
+ "http://images.google.com",
+- "http://images.google.com/images?q=%s",
++ "http://images.google.com/images?ie=UTF-8&oe=UTF-8&q=%s",
+ SHARE_DIR "/google_images.png", NULL);
+ }
+ if (dictionary_checked)
diff --git a/net-www/galeon/galeon-1.2.7-r1.ebuild b/net-www/galeon/galeon-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..337971d0e301
--- /dev/null
+++ b/net-www/galeon/galeon-1.2.7-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.7-r1.ebuild,v 1.1 2002/12/26 02:45:40 azarah Exp $
+
+IUSE="nls"
+
+inherit eutils libtool
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://galeon.sourceforge.net"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha"
+SLOT="0"
+
+RDEPEND="=net-www/mozilla-1.2*
+ >=gnome-base/gnome-libs-1.4.1.4
+ <=gnome-base/libglade-0.99.0
+ =gnome-base/gnome-vfs-1.0*
+ =gnome-base/gconf-1.0*
+ >=gnome-base/oaf-0.6.10
+ >=dev-libs/libxml-1.8.17
+ >=media-libs/gdk-pixbuf-0.18.0
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.17 )"
+ # bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper"
+
+pkg_setup() {
+
+ if [ ! -f ${ROOT}/usr/lib/mozilla/components/libwidget_gtk.so ]
+ then
+ eerror
+ eerror "It seems that your Mozilla was not compiled against gtk+-1.2,"
+ eerror "but rather gtk+-2.0. As Galeon does not support this setup yet,"
+ eerror "you will have to remerge Mozilla with gtk+-1.2 support. This"
+ eerror "can be done by taking \"gtk2\" out of your USE flags:"
+ eerror
+ eerror " # USE="-gtk2" emerge mozilla "
+ eerror
+ die "Need Mozilla compiled with gtk+-1.2!!"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Add UTF8 support to the google smart bookmarks. Note that
+ # it will probibly only work for a newly created bookmark ...
+ # <azarah@gentoo.org> (26 Dec 2002)
+ cd ${S}; epatch ${FILESDIR}/${P}-google-UTF8.patch
+}
+
+src_compile() {
+
+ elibtoolize
+
+ local myconf=""
+
+ use nls || myconf="${myconf} --disable-nls"
+ # use bonobo && myconf="${myconf} --enable-gnome-file-selector"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-mozilla-libs=${MOZILLA_FIVE_HOME} \
+ --with-mozilla-includes=${MOZILLA_FIVE_HOME}/include \
+ --without-debug --disable-werror \
+ --disable-applet \
+ --disable-werror \
+ --disable-install-schemas \
+ --enable-nautilus-view=no \
+ --with-mozilla-snapshot=1.2 \
+ ${myconf} || die
+
+ emake || make || die
+}
+
+src_install() {
+
+ # galeon-config-tool was rewritten for 1.2.0 and causes sandbox
+ # violations if gconfd is shut down... The schemas seem to install
+ # fine without it (at least it seems like it... *sigh*)
+ #gconftool --shutdown
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING* FAQ NEWS README TODO THANKS
+}
+
+pkg_postinst() {
+
+ galeon-config-tool --fix-gconf-permissions
+ galeon-config-tool --pkg-install-schemas
+ scrollkeeper-update
+
+ if [ -z "`use gnome`" ]
+ then
+ einfo "Please make sure libglade was built with gnome support, or"
+ einfo "else galeon will not be able to start up."
+ einfo
+ einfo 'To do this, type: '
+ einfo 'USE="gnome" emerge libglade'
+ fi
+}
+
diff --git a/net-www/galeon/galeon-1.2.7.ebuild b/net-www/galeon/galeon-1.2.7.ebuild
index e896048a7aa7..4c323368c995 100644
--- a/net-www/galeon/galeon-1.2.7.ebuild
+++ b/net-www/galeon/galeon-1.2.7.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.7.ebuild,v 1.6 2002/12/24 17:27:06 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.7.ebuild,v 1.7 2002/12/26 02:45:40 azarah Exp $
IUSE="nls"
+inherit libtool
+
S="${WORKDIR}/${P}"
DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz
@@ -47,6 +49,8 @@ pkg_setup() {
src_compile() {
+ elibtoolize
+
local myconf=""
use nls || myconf="${myconf} --disable-nls"