summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-24 19:10:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-24 19:10:40 +0000
commitddb73075fa6c7372bd5619bdd39d36ee5d0b9c82 (patch)
tree53a86f970147f271778ace50e1c06d5323fe98e4 /net-proxy/squidclamav
parentRestore ebuild that shouldn't have been deleted. (diff)
downloadgentoo-2-ddb73075fa6c7372bd5619bdd39d36ee5d0b9c82.tar.gz
gentoo-2-ddb73075fa6c7372bd5619bdd39d36ee5d0b9c82.tar.bz2
gentoo-2-ddb73075fa6c7372bd5619bdd39d36ee5d0b9c82.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/squidclamav')
-rw-r--r--net-proxy/squidclamav/ChangeLog8
-rw-r--r--net-proxy/squidclamav/squidclamav-6.7.ebuild63
2 files changed, 69 insertions, 2 deletions
diff --git a/net-proxy/squidclamav/ChangeLog b/net-proxy/squidclamav/ChangeLog
index fca1371f90b0..323a8876d39d 100644
--- a/net-proxy/squidclamav/ChangeLog
+++ b/net-proxy/squidclamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/squidclamav
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.21 2012/05/29 06:02:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.22 2012/07/24 19:10:40 flameeyes Exp $
+
+*squidclamav-6.7 (24 Jul 2012)
+
+ 24 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +squidclamav-6.7.ebuild:
+ Version bump.
*squidclamav-6.6 (29 May 2012)
@@ -107,4 +112,3 @@
+files/squidclamav-3.0-gentoo.patch, +metadata.xml,
+squidclamav-3.0.ebuild:
Initial import from bug #138855, thanks to Cedric Krier <ced@ced.homedns.org>.
-
diff --git a/net-proxy/squidclamav/squidclamav-6.7.ebuild b/net-proxy/squidclamav/squidclamav-6.7.ebuild
new file mode 100644
index 000000000000..ad0e5125844e
--- /dev/null
+++ b/net-proxy/squidclamav/squidclamav-6.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/squidclamav-6.7.ebuild,v 1.1 2012/07/24 19:10:40 flameeyes Exp $
+
+EAPI=4
+
+inherit libtool autotools
+
+DESCRIPTION="HTTP Antivirus for Squid based on ClamAv and ICAP"
+HOMEPAGE="http://squidclamav.darold.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-proxy/c-icap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # version 6.3 causes maintainer-mode rebuild from tarball, and
+ # contains acinclude.m4 with libtool macros which cause trouble.
+ rm acinclude.m4 || die
+ eautoreconf
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+
+ # delete its own documentation installed
+ rm -r "${D}"/usr/share/${PN} || die
+
+ dodoc README AUTHORS ChangeLog
+
+ # Fix configuration file to adapt to the Gentoo configuration
+ sed -i \
+ -e '/clamd_local/s:\.ctl:.sock:' \
+ "${D}"/etc/squidclamav.conf || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 6, Squid Clamav is now a module for the c-icap"
+ elog "server, which is called from squid, rather than being a redirector"
+ elog "directly."
+ elog ""
+ elog "To enable the service, you should add this to your c-icap.conf file:"
+ elog ""
+ elog " Service clamav squidclamav.so"
+ elog ""
+ elog "And then this to squid.conf (for a local ICAP server):"
+ elog ""
+ elog " icap_enable on"
+ elog ""
+ elog " # not strictly needed, but useful for special access"
+ elog " icap_send_client_ip on"
+ elog " icap_send_client_username on"
+ elog ""
+ elog " icap_service clamav respmod_precache bypass=0 icap://localhost:1344/clamav"
+ elog " adaptation_access clamav allow all"
+}