summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-15 19:45:57 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-15 19:45:57 +0000
commitaa18f78fb92a18da8a66c132ee8994fbf9cc6063 (patch)
tree1a54b8fc2d1c0bdfc8b5a6cc02fa1e20f127761c /net-p2p
parentDo much LeechCraft maintainance, including bump to 0.4.96 (diff)
downloadgentoo-2-aa18f78fb92a18da8a66c132ee8994fbf9cc6063.tar.gz
gentoo-2-aa18f78fb92a18da8a66c132ee8994fbf9cc6063.tar.bz2
gentoo-2-aa18f78fb92a18da8a66c132ee8994fbf9cc6063.zip
Do much LeechCraft maintainance, including bump to 0.4.96
(Portage version: 2.1.10.40/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/ChangeLog8
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.96.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
index 2480063b953f..e5dfc45f399b 100644
--- a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
+++ b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/leechcraft-eiskaltdcpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.2 2011/10/11 16:20:18 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.3 2011/12/15 19:45:57 maksbotan Exp $
+
+*leechcraft-eiskaltdcpp-0.4.96 (15 Dec 2011)
+
+ 15 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-eiskaltdcpp-0.4.96.ebuild:
+ Bump net-p2p/leechcraft-eiskaltdcpp to 0.4.96, thanks to 0xd34df00d
11 Oct 2011; Maxim Koltsov <maksbotan@gentoo.org>
leechcraft-eiskaltdcpp-0.4.85.ebuild, leechcraft-eiskaltdcpp-0.4.90.ebuild,
diff --git a/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.96.ebuild b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.96.ebuild
new file mode 100644
index 000000000000..ee39c8570f66
--- /dev/null
+++ b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.96.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.4.96.ebuild,v 1.1 2011/12/15 19:45:57 maksbotan Exp $
+
+EAPI="2"
+
+inherit leechcraft
+
+DESCRIPTION="EiskaltDC++ ported to LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +emoticons examples javascript lua pcre spell sqlite upnp"
+
+RDEPEND="=net-misc/leechcraft-core-${PV}
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/openssl-0.9.8
+ virtual/libiconv
+ sys-devel/gettext
+ lua? ( >=dev-lang/lua-5.1 )
+ upnp? ( net-libs/miniupnpc )
+ javascript? (
+ x11-libs/qt-script
+ x11-libs/qtscriptgenerator
+ )
+ spell? ( app-text/aspell )
+ sqlite? ( x11-libs/qt-sql:4[sqlite] )
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ virtual/leechcraft-task-show
+ !!net-p2p/eiskaltdcpp"
+DEPEND="=net-misc/leechcraft-core-${PV}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use lua LUA_SCRIPT)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use javascript USE_JS)"
+ "$(cmake-utils_use spell USE_ASPELL)"
+ "$(cmake-utils_use sqlite USE_QT_SQLITE)"
+ "$(cmake-utils_use upnp USE_MINIUPNP)"
+ -DLOCAL_MINIUPNP="0"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
+ "$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use pcre PERL_REGEX)"
+ )
+
+ cmake-utils_src_configure
+}