summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-08-25 10:47:05 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-08-25 10:47:05 +0000
commitd63fcdd76057563730b7ed444a0f0a03fdec220a (patch)
treedb4732acd59a2fbb0070cd61c9ed49bec060b6e8 /net-p2p/lince
parentkeyword ~sparc-fbsd (diff)
downloadgentoo-2-d63fcdd76057563730b7ed444a0f0a03fdec220a.tar.gz
gentoo-2-d63fcdd76057563730b7ed444a0f0a03fdec220a.tar.bz2
gentoo-2-d63fcdd76057563730b7ed444a0f0a03fdec220a.zip
Fix dependencies (#235646) and add missing use flags (#235144).
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'net-p2p/lince')
-rw-r--r--net-p2p/lince/ChangeLog8
-rw-r--r--net-p2p/lince/lince-0.99.4.ebuild30
-rw-r--r--net-p2p/lince/lince-1.0_rc1-r1.ebuild (renamed from net-p2p/lince/lince-1.0_rc1.ebuild)28
3 files changed, 26 insertions, 40 deletions
diff --git a/net-p2p/lince/ChangeLog b/net-p2p/lince/ChangeLog
index 993b9ba48ad8..cb84138e2b4e 100644
--- a/net-p2p/lince/ChangeLog
+++ b/net-p2p/lince/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/lince
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/ChangeLog,v 1.12 2008/08/17 16:18:15 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/ChangeLog,v 1.13 2008/08/25 10:47:05 coldwind Exp $
+
+*lince-1.0_rc1-r1 (25 Aug 2008)
+
+ 25 Aug 2008; Santiago M. Mola <coldwind@gentoo.org> metadata.xml,
+ -lince-0.99.4.ebuild, -lince-1.0_rc1.ebuild, +lince-1.0_rc1-r1.ebuild:
+ Fix dependencies (#235646) and add missing use flags (#235144).
*lince-1.0_rc1 (17 Aug 2008)
diff --git a/net-p2p/lince/lince-0.99.4.ebuild b/net-p2p/lince/lince-0.99.4.ebuild
deleted file mode 100644
index 030d1c759592..000000000000
--- a/net-p2p/lince/lince-0.99.4.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/lince-0.99.4.ebuild,v 1.2 2008/06/19 14:21:51 coldwind Exp $
-
-EAPI="1"
-
-MY_P="Lince-${PV}"
-
-DESCRIPTION="a light, powerfull and full feature gtkmm bittorrent client"
-SRC_URI="mirror://sourceforge/lincetorrent/${MY_P}.tar.gz"
-HOMEPAGE="http://lincetorrent.sourceforge.net"
-
-RDEPEND="dev-cpp/gtkmm:2.4
- x11-libs/cairo
- >=net-libs/rb_libtorrent-0.13
- dev-libs/libxml2
- sys-devel/gettext"
-DEPEND="${RDEPEND}
- dev-util/intltool"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-
-src_install () {
- emake DESTDIR="${D}" install || die
-}
diff --git a/net-p2p/lince/lince-1.0_rc1.ebuild b/net-p2p/lince/lince-1.0_rc1-r1.ebuild
index fd92c3081eeb..b691e3a09373 100644
--- a/net-p2p/lince/lince-1.0_rc1.ebuild
+++ b/net-p2p/lince/lince-1.0_rc1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/lince-1.0_rc1.ebuild,v 1.1 2008/08/17 16:18:15 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lince/lince-1.0_rc1-r1.ebuild,v 1.1 2008/08/25 10:47:05 coldwind Exp $
EAPI="1"
@@ -11,21 +11,31 @@ DESCRIPTION="a light, powerfull and full feature gtkmm bittorrent client"
SRC_URI="mirror://sourceforge/lincetorrent/${MY_P}.tar.gz"
HOMEPAGE="http://lincetorrent.sourceforge.net"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dbus libnotify"
+
RDEPEND="dev-cpp/gtkmm:2.4
- x11-libs/cairo
+ dev-cpp/cairomm
+ >=dev-cpp/glibmm-2.16
>=net-libs/rb_libtorrent-0.13
dev-libs/libxml2
- sys-devel/gettext"
+ sys-devel/gettext
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )"
DEPEND="${RDEPEND}
dev-util/intltool"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
S=${WORKDIR}/${MY_P}
+src_compile() {
+ econf \
+ $(use_with dbus) \
+ $(use_with libnotify) || die "econf failed"
+ emake || die "emake failed"
+}
+
src_install () {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
}