summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-04-25 16:29:30 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-04-25 16:29:30 +0000
commit12f1052fd6d45114cae50ed810445c359887c2dd (patch)
tree7bc6ec4903d2c763cb018eb34f242115429c89fb /net-nntp/pan
parentKeyworded ~amd64 (diff)
downloadgentoo-2-12f1052fd6d45114cae50ed810445c359887c2dd.tar.gz
gentoo-2-12f1052fd6d45114cae50ed810445c359887c2dd.tar.bz2
gentoo-2-12f1052fd6d45114cae50ed810445c359887c2dd.zip
Fix for building with gcc4.
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'net-nntp/pan')
-rw-r--r--net-nntp/pan/ChangeLog6
-rw-r--r--net-nntp/pan/files/pan-0.14.2.91-gcc4.patch23
-rw-r--r--net-nntp/pan/pan-0.14.2.91.ebuild7
3 files changed, 33 insertions, 3 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index 1755bb709b9a..49e14d2d7be6 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/pan
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.3 2005/02/06 17:40:23 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.4 2005/04/25 16:29:30 azarah Exp $
+
+ 25 Apr 2005; Martin Schlemmer <azarah@gentoo.org>
+ +files/pan-0.14.2.91-gcc4.patch, pan-0.14.2.91.ebuild:
+ Fix for building with gcc4.
06 Feb 2005; Markus Rothe <corsair@gentoo.org> pan-0.14.2.91.ebuild:
Stable on ppc64
diff --git a/net-nntp/pan/files/pan-0.14.2.91-gcc4.patch b/net-nntp/pan/files/pan-0.14.2.91-gcc4.patch
new file mode 100644
index 000000000000..519019568442
--- /dev/null
+++ b/net-nntp/pan/files/pan-0.14.2.91-gcc4.patch
@@ -0,0 +1,23 @@
+--- pan-0.14.2.91/pan/base/msort.c.orig 2005-04-25 15:54:31.000000000 +0000
++++ pan-0.14.2.91/pan/base/msort.c 2005-04-25 15:59:21.000000000 +0000
+@@ -65,14 +65,16 @@
+ if ((*cmp) (b1, b2) <= 0)
+ {
+ --n1;
+- *((unsigned long int *) tmp)++ =
+- *((unsigned long int *) b1)++;
++ *tmp = *b1;
++ tmp++;
++ b1++;
+ }
+ else
+ {
+ --n2;
+- *((unsigned long int *) tmp)++ =
+- *((unsigned long int *) b2)++;
++ *tmp = *b2;
++ tmp++;
++ b1++;
+ }
+ }
+ else
diff --git a/net-nntp/pan/pan-0.14.2.91.ebuild b/net-nntp/pan/pan-0.14.2.91.ebuild
index a76306ed0a82..a2437fb821ee 100644
--- a/net-nntp/pan/pan-0.14.2.91.ebuild
+++ b/net-nntp/pan/pan-0.14.2.91.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.14.2.91.ebuild,v 1.2 2005/02/06 17:40:23 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.14.2.91.ebuild,v 1.3 2005/04/25 16:29:30 azarah Exp $
-inherit libtool
+inherit eutils libtool
IUSE="nls spell"
@@ -40,6 +40,9 @@ src_unpack() {
unpack ${A}
cd ${S}
+ # Fix for building with gcc4
+ epatch ${FILESDIR}/${P}-gcc4.patch
+
elibtoolize || die "elibtoolize failed"
}