summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-10-10 06:30:42 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-10-10 06:30:42 +0000
commit44570c777bb6174effee5c759dc477a775722ffb (patch)
treed9651e7112d2c21e952420e22d6bee552d681e47 /net-misc/quagga
parentdev-lang/idb: Bump to correct version, thanks Arfrever for pinging me (diff)
downloadgentoo-2-44570c777bb6174effee5c759dc477a775722ffb.tar.gz
gentoo-2-44570c777bb6174effee5c759dc477a775722ffb.tar.bz2
gentoo-2-44570c777bb6174effee5c759dc477a775722ffb.zip
Security cleanup wrt bug #475706
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-misc/quagga')
-rw-r--r--net-misc/quagga/ChangeLog9
-rw-r--r--net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch136
-rw-r--r--net-misc/quagga/files/quagga-link-libcap.patch24
-rw-r--r--net-misc/quagga/files/quagga-services.init.253
-rw-r--r--net-misc/quagga/files/zebra.init.355
-rw-r--r--net-misc/quagga/quagga-0.99.20-r1.ebuild124
-rw-r--r--net-misc/quagga/quagga-0.99.20.ebuild125
-rw-r--r--net-misc/quagga/quagga-0.99.21.ebuild124
-rw-r--r--net-misc/quagga/quagga-0.99.22.1.ebuild111
-rw-r--r--net-misc/quagga/quagga-0.99.22.ebuild118
10 files changed, 8 insertions, 871 deletions
diff --git a/net-misc/quagga/ChangeLog b/net-misc/quagga/ChangeLog
index 0710ad9c8fb2..c8013f1e8512 100644
--- a/net-misc/quagga/ChangeLog
+++ b/net-misc/quagga/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/quagga
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/ChangeLog,v 1.163 2013/10/09 17:10:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/ChangeLog,v 1.164 2013/10/10 06:30:42 pinkbyte Exp $
+
+ 10 Oct 2013; Sergey Popov <pinkbyte@gentoo.org> -quagga-0.99.20.ebuild,
+ -quagga-0.99.20-r1.ebuild, -quagga-0.99.21.ebuild,
+ -files/quagga-0.99.21-fix-no-ipv6.patch, -quagga-0.99.22.ebuild,
+ -quagga-0.99.22.1.ebuild, -files/quagga-link-libcap.patch,
+ -files/quagga-services.init.2, -files/zebra.init.3:
+ Security cleanup wrt bug #475706
09 Oct 2013; Agostino Sarubbo <ago@gentoo.org> quagga-0.99.22.4.ebuild:
Stable for sparc, wrt bug #475706
diff --git a/net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch b/net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch
deleted file mode 100644
index ad476652058b..000000000000
--- a/net-misc/quagga/files/quagga-0.99.21-fix-no-ipv6.patch
+++ /dev/null
@@ -1,136 +0,0 @@
-Fix building with no IPv6 support
-https://dev.openwrt.org/changeset/32697
-
-Index: quagga-0.99.21/zebra/main.c
-===================================================================
---- quagga-0.99.21.orig/zebra/main.c
-+++ quagga-0.99.21/zebra/main.c
-@@ -327,7 +327,9 @@ main (int argc, char **argv)
- zebra_vty_init ();
- access_list_init ();
- prefix_list_init ();
-+#ifdef RTADV
- rtadv_init ();
-+#endif
- #ifdef HAVE_IRDP
- irdp_init();
- #endif
-Index: quagga-0.99.21/zebra/rtadv.h
-===================================================================
---- quagga-0.99.21.orig/zebra/rtadv.h
-+++ quagga-0.99.21/zebra/rtadv.h
-@@ -26,6 +26,9 @@
- #include "vty.h"
- #include "zebra/interface.h"
-
-+/* NB: RTADV is defined in zebra/interface.h above */
-+#ifdef RTADV
-+
- /* Router advertisement prefix. */
- struct rtadv_prefix
- {
-@@ -96,4 +99,6 @@ struct nd_opt_homeagent_info { /* Home
-
- extern const char *rtadv_pref_strs[];
-
-+#endif /* RTADV */
-+
- #endif /* _ZEBRA_RTADV_H */
-Index: quagga-0.99.21/zebra/zebra_vty.c
-===================================================================
---- quagga-0.99.21.orig/zebra/zebra_vty.c
-+++ quagga-0.99.21/zebra/zebra_vty.c
-@@ -1197,6 +1197,40 @@ DEFUN (show_ip_protocol,
- return CMD_SUCCESS;
- }
-
-+/*
-+ * Show IP mroute command to dump the BGP Multicast
-+ * routing table
-+ */
-+DEFUN (show_ip_mroute,
-+ show_ip_mroute_cmd,
-+ "show ip mroute",
-+ SHOW_STR
-+ IP_STR
-+ "IP Multicast routing table\n")
-+{
-+ struct route_table *table;
-+ struct route_node *rn;
-+ struct rib *rib;
-+ int first = 1;
-+
-+ table = vrf_table (AFI_IP, SAFI_MULTICAST, 0);
-+ if (! table)
-+ return CMD_SUCCESS;
-+
-+ /* Show all IPv4 routes. */
-+ for (rn = route_top (table); rn; rn = route_next (rn))
-+ for (rib = rn->info; rib; rib = rib->next)
-+ {
-+ if (first)
-+ {
-+ vty_out (vty, SHOW_ROUTE_V4_HEADER);
-+ first = 0;
-+ }
-+ vty_show_ip_route (vty, rn, rib);
-+ }
-+ return CMD_SUCCESS;
-+}
-+
-
- #ifdef HAVE_IPV6
- /* General fucntion for IPv6 static route. */
-@@ -1952,40 +1986,6 @@ DEFUN (show_ipv6_route_summary,
- }
-
- /*
-- * Show IP mroute command to dump the BGP Multicast
-- * routing table
-- */
--DEFUN (show_ip_mroute,
-- show_ip_mroute_cmd,
-- "show ip mroute",
-- SHOW_STR
-- IP_STR
-- "IP Multicast routing table\n")
--{
-- struct route_table *table;
-- struct route_node *rn;
-- struct rib *rib;
-- int first = 1;
--
-- table = vrf_table (AFI_IP, SAFI_MULTICAST, 0);
-- if (! table)
-- return CMD_SUCCESS;
--
-- /* Show all IPv4 routes. */
-- for (rn = route_top (table); rn; rn = route_next (rn))
-- for (rib = rn->info; rib; rib = rib->next)
-- {
-- if (first)
-- {
-- vty_out (vty, SHOW_ROUTE_V4_HEADER);
-- first = 0;
-- }
-- vty_show_ip_route (vty, rn, rib);
-- }
-- return CMD_SUCCESS;
--}
--
--/*
- * Show IPv6 mroute command.Used to dump
- * the Multicast routing table.
- */
-@@ -2020,11 +2020,6 @@ DEFUN (show_ipv6_mroute,
- return CMD_SUCCESS;
- }
-
--
--
--
--
--
- /* Write IPv6 static route configuration. */
- static int
- static_config_ipv6 (struct vty *vty)
diff --git a/net-misc/quagga/files/quagga-link-libcap.patch b/net-misc/quagga/files/quagga-link-libcap.patch
deleted file mode 100644
index 7e63c7f2eb79..000000000000
--- a/net-misc/quagga/files/quagga-link-libcap.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Nru quagga-0.99.8.orig/lib/Makefile.am quagga-0.99.8/lib/Makefile.am
---- quagga-0.99.8.orig/lib/Makefile.am 2006-06-27 10:48:16.000000000 +0300
-+++ quagga-0.99.8/lib/Makefile.am 2007-08-13 22:09:10.000000000 +0300
-@@ -18,7 +18,7 @@
-
- libzebra_la_DEPENDENCIES = @LIB_REGEX@
-
--libzebra_la_LIBADD = @LIB_REGEX@
-+libzebra_la_LIBADD = @LIB_REGEX@ @LIBCAP@
-
- pkginclude_HEADERS = \
- buffer.h checksum.h command.h filter.h getopt.h hash.h \
-diff -Nru quagga-0.99.8.orig/zebra/Makefile.am quagga-0.99.8/zebra/Makefile.am
---- quagga-0.99.8.orig/zebra/Makefile.am 2007-05-02 18:28:33.000000000 +0300
-+++ quagga-0.99.8/zebra/Makefile.am 2007-08-13 22:09:10.000000000 +0300
-@@ -36,7 +36,7 @@
- connected.h ioctl.h rib.h rt.h zserv.h redistribute.h debug.h rtadv.h \
- interface.h ipforward.h irdp.h router-id.h kernel_socket.h
-
--zebra_LDADD = $(otherobj) $(LIBCAP) $(LIB_IPV6) ../lib/libzebra.la
-+zebra_LDADD = $(otherobj) ../lib/libzebra.la $(LIBCAP) $(LIB_IPV6)
-
- testzebra_LDADD = $(LIBCAP) $(LIB_IPV6) ../lib/libzebra.la
-
diff --git a/net-misc/quagga/files/quagga-services.init.2 b/net-misc/quagga/files/quagga-services.init.2
deleted file mode 100644
index c05face00458..000000000000
--- a/net-misc/quagga/files/quagga-services.init.2
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/files/quagga-services.init.2,v 1.3 2011/09/27 21:51:34 flameeyes Exp $
-
-: ${CFGFILE:=/etc/quagga/${SVCNAME}.conf}
-
-get_service_config() {
- [ -e "$CFGFILE" ] || return
-
- awk '$1 == "'$1'" { s=$2 } END { print s }' "$CFGFILE"
-}
-
-depend() {
- config "$CFGFILE"
-
- need zebra
-
- [ "$(get_service_config log)" = "syslog" ] && \
- use logger
-}
-
-start() {
- if [ ! -e "${CFGFILE}" ] ; then
- eerror "Before starting ${SVCNAME} you have to configure it, by creating"
- eerror "a ${CFGFILE} file."
- eerror ""
- eerror "A sample file has been installed in `ls /usr/share/doc/quagga-*/samples/${SVCNAME}.conf.sample`"
- return 1
- fi
-
- if [ ! -d /var/run/quagga ] ; then
- mkdir -p /var/run/quagga
- chown quagga:quagga /var/run/quagga
- chmod 0750 /var/run/quagga
- fi
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon \
- --start --exec /usr/sbin/${SVCNAME} \
- --pidfile /var/run/quagga/${SVCNAME}.pid \
- -- -d -f "${CFGFILE}" ${EXTRA_OPTS} \
- --pid_file /var/run/quagga/${SVCNAME}.pid
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop \
- --pidfile /var/run/quagga/${SVCNAME}.pid
- eend $?
-}
diff --git a/net-misc/quagga/files/zebra.init.3 b/net-misc/quagga/files/zebra.init.3
deleted file mode 100644
index b0c6f92f3c40..000000000000
--- a/net-misc/quagga/files/zebra.init.3
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/files/zebra.init.3,v 1.2 2011/09/27 21:50:12 flameeyes Exp $
-
-: ${CFGFILE:=/etc/quagga/${SVCNAME}.conf}
-
-get_service_config() {
- awk '$1 == "'$1'" { s=$2 } END { print s }' "$CFGFILE"
-}
-
-depend() {
- config "$CFGFILE"
-
- need net
-
- [ "$(get_service_config log)" = "syslog" ] && \
- use logger
-}
-
-start() {
- if [ ! -e "${CFGFILE}" ] ; then
- eerror "Before starting ${SVCNAME} you have to configure it, by creating"
- eerror "a ${CFGFILE} file."
- eerror ""
- eerror "A sample file has been installed in `ls /usr/share/doc/quagga-*/samples/${SVCNAME}.conf.sample`"
- return 1
- fi
-
- if [ ! -d /var/run/quagga ] ; then
- mkdir -p /var/run/quagga
- chown quagga:quagga /var/run/quagga
- chmod 0750 /var/run/quagga
- fi
-
- ebegin "Cleaning up stale zebra routes..."
- ip route flush proto zebra
- eend $?
-
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon \
- --start --exec /usr/sbin/${SVCNAME} \
- --pidfile /var/run/quagga/${SVCNAME}.pid \
- -- -d -f "${CFGFILE}" ${EXTRA_OPTS} \
- --pid_file /var/run/quagga/${SVCNAME}.pid
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop \
- --pidfile /var/run/quagga/${SVCNAME}.pid
- eend $?
-}
diff --git a/net-misc/quagga/quagga-0.99.20-r1.ebuild b/net-misc/quagga/quagga-0.99.20-r1.ebuild
deleted file mode 100644
index 0722644e0004..000000000000
--- a/net-misc/quagga/quagga-0.99.20-r1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.99.20-r1.ebuild,v 1.8 2012/12/07 15:58:54 pinkbyte Exp $
-
-EAPI="4"
-
-CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
-
-BACKPORTS=2
-
-inherit eutils multilib autotools pam flag-o-matic user
-
-DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP."
-HOMEPAGE="http://quagga.net/"
-SRC_URI="http://www.quagga.net/download/${P}.tar.gz
- ${BACKPORTS:+
- http://dev.gentoo.org/~flameeyes/${PN}/${P}-backports-${BACKPORTS}.tar.xz}
- bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc s390 sparc x86"
-IUSE="caps doc ipv6 snmp pam bgpclassless ospfapi multipath tcp-zebra elibc_glibc +readline"
-
-COMMON_DEPEND="
- caps? ( sys-libs/libcap )
- snmp? ( net-analyzer/net-snmp )
- readline? (
- sys-libs/readline
- pam? ( sys-libs/pam )
- )
- !elibc_glibc? ( dev-libs/libpcre )"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- >=sys-devel/libtool-2.2.4"
-RDEPEND="${COMMON_DEPEND}
- sys-apps/openrc
- sys-apps/iproute2"
-
-pkg_setup() {
- enewgroup quagga
- enewuser quagga -1 -1 /var/empty quagga
-}
-
-src_prepare() {
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
-
- # Classless prefixes for BGP
- # http://hasso.linux.ee/doku.php/english:network:quagga
- use bgpclassless && epatch "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=
-
- use ospfapi \
- && myconf="${myconf} --enable-opaque-lsa --enable-ospf-te --enable-ospfclient"
-
- use multipath && myconf="${myconf} --enable-multipath=0"
-
- append-flags -fno-strict-aliasing
-
- econf \
- --enable-user=quagga \
- --enable-group=quagga \
- --enable-vty-group=quagga \
- --with-cflags="${CFLAGS}" \
- --sysconfdir=/etc/quagga \
- --enable-exampledir=/usr/share/doc/${PF}/samples \
- --localstatedir=/var/run/quagga \
- --disable-static \
- --disable-pie \
- \
- $(use_enable caps capabilities) \
- $(use_enable snmp) \
- $(use_enable !elibc_glibc pcreposix) \
- $(use_enable tcp-zebra) \
- $(use_enable doc) \
- \
- $(use_enable readline vtysh) \
- $(use_with pam libpam) \
- \
- $(use_enable ipv6) \
- $(use_enable ipv6 ripngd) \
- $(use_enable ipv6 ospf6d) \
- $(use_enable ipv6 rtadv) \
- \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- find "${D}" -name '*.la' -delete || die
-
- keepdir /etc/quagga
- fowners root:quagga /etc/quagga
- fperms 0770 /etc/quagga
-
- # install zebra as a file, symlink the rest
- newinitd "${FILESDIR}"/quagga-services.init.3 zebra
-
- for service in ripd ospfd bgpd $(use ipv6 && echo ripngd ospf6d); do
- dosym zebra /etc/init.d/${service}
- done
-
- use readline && newpamd "${FILESDIR}/quagga.pam" quagga
-}
-
-pkg_postinst() {
- elog "Sample configuration files can be found in /usr/share/doc/${PF}/samples"
- elog "You have to create config files in /etc/quagga before"
- elog "starting one of the daemons."
- elog ""
- elog "You can pass additional options to the daemon by setting the EXTRA_OPTS"
- elog "variable in their respective file in /etc/conf.d"
- elog ""
- elog "Starting from version 0.99.18, quagga no longer supports the realms patch."
- elog "The patch was abandoned upstream and once again didn't apply; it needs a"
- elog "dedicated maintainer, if it is still necessary."
-}
diff --git a/net-misc/quagga/quagga-0.99.20.ebuild b/net-misc/quagga/quagga-0.99.20.ebuild
deleted file mode 100644
index 03d6c8e99f90..000000000000
--- a/net-misc/quagga/quagga-0.99.20.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.99.20.ebuild,v 1.7 2012/12/07 15:58:54 pinkbyte Exp $
-
-EAPI="4"
-
-CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
-
-BACKPORTS=1
-
-inherit eutils multilib autotools pam flag-o-matic user
-
-DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP."
-HOMEPAGE="http://quagga.net/"
-SRC_URI="http://www.quagga.net/download/${P}.tar.gz
- ${BACKPORTS:+
- http://dev.gentoo.org/~flameeyes/${PN}/${P}-backports-${BACKPORTS}.tar.bz2}
- bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc s390 sparc x86"
-IUSE="caps doc ipv6 snmp pam bgpclassless ospfapi multipath tcp-zebra elibc_glibc +readline"
-
-COMMON_DEPEND="
- caps? ( sys-libs/libcap )
- snmp? ( net-analyzer/net-snmp )
- readline? (
- sys-libs/readline
- pam? ( sys-libs/pam )
- )
- !elibc_glibc? ( dev-libs/libpcre )"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/libtool-2.2.4"
-RDEPEND="${COMMON_DEPEND}
- sys-apps/openrc
- sys-apps/iproute2"
-
-pkg_setup() {
- enewgroup quagga
- enewuser quagga -1 -1 /var/empty quagga
-}
-
-src_prepare() {
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
-
- # Classless prefixes for BGP
- # http://hasso.linux.ee/doku.php/english:network:quagga
- use bgpclassless && epatch "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=
-
- use ospfapi \
- && myconf="${myconf} --enable-opaque-lsa --enable-ospf-te --enable-ospfclient"
-
- use multipath && myconf="${myconf} --enable-multipath=0"
-
- append-flags -fno-strict-aliasing
-
- econf \
- --enable-user=quagga \
- --enable-group=quagga \
- --enable-vty-group=quagga \
- --with-cflags="${CFLAGS}" \
- --sysconfdir=/etc/quagga \
- --enable-exampledir=/usr/share/doc/${PF}/samples \
- --localstatedir=/var/run/quagga \
- --disable-static \
- --disable-pie \
- \
- $(use_enable caps capabilities) \
- $(use_enable snmp) \
- $(use_enable !elibc_glibc pcreposix) \
- $(use_enable tcp-zebra) \
- $(use_enable doc) \
- \
- $(use_enable readline vtysh) \
- $(use_with pam libpam) \
- \
- $(use_enable ipv6) \
- $(use_enable ipv6 ripngd) \
- $(use_enable ipv6 ospf6d) \
- $(use_enable ipv6 rtadv) \
- \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- find "${D}" -name '*.la' -delete || die
-
- keepdir /etc/quagga
- fowners root:quagga /etc/quagga
- fperms 0770 /etc/quagga
-
- newinitd "${FILESDIR}"/zebra.init.3 zebra
-
- # install ripd as a file, symlink the rest
- newinitd "${FILESDIR}"/quagga-services.init.2 ripd
-
- for service in ospfd bgpd $(use ipv6 && echo ripngd ospf6d); do
- dosym ripd /etc/init.d/${service}
- done
-
- use readline && newpamd "${FILESDIR}/quagga.pam" quagga
-}
-
-pkg_postinst() {
- elog "Sample configuration files can be found in /usr/share/doc/${PF}/samples"
- elog "You have to create config files in /etc/quagga before"
- elog "starting one of the daemons."
- elog ""
- elog "You can pass additional options to the daemon by setting the EXTRA_OPTS"
- elog "variable in their respective file in /etc/conf.d"
- elog ""
- elog "Starting from version 0.99.18, quagga no longer supports the realms patch."
- elog "The patch was abandoned upstream and once again didn't apply; it needs a"
- elog "dedicated maintainer, if it is still necessary."
-}
diff --git a/net-misc/quagga/quagga-0.99.21.ebuild b/net-misc/quagga/quagga-0.99.21.ebuild
deleted file mode 100644
index 4ec9fc6606c7..000000000000
--- a/net-misc/quagga/quagga-0.99.21.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.99.21.ebuild,v 1.9 2012/12/22 15:20:38 ago Exp $
-
-EAPI="4"
-
-CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
-#BACKPORTS=2
-
-AUTOTOOLS_AUTORECONF=1
-inherit eutils autotools-utils multilib flag-o-matic pam user
-
-DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP"
-HOMEPAGE="http://quagga.net/"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz
- ${BACKPORTS:+
- http://dev.gentoo.org/~flameeyes/${PN}/${P}-backports-${BACKPORTS}.tar.xz}
- bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc s390 sparc x86"
-IUSE="bgpclassless caps doc elibc_glibc ipv6 multipath ospfapi pam +readline snmp tcp-zebra"
-
-COMMON_DEPEND="
- caps? ( sys-libs/libcap )
- snmp? ( net-analyzer/net-snmp )
- readline? (
- sys-libs/readline
- pam? ( sys-libs/pam )
- )
- !elibc_glibc? ( dev-libs/libpcre )"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- >=sys-devel/libtool-2.2.4"
-RDEPEND="${COMMON_DEPEND}
- sys-apps/openrc
- sys-apps/iproute2"
-
-pkg_setup() {
- enewgroup quagga
- enewuser quagga -1 -1 /var/empty quagga
-}
-
-src_prepare() {
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
-
- # bug #446289
- epatch "${FILESDIR}/${P}-fix-no-ipv6.patch"
-
- # bug #446346
- epatch "${FILESDIR}/${PN}-link-libcap.patch"
-
- # Classless prefixes for BGP
- # http://hasso.linux.ee/doku.php/english:network:quagga
- use bgpclassless && epatch "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- local myeconfargs=(
- --enable-user=quagga
- --enable-group=quagga
- --enable-vty-group=quagga
- --with-cflags="${CFLAGS}"
- --sysconfdir=/etc/quagga
- --enable-exampledir=/usr/share/doc/${PF}/samples
- --localstatedir=/var/run/quagga
- --disable-static
- --disable-pie
- --disable-babeld # does not build properly with USE="-ipv6", bug #446289
- $(use_enable caps capabilities)
- $(use_enable snmp)
- $(use_enable !elibc_glibc pcreposix)
- $(use_enable tcp-zebra)
- $(use_enable doc)
- $(usex multipath $(use_enable multipath) '' '=0' '')
- $(usex ospfapi '--enable-opaque-lsa --enable-ospf-te --enable-ospfclient' '' '' '')
- $(use_enable readline vtysh)
- $(use_with pam libpam)
- $(use_enable ipv6)
- $(use_enable ipv6 ripngd)
- $(use_enable ipv6 ospf6d)
- $(use_enable ipv6 rtadv)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- keepdir /etc/quagga
- fowners root:quagga /etc/quagga
- fperms 0770 /etc/quagga
-
- # install zebra as a file, symlink the rest
- newinitd "${FILESDIR}"/quagga-services.init.3 zebra
-
- for service in ripd ospfd bgpd $(use ipv6 && echo ripngd ospf6d); do
- dosym zebra /etc/init.d/${service}
- done
-
- use readline && newpamd "${FILESDIR}/quagga.pam" quagga
-
- insinto /etc/logrotate.d
- newins redhat/quagga.logrotate quagga
-}
-
-pkg_postinst() {
- elog "Sample configuration files can be found in /usr/share/doc/${PF}/samples"
- elog "You have to create config files in /etc/quagga before"
- elog "starting one of the daemons."
- elog ""
- elog "You can pass additional options to the daemon by setting the EXTRA_OPTS"
- elog "variable in their respective file in /etc/conf.d"
- elog ""
- elog "Starting from version 0.99.18, quagga no longer supports the realms patch."
- elog "The patch was abandoned upstream and once again didn't apply; it needs a"
- elog "dedicated maintainer, if it is still necessary."
-}
diff --git a/net-misc/quagga/quagga-0.99.22.1.ebuild b/net-misc/quagga/quagga-0.99.22.1.ebuild
deleted file mode 100644
index 6df3fa07ad64..000000000000
--- a/net-misc/quagga/quagga-0.99.22.1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.99.22.1.ebuild,v 1.9 2013/05/26 07:24:41 ago Exp $
-
-EAPI="5"
-
-CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
-
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils eutils flag-o-matic multilib pam readme.gentoo user
-
-DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP"
-HOMEPAGE="http://quagga.net/"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz
- bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc s390 sparc x86"
-IUSE="bgpclassless caps doc elibc_glibc ipv6 multipath ospfapi pam +readline snmp tcp-zebra"
-
-COMMON_DEPEND="
- caps? ( sys-libs/libcap )
- snmp? ( net-analyzer/net-snmp )
- readline? (
- sys-libs/readline
- pam? ( sys-libs/pam )
- )
- !elibc_glibc? ( dev-libs/libpcre )"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- >=sys-devel/libtool-2.2.4"
-RDEPEND="${COMMON_DEPEND}
- sys-apps/openrc
- sys-apps/iproute2"
-
-DISABLE_AUTOFORMATTING=1
-DOC_CONTENTS="Sample configuration files can be found in /usr/share/doc/${PF}/samples
-You have to create config files in /etc/quagga before
-starting one of the daemons.
-
-You can pass additional options to the daemon by setting the EXTRA_OPTS
-variable in their respective file in /etc/conf.d
-
-Starting from version 0.99.18, quagga no longer supports the realms patch.
-The patch was abandoned upstream and once again didn't apply; it needs a
-dedicated maintainer, if it is still necessary."
-
-pkg_setup() {
- enewgroup quagga
- enewuser quagga -1 -1 /var/empty quagga
-}
-
-src_prepare() {
- # Classless prefixes for BGP
- # http://hasso.linux.ee/doku.php/english:network:quagga
- use bgpclassless && epatch "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- local myeconfargs=(
- --enable-user=quagga
- --enable-group=quagga
- --enable-vty-group=quagga
- --with-cflags="${CFLAGS}"
- --sysconfdir=/etc/quagga
- --enable-exampledir=/usr/share/doc/${PF}/samples
- --localstatedir=/run/quagga
- --disable-static
- --disable-pie
- $(use_enable caps capabilities)
- $(usex snmp '--enable-snmp' '' '' '')
- $(use_enable !elibc_glibc pcreposix)
- $(use_enable tcp-zebra)
- $(use_enable doc)
- $(usex multipath $(use_enable multipath) '' '=0' '')
- $(usex ospfapi '--enable-opaque-lsa --enable-ospf-te --enable-ospfclient' '' '' '')
- $(use_enable readline vtysh)
- $(use_with pam libpam)
- $(use_enable ipv6)
- $(use_enable ipv6 babeld) # babeld does not build properly with USE="-ipv6", bug #446289
- $(use_enable ipv6 ripngd)
- $(use_enable ipv6 ospf6d)
- $(use_enable ipv6 rtadv)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- readme.gentoo_create_doc
-
- keepdir /etc/quagga
- fowners root:quagga /etc/quagga
- fperms 0770 /etc/quagga
-
- # install zebra as a file, symlink the rest
- newinitd "${FILESDIR}"/quagga-services.init.3 zebra
-
- for service in ripd ospfd bgpd $(use ipv6 && echo babeld ripngd ospf6d); do
- dosym zebra /etc/init.d/${service}
- done
-
- use readline && newpamd "${FILESDIR}/quagga.pam" quagga
-
- insinto /etc/logrotate.d
- newins redhat/quagga.logrotate quagga
-}
diff --git a/net-misc/quagga/quagga-0.99.22.ebuild b/net-misc/quagga/quagga-0.99.22.ebuild
deleted file mode 100644
index 06c760a10aa4..000000000000
--- a/net-misc/quagga/quagga-0.99.22.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/quagga/quagga-0.99.22.ebuild,v 1.1 2013/04/02 16:32:48 pinkbyte Exp $
-
-EAPI="5"
-
-CLASSLESS_BGP_PATCH=ht-20040304-classless-bgp.patch
-#BACKPORTS=2
-
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils eutils flag-o-matic multilib pam user
-
-DESCRIPTION="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP"
-HOMEPAGE="http://quagga.net/"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz
- ${BACKPORTS:+
- http://dev.gentoo.org/~flameeyes/${PN}/${P}-backports-${BACKPORTS}.tar.xz}
- bgpclassless? ( http://hasso.linux.ee/stuff/patches/quagga/${CLASSLESS_BGP_PATCH} )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
-IUSE="bgpclassless caps doc elibc_glibc ipv6 multipath ospfapi pam +readline snmp tcp-zebra"
-
-COMMON_DEPEND="
- caps? ( sys-libs/libcap )
- snmp? ( net-analyzer/net-snmp )
- readline? (
- sys-libs/readline
- pam? ( sys-libs/pam )
- )
- !elibc_glibc? ( dev-libs/libpcre )"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- >=sys-devel/libtool-2.2.4"
-RDEPEND="${COMMON_DEPEND}
- sys-apps/openrc
- sys-apps/iproute2"
-
-pkg_setup() {
- enewgroup quagga
- enewuser quagga -1 -1 /var/empty quagga
-}
-
-src_prepare() {
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
-
- # Classless prefixes for BGP
- # http://hasso.linux.ee/doku.php/english:network:quagga
- use bgpclassless && epatch "${DISTDIR}/${CLASSLESS_BGP_PATCH}"
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- local myeconfargs=(
- --enable-user=quagga
- --enable-group=quagga
- --enable-vty-group=quagga
- --with-cflags="${CFLAGS}"
- --sysconfdir=/etc/quagga
- --enable-exampledir=/usr/share/doc/${PF}/samples
- --localstatedir=/var/run/quagga
- --disable-static
- --disable-pie
- $(use_enable caps capabilities)
- $(usex snmp '--enable-snmp' '' '' '')
- $(use_enable !elibc_glibc pcreposix)
- $(use_enable tcp-zebra)
- $(use_enable doc)
- $(usex multipath $(use_enable multipath) '' '=0' '')
- $(usex ospfapi '--enable-opaque-lsa --enable-ospf-te --enable-ospfclient' '' '' '')
- $(use_enable readline vtysh)
- $(use_with pam libpam)
- $(use_enable ipv6)
- $(use_enable ipv6 babeld) # babeld does not build properly with USE="-ipv6", bug #446289
- $(use_enable ipv6 ripngd)
- $(use_enable ipv6 ospf6d)
- $(use_enable ipv6 rtadv)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- keepdir /etc/quagga
- fowners root:quagga /etc/quagga
- fperms 0770 /etc/quagga
-
- # install zebra as a file, symlink the rest
- newinitd "${FILESDIR}"/quagga-services.init.3 zebra
-
- for service in ripd ospfd bgpd $(use ipv6 && echo babeld ripngd ospf6d); do
- dosym zebra /etc/init.d/${service}
- done
-
- use readline && newpamd "${FILESDIR}/quagga.pam" quagga
-
- insinto /etc/logrotate.d
- newins redhat/quagga.logrotate quagga
-}
-
-pkg_postinst() {
- elog "Sample configuration files can be found in /usr/share/doc/${PF}/samples"
- elog "You have to create config files in /etc/quagga before"
- elog "starting one of the daemons."
- elog ""
- elog "You can pass additional options to the daemon by setting the EXTRA_OPTS"
- elog "variable in their respective file in /etc/conf.d"
- elog ""
- elog "Starting from version 0.99.18, quagga no longer supports the realms patch."
- elog "The patch was abandoned upstream and once again didn't apply; it needs a"
- elog "dedicated maintainer, if it is still necessary."
-}