summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-27 12:56:05 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-27 12:56:05 +0000
commit6dbba87855b641f05dad3855eabeca3b5084527c (patch)
treefd79b88f16a040bab62aa9d21ecdd0fe5ea46ea4 /net-misc/hylafaxplus
parentVersion bump (diff)
downloadgentoo-2-6dbba87855b641f05dad3855eabeca3b5084527c.tar.gz
gentoo-2-6dbba87855b641f05dad3855eabeca3b5084527c.tar.bz2
gentoo-2-6dbba87855b641f05dad3855eabeca3b5084527c.zip
Version bump, wrt bug #438600. EAPI 5, respect CC/CXX/AR/RANLIB. Partially respect LDFLAGS. drop broken auto-detection of page format. Add net-dialup herd to metadata
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-misc/hylafaxplus')
-rw-r--r--net-misc/hylafaxplus/ChangeLog10
-rw-r--r--net-misc/hylafaxplus/hylafaxplus-5.5.4.ebuild174
-rw-r--r--net-misc/hylafaxplus/metadata.xml27
3 files changed, 197 insertions, 14 deletions
diff --git a/net-misc/hylafaxplus/ChangeLog b/net-misc/hylafaxplus/ChangeLog
index c212cd87e71f..37e3ea0d1de5 100644
--- a/net-misc/hylafaxplus/ChangeLog
+++ b/net-misc/hylafaxplus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/hylafaxplus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafaxplus/ChangeLog,v 1.5 2013/03/10 01:42:10 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafaxplus/ChangeLog,v 1.6 2013/09/27 12:56:05 pinkbyte Exp $
+
+*hylafaxplus-5.5.4 (27 Sep 2013)
+
+ 27 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> +hylafaxplus-5.5.4.ebuild,
+ metadata.xml:
+ Version bump, wrt bug #438600. EAPI 5, respect CC/CXX/AR/RANLIB. Partially
+ respect LDFLAGS. drop broken auto-detection of page format. Add net-dialup
+ herd to metadata
10 Mar 2013; Christoph Junghans <ottxor@gentoo.org>
hylafaxplus-5.5.1-r1.ebuild, hylafaxplus-5.5.1.ebuild:
diff --git a/net-misc/hylafaxplus/hylafaxplus-5.5.4.ebuild b/net-misc/hylafaxplus/hylafaxplus-5.5.4.ebuild
new file mode 100644
index 000000000000..68f591670558
--- /dev/null
+++ b/net-misc/hylafaxplus/hylafaxplus-5.5.4.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafaxplus/hylafaxplus-5.5.4.ebuild,v 1.1 2013/09/27 12:56:05 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils multilib pam toolchain-funcs
+
+MY_PN="${PN/plus/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enterprise client-server fax package for class 1 and 2 fax modems."
+HOMEPAGE="http://hylafax.sourceforge.net"
+SRC_URI="mirror://sourceforge/hylafax/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="hylafaxplus"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="jbig html ldap mgetty pam"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ app-text/ghostscript-gpl
+ virtual/mta
+ media-libs/tiff[jbig?]
+ virtual/jpeg
+ jbig? ( media-libs/jbigkit )
+ virtual/awk
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam )
+ mgetty? ( net-dialup/mgetty[-fax] )"
+
+RDEPEND="${DEPEND}
+ net-mail/metamail
+ !net-dialup/sendpage"
+
+S="${WORKDIR}/${MY_P}"
+
+export CONFIG_PROTECT="${CONFIG_PROTECT} /var/spool/fax/etc /usr/lib/fax"
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig-patch"
+ # force it not to strip binaries
+ for dir in etc util faxalter faxcover faxd faxmail faxrm faxstat \
+ hfaxd sendfax sendpage ; do
+ sed -i -e "s:-idb:-idb \"nostrip\" -idb:g" \
+ "${dir}"/Makefile.in || die "sed failed"
+ done
+
+ sed -i -e "s:hostname:hostname -f:g" util/{faxrcvd,pollrcvd}.sh.in || die "sed on hostname failed"
+
+ # Respect LDFLAGS(at least partially)
+ sed -i -e "/^LDFLAGS/s/LDOPTS}/LDOPTS} ${LDFLAGS}/" defs.in || die "sed on defs.in failed"
+
+ sed -i -e "s|-fpic|-fPIC|g" \
+ configure || die
+
+ epatch_user
+}
+
+src_configure() {
+ do_configure() {
+ echo ./configure --nointeractive ${1}
+ # eval required for quoting in ${my_conf} to work properly, better way?
+ eval ./configure --nointeractive ${1} || die "./configure failed"
+ }
+ local my_conf="
+ --with-DIR_BIN=/usr/bin
+ --with-DIR_SBIN=/usr/sbin
+ --with-DIR_LIB=/usr/$(get_libdir)
+ --with-DIR_LIBEXEC=/usr/sbin
+ --with-DIR_LIBDATA=/usr/$(get_libdir)/fax
+ --with-DIR_LOCALE=/usr/share/locale
+ --with-DIR_LOCKS=/var/lock
+ --with-DIR_MAN=/usr/share/man
+ --with-DIR_SPOOL=/var/spool/fax
+ --with-DIR_HTML=/usr/share/doc/${P}/html
+ --with-DIR_CGI="${WORKDIR}"
+ --with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax
+ --with-PATH_IMPRIP=\"\"
+ --with-SYSVINIT=no
+ --with-REGEX=yes
+ --with-LIBTIFF=\"-ltiff -ljpeg -lz\"
+ --with-OPTIMIZER=\"${CFLAGS}\"
+ --with-DSO=auto
+ --with-HTML=$(usex html)"
+
+ if use mgetty; then
+ my_conf="${my_conf} \
+ --with-PATH_GETTY=/sbin/mgetty \
+ --with-PATH_EGETTY=/sbin/mgetty \
+ --with-PATH_VGETTY=/usr/sbin/vgetty"
+ else
+ # GETTY defaults to /sbin/agetty
+ my_conf="${my_conf} \
+ --with-PATH_EGETTY=/bin/false \
+ --with-PATH_VGETTY=/bin/false"
+ fi
+
+ #--enable-pam isn't valid
+ use pam || my_conf="${my_conf} $(use_enable pam)"
+ use ldap || my_conf="${my_conf} $(use_enable ldap)"
+ use jbig || my_conf="${my_conf} $(use_enable jbig)"
+
+ tc-export CC CXX AR RANLIB
+
+ do_configure "${my_conf}"
+}
+
+src_compile() {
+ # Parallel building is borked
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/{bin,sbin} /usr/$(get_libdir)/fax /usr/share/man
+ dodir /var/spool /var/spool/recvq /var/spool/fax
+ fowners uucp:uucp /var/spool/fax
+ fperms 0600 /var/spool/fax
+ dodir /usr/share/doc/${P}/samples
+
+ emake DESTDIR="${D}" \
+ BIN="${D}/usr/bin" \
+ SBIN="${D}/usr/sbin" \
+ LIBDIR="${D}/usr/$(get_libdir)" \
+ LIB="${D}/usr/$(get_libdir)" \
+ LIBEXEC="${D}/usr/sbin" \
+ LIBDATA="${D}/usr/$(get_libdir)/fax" \
+ DIR_LOCALE="${D}/usr/share/locale" \
+ MAN="${D}/usr/share/man" \
+ SPOOL="${D}/var/spool/fax" \
+ HTMLDIR="${D}/usr/share/doc/${PF}/html" \
+ install
+
+ keepdir /var/spool/fax/{archive,client,etc,pollq,recvq,tmp}
+ keepdir /var/spool/fax/{status,sendq,log,info,doneq,docq,dev}
+
+ generate_files # in this case, it only generates the env.d entry
+
+ einfo "Adding env.d entry for ${PN}"
+ doenvd "${T}/99${PN}"
+
+ newconfd "${FILESDIR}/${PN}-conf" ${PN}
+ newinitd "${FILESDIR}/${PN}-init" ${PN}
+
+ use pam && pamd_mimic_system ${MY_PN} auth account session
+
+ dodoc CONTRIBUTORS README TODO
+ docinto samples
+}
+
+pkg_postinst() {
+ elog
+ elog "The faxonly USE flag has been removed; since ${PN} does not"
+ elog "require mgetty, and certain fax files conflict, you must build"
+ elog "mgetty without fax support if you wish to use them both. You"
+ elog "may want to add both to package.use so any future updates are"
+ elog "correctly built:"
+ elog
+ elog " net-dialup/mgetty -fax"
+ elog " net-misc/hylafax [-mgetty|mgetty]"
+ elog
+ elog "See the docs and man pages for detailed configuration info."
+ elog
+ elog "Now run faxsetup and (if necessary) faxaddmodem."
+ elog
+}
+
+generate_files() {
+ cat <<-EOF > "${T}/99${PN}"
+ PATH="/var/spool/fax/bin"
+ CONFIG_PROTECT="/var/spool/fax/etc /usr/$(get_libdir)/fax"
+ EOF
+}
diff --git a/net-misc/hylafaxplus/metadata.xml b/net-misc/hylafaxplus/metadata.xml
index 09613957e555..e6c94715cb35 100644
--- a/net-misc/hylafaxplus/metadata.xml
+++ b/net-misc/hylafaxplus/metadata.xml
@@ -1,17 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
-<email>mattm@gentoo.org</email>
-<name>Matthew Marlowe</name>
-</maintainer>
-<longdescription>
-Enterprise client-server fax package for class 1 and 2 fax modems.
-</longdescription>
-<use>
- <flag name='jbig'>JBIG Fax Compression Support</flag>
- <flag name='pam'>hfaxd authentication via PAM</flag>
- <flag name='mgetty'>Receive faxes via serial port connections</flag>
- <flag name='html'>Convert faxes into html email</flag>
-</use>
+ <herd>net-dialup</herd>
+ <maintainer>
+ <email>mattm@gentoo.org</email>
+ <name>Matthew Marlowe</name>
+ </maintainer>
+ <longdescription>
+ Enterprise client-server fax package for class 1 and 2 fax modems.
+ </longdescription>
+ <use>
+ <flag name='jbig'>JBIG Fax Compression Support</flag>
+ <flag name='pam'>hfaxd authentication via PAM</flag>
+ <flag name='mgetty'>Receive faxes via serial port connections</flag>
+ <flag name='html'>Convert faxes into html email</flag>
+ </use>
</pkgmetadata>