summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-01-08 22:14:34 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-01-08 22:14:34 +0000
commitdf1b87833c6837205ec7afd157fb8426cb79ff65 (patch)
treec1da7d2c072e1e33b5ac6fb9c73311f90f4270d7 /net-misc/hylafax
parentDisabled jikes support due to bug #108819. (diff)
downloadgentoo-2-df1b87833c6837205ec7afd157fb8426cb79ff65.tar.gz
gentoo-2-df1b87833c6837205ec7afd157fb8426cb79ff65.tar.bz2
gentoo-2-df1b87833c6837205ec7afd157fb8426cb79ff65.zip
Updated with partial fix for bug 74457
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-misc/hylafax')
-rw-r--r--net-misc/hylafax/ChangeLog7
-rw-r--r--net-misc/hylafax/hylafax-4.2.3-r1.ebuild10
-rw-r--r--net-misc/hylafax/hylafax-4.2.4.ebuild10
3 files changed, 22 insertions, 5 deletions
diff --git a/net-misc/hylafax/ChangeLog b/net-misc/hylafax/ChangeLog
index ca609f89483d..a8fca5f3161e 100644
--- a/net-misc/hylafax/ChangeLog
+++ b/net-misc/hylafax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/hylafax
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.60 2006/01/06 03:02:36 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/ChangeLog,v 1.61 2006/01/08 22:14:34 nerdboy Exp $
+
+ 08 Jan 2006; Steve Arnold <nerdboy@gentoo.org> hylafax-4.2.3-r1.ebuild,
+ hylafax-4.2.4.ebuild:
+ Updated with partial fix for bug 74457; thanks to kerframil for the tests
+ and recommended fix (goes away once it works correctly with SSP).
06 Jan 2006; Steve Arnold <nerdboy@gentoo.org>
-files/configure-gcc-3.4.patch, -files/hylafax-4.2.0-fPIC.patch,
diff --git a/net-misc/hylafax/hylafax-4.2.3-r1.ebuild b/net-misc/hylafax/hylafax-4.2.3-r1.ebuild
index 69b489526d68..ec756d67d695 100644
--- a/net-misc/hylafax/hylafax-4.2.3-r1.ebuild
+++ b/net-misc/hylafax/hylafax-4.2.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.3-r1.ebuild,v 1.2 2006/01/06 03:02:36 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.3-r1.ebuild,v 1.3 2006/01/08 22:14:34 nerdboy Exp $
-inherit eutils multilib pam
+inherit eutils multilib pam flag-o-matic toolchain-funcs
IUSE="faxonly jpeg pam mgetty"
@@ -43,6 +43,12 @@ src_compile() {
eerror "You cannot set both faxonly and mgetty, please remove one." && die "invalid use flags"
fi
fi
+
+ # Hylafax doesn't play nice with gcc-3.4 and SSP (bug #74457)
+ # so drop the flags until a better solution comes along
+ [ $(gcc-major-version) -eq 3 ] && [ $(gcc-minor-version) -ge 4 ] \
+ && filter-flags -fstack-protector -fstack-protector-all
+
local my_conf="
--with-DIR_BIN=/usr/bin
--with-DIR_SBIN=/usr/sbin
diff --git a/net-misc/hylafax/hylafax-4.2.4.ebuild b/net-misc/hylafax/hylafax-4.2.4.ebuild
index 6ef6b3d4c699..7f1ac816cb23 100644
--- a/net-misc/hylafax/hylafax-4.2.4.ebuild
+++ b/net-misc/hylafax/hylafax-4.2.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.4.ebuild,v 1.1 2006/01/05 07:51:49 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.2.4.ebuild,v 1.2 2006/01/08 22:14:34 nerdboy Exp $
-inherit eutils multilib pam
+inherit eutils multilib pam flag-o-matic toolchain-funcs
IUSE="faxonly jpeg pam mgetty"
@@ -35,6 +35,12 @@ src_compile() {
eerror "You cannot set both faxonly and mgetty, please remove one." && die "invalid use flags"
fi
fi
+
+ # Hylafax doesn't play nice with gcc-3.4 and SSP (bug #74457)
+ # so drop the flags until a better solution comes along
+ [ $(gcc-major-version) -eq 3 ] && [ $(gcc-minor-version) -ge 4 ] \
+ && filter-flags -fstack-protector -fstack-protector-all
+
local my_conf="
--with-DIR_BIN=/usr/bin
--with-DIR_SBIN=/usr/sbin