summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2008-12-30 18:04:51 +0000
committerMike Pagano <mpagano@gentoo.org>2008-12-30 18:04:51 +0000
commit948cb72c443e476b60ec76da757a787bd21703c3 (patch)
tree7057ba1f4070460647639fe16be4820042a8bea4 /net-misc/efax
parentVersion bump, fixes rare segfault and password processing error. (diff)
downloadgentoo-2-948cb72c443e476b60ec76da757a787bd21703c3.tar.gz
gentoo-2-948cb72c443e476b60ec76da757a787bd21703c3.tar.bz2
gentoo-2-948cb72c443e476b60ec76da757a787bd21703c3.zip
Respect compiler and cflags as per bug #241062
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'net-misc/efax')
-rw-r--r--net-misc/efax/ChangeLog5
-rw-r--r--net-misc/efax/efax-0.9a-r1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/net-misc/efax/ChangeLog b/net-misc/efax/ChangeLog
index af32b9e08e80..570e5676a925 100644
--- a/net-misc/efax/ChangeLog
+++ b/net-misc/efax/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/efax
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/efax/ChangeLog,v 1.9 2008/12/30 17:30:17 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/efax/ChangeLog,v 1.10 2008/12/30 18:04:51 mpagano Exp $
+
+ 30 Dec 2008; Mike Pagano <mpagano@gentoo.org> efax-0.9a-r1.ebuild:
+ Respect compiler and cflags as per bug #241062
30 Dec 2008; Mike Pagano <mpagano@gentoo.org> efax-0.9a-r1.ebuild:
Removed strip command as per bug #240932
diff --git a/net-misc/efax/efax-0.9a-r1.ebuild b/net-misc/efax/efax-0.9a-r1.ebuild
index 09d20187eb80..12ca6b8f9ba9 100644
--- a/net-misc/efax/efax-0.9a-r1.ebuild
+++ b/net-misc/efax/efax-0.9a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/efax/efax-0.9a-r1.ebuild,v 1.3 2008/12/30 17:30:17 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/efax/efax-0.9a-r1.ebuild,v 1.4 2008/12/30 18:04:51 mpagano Exp $
inherit eutils
@@ -16,13 +16,16 @@ LICENSE="GPL-2"
src_unpack () {
unpack ${A}
cd "${S}"
- sed -i -e "s:CFLAGS=:CFLAGS=${CFLAGS}:" Makefile
epatch "${FILESDIR}/${P}-segfault.patch"
# remove strip command as per bug #240932
sed -i -e '/strip/d' Makefile
}
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die "compilation failed"
+}
+
src_install () {
dobin efax efix fax || die "dobin failed"
doman efax.1 efix.1 fax.1