summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-27 10:56:25 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-27 10:56:25 +0000
commitdfc3b1ccfa44146115312e5f03de3af5b7d8cbea (patch)
treefee40a46ad564ae7dfa3044321955694e14c15a3 /net-libs
parentStable for amd64, wrt bug #543930 (diff)
downloadgentoo-2-dfc3b1ccfa44146115312e5f03de3af5b7d8cbea.tar.gz
gentoo-2-dfc3b1ccfa44146115312e5f03de3af5b7d8cbea.tar.bz2
gentoo-2-dfc3b1ccfa44146115312e5f03de3af5b7d8cbea.zip
Add a live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index f5cb760f76ec..284fa7a2531e 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.105 2015/03/30 15:42:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.106 2015/05/27 10:56:25 mgorny Exp $
+
+*libssh2-9999 (27 May 2015)
+
+ 27 May 2015; Michał Górny <mgorny@gentoo.org> +libssh2-9999.ebuild:
+ Add a live ebuild
30 Mar 2015; Jeroen Roovers <jer@gentoo.org> -libssh2-1.4.3.ebuild,
-libssh2-1.4.3-r1.ebuild:
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
new file mode 100644
index 000000000000..3892f21dd982
--- /dev/null
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-9999.ebuild,v 1.1 2015/05/27 10:56:25 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+EGIT_REPO_URI="https://github.com/libssh2/libssh2"
+inherit autotools-multilib git-r3
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="gcrypt static-libs test zlib"
+
+DEPEND="!gcrypt? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.2-pkgconfig.patch )
+
+src_prepare() {
+ sed -i -e 's|mansyntax.sh||g' tests/Makefile.am || die
+ ln -s ../src/libssh2_config.h.in example/libssh2_config.h.in || die
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ # Disable tests that require extra permissions (bug #333319)
+ use test && local -x ac_cv_path_SSHD=
+
+ local myeconfargs=(
+ $(use_with zlib libz)
+ $(usex gcrypt --with-libgcrypt --with-openssl)
+ )
+ autotools-utils_src_configure
+}