summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-12-27 15:07:30 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-12-27 15:07:30 +0000
commitc0c0ac813362b41f0cd9ab7d77a1450fa3d264fd (patch)
treede3b7ec2c921728ecadc9020ba07bcac44e22072 /net-libs
parentAdd ~x86 keyword, bug 531934 (diff)
downloadgentoo-2-c0c0ac813362b41f0cd9ab7d77a1450fa3d264fd.tar.gz
gentoo-2-c0c0ac813362b41f0cd9ab7d77a1450fa3d264fd.tar.bz2
gentoo-2-c0c0ac813362b41f0cd9ab7d77a1450fa3d264fd.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog8
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.39.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index 6f3e64a35e78..c7123ee57d7e 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.81 2014/12/24 11:53:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.82 2014/12/27 15:07:30 blueness Exp $
+
+*libmicrohttpd-0.9.39 (27 Dec 2014)
+
+ 27 Dec 2014; Anthony G. Basile <blueness@gentoo.org>
+ +libmicrohttpd-0.9.39.ebuild:
+ Version bump
24 Dec 2014; Anthony G. Basile <blueness@gentoo.org>
-libmicrohttpd-0.9.32.ebuild, -libmicrohttpd-0.9.33.ebuild,
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.39.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.39.ebuild
new file mode 100644
index 000000000000..e6ac2f186a96
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.39.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.39.ebuild,v 1.1 2014/12/27 15:07:30 blueness Exp $
+
+EAPI="5"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application"
+HOMEPAGE="http://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="epoll messages ssl static-libs test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0
+ net-libs/gnutls
+ )"
+
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-spdy \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable messages postprocessor) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}