summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-05-10 20:00:28 +0000
committerJeroen Roovers <jer@gentoo.org>2011-05-10 20:00:28 +0000
commit4433637491b34c9eec23641e338f8db6a8060438 (patch)
treea89389985883a10e40ed34a8589b4af102b2648a /net-libs/libssh2
parentAdded ewarn message if libproxy is present (diff)
downloadgentoo-2-4433637491b34c9eec23641e338f8db6a8060438.tar.gz
gentoo-2-4433637491b34c9eec23641e338f8db6a8060438.tar.bz2
gentoo-2-4433637491b34c9eec23641e338f8db6a8060438.zip
Fix "VERSION" in autoconf script thanks to Lars, patch by Stratos Psomadakis (bug #366599).
(Portage version: 2.2.0_alpha32/cvs/Linux i686)
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/ChangeLog9
-rw-r--r--net-libs/libssh2/files/libssh2-1.2.8-version.patch44
-rw-r--r--net-libs/libssh2/libssh2-1.2.8-r1.ebuild (renamed from net-libs/libssh2/libssh2-1.2.8.ebuild)9
3 files changed, 59 insertions, 3 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index ceac6da5c753..29ebf5d66e00 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.36 2011/05/08 20:18:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.37 2011/05/10 20:00:28 jer Exp $
+
+*libssh2-1.2.8-r1 (10 May 2011)
+
+ 10 May 2011; Jeroen Roovers <jer@gentoo.org> -libssh2-1.2.8.ebuild,
+ +libssh2-1.2.8-r1.ebuild, +files/libssh2-1.2.8-version.patch:
+ Fix "VERSION" in autoconf script thanks to Lars, patch by Stratos Psomadakis
+ (bug #366599).
*libssh2-1.2.8 (08 May 2011)
diff --git a/net-libs/libssh2/files/libssh2-1.2.8-version.patch b/net-libs/libssh2/files/libssh2-1.2.8-version.patch
new file mode 100644
index 000000000000..529796c48f12
--- /dev/null
+++ b/net-libs/libssh2/files/libssh2-1.2.8-version.patch
@@ -0,0 +1,44 @@
+diff --git a/configure.ac b/configure.ac
+index 9bdf3b9..46c6cfa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,12 +15,14 @@ if test "x$SED" = "xsed-was-not-found-by-configure"; then
+ fi
+
+ dnl figure out the libssh2 version
+-VERSION=`$SED -ne 's/^#define LIBSSH2_VERSION *"\(.*\)"/\1/p' ${srcdir}/include/libssh2.h`
++LIBSSH2VER=`$SED -ne 's/^#define LIBSSH2_VERSION *"\(.*\)"/\1/p' ${srcdir}/include/libssh2.h`
+ AM_INIT_AUTOMAKE
+ AC_MSG_CHECKING([libssh2 version])
+-AC_MSG_RESULT($VERSION)
++AC_MSG_RESULT($LIBSSH2VER)
+
+-AB_VERSION=$VERSION
++AC_SUBST(LIBSSH2VER)
++
++AB_VERSION=$LIBSSH2VER
+
+ AB_INIT
+
+@@ -289,7 +291,7 @@ AC_OUTPUT
+
+ AC_MSG_NOTICE([summary of build options:
+
+- version: ${VERSION}
++ version: ${LIBSSH2VER}
+ Host type: ${host}
+ Install prefix: ${prefix}
+ Compiler: ${CC}
+diff --git a/libssh2.pc.in b/libssh2.pc.in
+index 013e6bf..eaef88b 100644
+--- a/libssh2.pc.in
++++ b/libssh2.pc.in
+@@ -10,7 +10,7 @@ includedir=@includedir@
+ Name: libssh2
+ URL: http://www.libssh2.org/
+ Description: Library for SSH based connunication
+-Version: @VERSION@
++Version: @LIBSSH2VER@
+ Libs: -L${libdir} -lssh2 @LDFLAGS@ @LIBS@
+ Libs.private: @LIBS@
+ Cflags: -I${includedir}
diff --git a/net-libs/libssh2/libssh2-1.2.8.ebuild b/net-libs/libssh2/libssh2-1.2.8-r1.ebuild
index c5deaa643254..82d80dbb37cf 100644
--- a/net-libs/libssh2/libssh2-1.2.8.ebuild
+++ b/net-libs/libssh2/libssh2-1.2.8-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.2.8.ebuild,v 1.1 2011/05/08 20:18:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.2.8-r1.ebuild,v 1.1 2011/05/10 20:00:28 jer Exp $
EAPI="2"
-inherit autotools-utils
+inherit autotools-utils eutils
DESCRIPTION="Library implementing the SSH2 protocol"
HOMEPAGE="http://www.libssh2.org/"
@@ -20,6 +20,11 @@ DEPEND="!gcrypt? ( dev-libs/openssl )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-version.patch
+ eautoreconf
+}
+
src_configure() {
local myconf