summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-17 05:14:55 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-17 05:14:55 +0000
commit2e22849d68ea7908b3a3c0d7b49b69ccb96ecbce (patch)
tree669df11f64d079ef6dee838fe851c4679a3d74b1 /net-libs/libsoup
parentVersion bump for gnome-3.6, now with optional vala bindings. Update license. ... (diff)
downloadgentoo-2-2e22849d68ea7908b3a3c0d7b49b69ccb96ecbce.tar.gz
gentoo-2-2e22849d68ea7908b3a3c0d7b49b69ccb96ecbce.tar.bz2
gentoo-2-2e22849d68ea7908b3a3c0d7b49b69ccb96ecbce.zip
Version bump for gnome-3.6; libsoup's I/O code has been rewritten and improved. Switch to global introspection flag. Drop old.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-libs/libsoup')
-rw-r--r--net-libs/libsoup/ChangeLog11
-rw-r--r--net-libs/libsoup/files/libsoup-2.36.1-SoupHTTPInputStream-GCancellable.patch102
-rw-r--r--net-libs/libsoup/libsoup-2.36.1-r1.ebuild65
-rw-r--r--net-libs/libsoup/libsoup-2.40.2.ebuild (renamed from net-libs/libsoup/libsoup-2.36.1.ebuild)38
-rw-r--r--net-libs/libsoup/metadata.xml2
5 files changed, 31 insertions, 187 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index 7e174be72a30..ecc73872f98c 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/libsoup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.295 2012/10/28 16:28:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.296 2012/12/17 05:14:55 tetromino Exp $
+
+*libsoup-2.40.2 (17 Dec 2012)
+
+ 17 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -libsoup-2.36.1.ebuild, -libsoup-2.36.1-r1.ebuild,
+ -files/libsoup-2.36.1-SoupHTTPInputStream-GCancellable.patch,
+ +libsoup-2.40.2.ebuild, metadata.xml:
+ Version bump for gnome-3.6; libsoup's I/O code has been rewritten and
+ improved. Switch to global introspection flag. Drop old.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> libsoup-2.38.1.ebuild:
ia64/sh/sparc stable wrt #427544
diff --git a/net-libs/libsoup/files/libsoup-2.36.1-SoupHTTPInputStream-GCancellable.patch b/net-libs/libsoup/files/libsoup-2.36.1-SoupHTTPInputStream-GCancellable.patch
deleted file mode 100644
index 9e1a59e62cfb..000000000000
--- a/net-libs/libsoup/files/libsoup-2.36.1-SoupHTTPInputStream-GCancellable.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-From 856df33301221711789f0db744fce951eb70ba76 Mon Sep 17 00:00:00 2001
-From: Dan Winship <danw@gnome.org>
-Date: Mon, 23 Jan 2012 12:34:12 -0500
-Subject: [PATCH] SoupHTTPInputStream: don't burn through GCancellable fds
-
-SoupSession limits the number of outgoing TCP connections, but
-SoupRequestHTTP/SoupHTTPInputStream were still using a file descriptor
-for the GCancellable of each request that got queued, even before it
-was sent. This meant that if the app queued 1000ish requests all at
-once (eg, while rendering an HTML page with *lots* of images), we
-would run out of file descriptors.
-
-Fix this by just using the GCancellable::cancelled signal rather than
-g_cancellable_get_fd().
-
-https://bugzilla.gnome.org/show_bug.cgi?id=668508
----
- libsoup/soup-http-input-stream.c | 38 ++++++++++++++++----------------------
- 1 files changed, 16 insertions(+), 22 deletions(-)
-
-diff --git a/libsoup/soup-http-input-stream.c b/libsoup/soup-http-input-stream.c
-index 45f181c..c0337e9 100644
---- a/libsoup/soup-http-input-stream.c
-+++ b/libsoup/soup-http-input-stream.c
-@@ -43,7 +43,7 @@ typedef struct {
- goffset offset;
-
- GCancellable *cancellable;
-- GSource *cancel_watch;
-+ guint cancel_id;
- SoupHTTPInputStreamCallback got_headers_cb;
- SoupHTTPInputStreamCallback got_chunk_cb;
- SoupHTTPInputStreamCallback finished_cb;
-@@ -323,39 +323,34 @@ soup_http_input_stream_finished (SoupMessage *msg, gpointer stream)
- priv->finished_cb (stream);
- }
-
--static gboolean
--soup_http_input_stream_cancelled (GIOChannel *chan, GIOCondition condition,
-- gpointer stream)
-+static void
-+soup_http_input_stream_cancelled (GCancellable *cancellable,
-+ gpointer user_data)
- {
-+ SoupHTTPInputStream *stream = user_data;
- SoupHTTPInputStreamPrivate *priv = SOUP_HTTP_INPUT_STREAM_GET_PRIVATE (stream);
-
-- priv->cancel_watch = NULL;
-+ g_signal_handler_disconnect (cancellable, priv->cancel_id);
-+ priv->cancel_id = 0;
-
- soup_session_pause_message (priv->session, priv->msg);
- if (priv->cancelled_cb)
-- priv->cancelled_cb (stream);
--
-- return FALSE;
-+ priv->cancelled_cb (G_INPUT_STREAM (stream));
- }
-
- static void
- soup_http_input_stream_prepare_for_io (GInputStream *stream,
- GCancellable *cancellable,
- guchar *buffer,
-- gsize count)
-+ gsize count)
- {
- SoupHTTPInputStreamPrivate *priv = SOUP_HTTP_INPUT_STREAM_GET_PRIVATE (stream);
-- int cancel_fd;
-
- priv->cancellable = cancellable;
-- cancel_fd = g_cancellable_get_fd (cancellable);
-- if (cancel_fd != -1) {
-- GIOChannel *chan = g_io_channel_unix_new (cancel_fd);
-- priv->cancel_watch = soup_add_io_watch (priv->async_context, chan,
-- G_IO_IN | G_IO_ERR | G_IO_HUP,
-- soup_http_input_stream_cancelled,
-- stream);
-- g_io_channel_unref (chan);
-+ if (cancellable) {
-+ priv->cancel_id = g_signal_connect (cancellable, "cancelled",
-+ G_CALLBACK (soup_http_input_stream_cancelled),
-+ stream);
- }
-
- priv->caller_buffer = buffer;
-@@ -371,10 +366,9 @@ soup_http_input_stream_done_io (GInputStream *stream)
- {
- SoupHTTPInputStreamPrivate *priv = SOUP_HTTP_INPUT_STREAM_GET_PRIVATE (stream);
-
-- if (priv->cancel_watch) {
-- g_source_destroy (priv->cancel_watch);
-- priv->cancel_watch = NULL;
-- g_cancellable_release_fd (priv->cancellable);
-+ if (priv->cancel_id) {
-+ g_signal_handler_disconnect (priv->cancellable, priv->cancel_id);
-+ priv->cancel_id = 0;
- }
- priv->cancellable = NULL;
-
---
-1.7.8.4
-
diff --git a/net-libs/libsoup/libsoup-2.36.1-r1.ebuild b/net-libs/libsoup/libsoup-2.36.1-r1.ebuild
deleted file mode 100644
index ae6e3358934c..000000000000
--- a/net-libs/libsoup/libsoup-2.36.1-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.36.1-r1.ebuild,v 1.13 2012/10/20 06:16:02 tetromino Exp $
-
-EAPI="4"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="An HTTP library implementation in C"
-HOMEPAGE="http://live.gnome.org/LibSoup"
-
-LICENSE="LGPL-2+"
-SLOT="2.4"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="debug +introspection samba ssl test"
-
-# glib-networking-2.29.18 needed to avoid a tls bug, see NEWS file
-RDEPEND=">=dev-libs/glib-2.30.0:2
- >=dev-libs/libxml2-2:2
- >=net-libs/glib-networking-2.30.0[ssl?]
- introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- samba? ( net-fs/samba )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=dev-util/gtk-doc-am-1.10"
-# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
-# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
-# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
-# dev-lang/php[apache2,xmlrpc]
-# net-misc/curl
-# net-libs/glib-networking[ssl])"
-
-pkg_setup() {
- # Disable apache tests until they are usable on Gentoo, bug #326957
- DOCS="AUTHORS NEWS README"
- G2CONF="${G2CONF}
- --disable-static
- --disable-tls-check
- --without-gnome
- --without-apache-httpd
- $(use_enable introspection)
- $(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)"
-}
-
-src_prepare() {
- if ! use test; then
- # don't waste time building tests (bug #226271)
- sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
- || die "sed failed"
- fi
-
- # Patch from 2.37.x, fixes 'Too many open files' error
- epatch "${FILESDIR}/${P}-SoupHTTPInputStream-GCancellable.patch"
-
- gnome2_src_prepare
-}
-
-src_configure() {
- # FIXME: we need addpredict to workaround bug #324779 until
- # root cause (bug #249496) is solved
- addpredict /usr/share/snmp/mibs/.index
- gnome2_src_configure
-}
diff --git a/net-libs/libsoup/libsoup-2.36.1.ebuild b/net-libs/libsoup/libsoup-2.40.2.ebuild
index fec287c1453a..97ccc09f48c0 100644
--- a/net-libs/libsoup/libsoup-2.36.1.ebuild
+++ b/net-libs/libsoup/libsoup-2.40.2.ebuild
@@ -1,30 +1,32 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.36.1.ebuild,v 1.13 2012/10/20 06:16:02 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.40.2.ebuild,v 1.1 2012/12/17 05:14:55 tetromino Exp $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit gnome2 python
DESCRIPTION="An HTTP library implementation in C"
HOMEPAGE="http://live.gnome.org/LibSoup"
LICENSE="LGPL-2+"
SLOT="2.4"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="debug +introspection samba ssl test"
-# glib-networking-2.29.18 needed to avoid a tls bug, see NEWS file
-RDEPEND=">=dev-libs/glib-2.30.0:2
+RDEPEND=">=dev-libs/glib-2.33.1:2
>=dev-libs/libxml2-2:2
>=net-libs/glib-networking-2.30.0[ssl?]
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
samba? ( net-fs/samba )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=dev-util/gtk-doc-am-1.10"
+ =dev-lang/python-2*
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ virtual/pkgconfig"
# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
@@ -33,15 +35,8 @@ DEPEND="${RDEPEND}
# net-libs/glib-networking[ssl])"
pkg_setup() {
- # Disable apache tests until they are usable on Gentoo, bug #326957
- DOCS="AUTHORS NEWS README"
- G2CONF="${G2CONF}
- --disable-static
- --disable-tls-check
- --without-gnome
- --without-apache-httpd
- $(use_enable introspection)
- $(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)"
+ python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
@@ -55,6 +50,15 @@ src_prepare() {
}
src_configure() {
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-tls-check
+ --without-gnome
+ --without-apache-httpd
+ $(use_enable introspection)
+ $(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)"
+
# FIXME: we need addpredict to workaround bug #324779 until
# root cause (bug #249496) is solved
addpredict /usr/share/snmp/mibs/.index
diff --git a/net-libs/libsoup/metadata.xml b/net-libs/libsoup/metadata.xml
index 73ad8d8ea155..f96b3e310f95 100644
--- a/net-libs/libsoup/metadata.xml
+++ b/net-libs/libsoup/metadata.xml
@@ -3,8 +3,6 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
- for introspection</flag>
<flag name="samba">Use <pkg>net-fs/samba</pkg> for NTLM Single
Sign-On</flag>
</use>