summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-03 14:07:11 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-03 14:07:11 +0000
commit1d898d9c526a62a2aeb56505554eb828b8fa8b82 (patch)
treebce23d15f81ba2a71a184a4f5e2a496101c2940b /net-libs/librsync
parentAdd DEPEND on setuptools (bug 467314) (diff)
downloadgentoo-2-1d898d9c526a62a2aeb56505554eb828b8fa8b82.tar.gz
gentoo-2-1d898d9c526a62a2aeb56505554eb828b8fa8b82.tar.bz2
gentoo-2-1d898d9c526a62a2aeb56505554eb828b8fa8b82.zip
net-libs/librsync: Fix obsolete macros to work with automake-1.13, #467414; add some patches from fedora and debian to fix compiler warnings
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'net-libs/librsync')
-rw-r--r--net-libs/librsync/ChangeLog13
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-format-security.patch20
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-getopt.patch17
-rw-r--r--net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch19
-rw-r--r--net-libs/librsync/librsync-0.9.7-r3.ebuild36
-rw-r--r--net-libs/librsync/metadata.xml6
6 files changed, 106 insertions, 5 deletions
diff --git a/net-libs/librsync/ChangeLog b/net-libs/librsync/ChangeLog
index 128eaec804d3..d1a1a6dc947b 100644
--- a/net-libs/librsync/ChangeLog
+++ b/net-libs/librsync/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/librsync
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/librsync/ChangeLog,v 1.37 2012/09/09 16:19:39 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/librsync/ChangeLog,v 1.38 2013/05/03 14:07:11 jlec Exp $
+
+*librsync-0.9.7-r3 (03 May 2013)
+
+ 03 May 2013; Justin Lecher <jlec@gentoo.org> +librsync-0.9.7-r3.ebuild,
+ +files/librsync-0.9.7-format-security.patch,
+ +files/librsync-0.9.7-getopt.patch,
+ +files/librsync-0.9.7-implicit-declaration.patch, metadata.xml:
+ Fix obsolete macros to work with automake-1.13, #467414; add some patches
+ from fedora and debian to fix compiler warnings
09 Sep 2012; Michael Palimaka <kensington@gentoo.org>
-librsync-0.9.7-r1.ebuild, -librsync-0.9.7.ebuild:
diff --git a/net-libs/librsync/files/librsync-0.9.7-format-security.patch b/net-libs/librsync/files/librsync-0.9.7-format-security.patch
new file mode 100644
index 000000000000..e35980a4d7a0
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-format-security.patch
@@ -0,0 +1,20 @@
+Description: Always use a format string in printf
+ Fix the warning: buf.c:216:9: error: format not a string literal and no
+ format arguments [-Werror=format-security]
+Author: Andrey Rahmatullin <wrar@wrar.name>
+Forwarded: no
+Last-Update: 2012-02-05
+
+diff --git a/buf.c b/buf.c
+index 7f4e7a0..3a83f2b 100644
+--- a/buf.c
++++ b/buf.c
+@@ -213,7 +213,7 @@ rs_result rs_file_copy_cb(void *arg, rs_long_t pos, size_t *len, void **buf)
+
+ got = fread(*buf, 1, *len, f);
+ if (got == -1) {
+- rs_error(strerror(errno));
++ rs_error("%s", strerror(errno));
+ return RS_IO_ERROR;
+ } else if (got == 0) {
+ rs_error("unexpected eof on fd%d", fileno(f));
diff --git a/net-libs/librsync/files/librsync-0.9.7-getopt.patch b/net-libs/librsync/files/librsync-0.9.7-getopt.patch
new file mode 100644
index 000000000000..0859089b970a
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-getopt.patch
@@ -0,0 +1,17 @@
+Patch by Daniel Baumann <daniel@debian.org> for librsync >= 0.9.7, which makes
+rdiff aware of -i and -z getopt options mentioned in --help output. For further
+information, please have a look to Debian bug ID #435894.
+
+--- librsync-0.9.7/rdiff.c 2004-09-17 23:35:50.000000000 +0200
++++ librsync-0.9.7/rdiff.c.getopt 2008-12-20 13:45:58.000000000 +0100
+@@ -97,8 +97,8 @@
+ { "sum-size", 'S', POPT_ARG_INT, &strong_len },
+ { "statistics", 's', POPT_ARG_NONE, &show_stats },
+ { "stats", 0, POPT_ARG_NONE, &show_stats },
+- { "gzip", 0, POPT_ARG_NONE, 0, OPT_GZIP },
+- { "bzip2", 0, POPT_ARG_NONE, 0, OPT_BZIP2 },
++ { "gzip", 'z', POPT_ARG_NONE, 0, OPT_GZIP },
++ { "bzip2", 'i', POPT_ARG_NONE, 0, OPT_BZIP2 },
+ { "paranoia", 0, POPT_ARG_NONE, &rs_roll_paranoia },
+ { 0 }
+ };
diff --git a/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch b/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch
new file mode 100644
index 000000000000..782597c8fe2b
--- /dev/null
+++ b/net-libs/librsync/files/librsync-0.9.7-implicit-declaration.patch
@@ -0,0 +1,19 @@
+Description: Fix -Wimplicit-function-declaration warning in the test suite
+ Fix the warning: isprefix.driver.c:43:5: warning: implicit declaration of
+ function ‘strcmp’ [-Wimplicit-function-declaration]
+Author: Andrey Rahmatullin <wrar@wrar.name>
+Forwarded: no
+Last-Update: 2012-02-05
+
+diff --git a/testsuite/isprefix.driver.c b/testsuite/isprefix.driver.c
+index a9fd77b..df558c2 100644
+--- a/testsuite/isprefix.driver.c
++++ b/testsuite/isprefix.driver.c
+@@ -21,6 +21,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "isprefix.h"
+
diff --git a/net-libs/librsync/librsync-0.9.7-r3.ebuild b/net-libs/librsync/librsync-0.9.7-r3.ebuild
new file mode 100644
index 000000000000..00b4826a001c
--- /dev/null
+++ b/net-libs/librsync/librsync-0.9.7-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/librsync/librsync-0.9.7-r3.ebuild,v 1.1 2013/05/03 14:07:11 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Flexible remote checksum-based differencing"
+HOMEPAGE="http://librsync.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-huge-files.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-getopt.patch
+ "${FILESDIR}"/${P}-implicit-declaration.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
+ -i configure.ac || die
+
+ autotools-utils_src_prepare
+}
diff --git a/net-libs/librsync/metadata.xml b/net-libs/librsync/metadata.xml
index 91f4e72fb544..1470e032181b 100644
--- a/net-libs/librsync/metadata.xml
+++ b/net-libs/librsync/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>maintainer-needed@gentoo.org</email>
- </maintainer>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
</pkgmetadata>