summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-02 13:12:33 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-02 13:12:33 +0000
commit6a3628a46dfb136eb8ea432f0bdf54423da49bda (patch)
treef4905888e4ad99914a4a39e89a468076ba5023a7 /net-irc
parentStable on sparc wrt #183892 (diff)
downloadgentoo-2-6a3628a46dfb136eb8ea432f0bdf54423da49bda.tar.gz
gentoo-2-6a3628a46dfb136eb8ea432f0bdf54423da49bda.tar.bz2
gentoo-2-6a3628a46dfb136eb8ea432f0bdf54423da49bda.zip
Version bump wrt #183883, and remove xchattext USE-flag as it's deprecated by upstream
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/digest-xchat-2.8.46
-rw-r--r--net-irc/xchat/xchat-2.8.4.ebuild93
3 files changed, 106 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index f638534a7014..622c0339ae08 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.252 2007/07/01 09:16:38 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.253 2007/07/02 13:12:33 armin76 Exp $
+
+*xchat-2.8.4 (02 Jul 2007)
+
+ 02 Jul 2007; Raúl Porcel <armin76@gentoo.org> +xchat-2.8.4.ebuild:
+ Version bump wrt #183883, and remove xchattext USE-flag as it's deprecated
+ by upstream
01 Jul 2007; Peter Weller <welp@gentoo.org> xchat-2.8.2-r1.ebuild:
Clean up old dbus deps wrt bug 183696
diff --git a/net-irc/xchat/files/digest-xchat-2.8.4 b/net-irc/xchat/files/digest-xchat-2.8.4
new file mode 100644
index 000000000000..a35cdfc237e7
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.8.4
@@ -0,0 +1,6 @@
+MD5 66d60febc62a01bafac9bb3a35fb37ae xchat-2.8.4.tar.bz2 1370883
+RMD160 35cf84e03dfda160674d141063c8fc9cd0ac7de2 xchat-2.8.4.tar.bz2 1370883
+SHA256 f95a9a9e477128aae536669dedd79f4e7b4d469072565695289e4bbb5b36dd63 xchat-2.8.4.tar.bz2 1370883
+MD5 c0220456a4df8ee54ae02e7704a6e024 xchat-dccserver-0.6.patch.bz2 49320
+RMD160 24cc9bd414b1dd0e7e38ba9a49d12257aeb89e68 xchat-dccserver-0.6.patch.bz2 49320
+SHA256 90a49a8d810380020c507c1a36f02e7d972cf92b5e4802dcd5cc518cba29078f xchat-dccserver-0.6.patch.bz2 49320
diff --git a/net-irc/xchat/xchat-2.8.4.ebuild b/net-irc/xchat/xchat-2.8.4.ebuild
new file mode 100644
index 000000000000..aa384b626787
--- /dev/null
+++ b/net-irc/xchat/xchat-2.8.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.4.ebuild,v 1.1 2007/07/02 13:12:33 armin76 Exp $
+
+inherit eutils versionator gnome2
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ xchatdccserver? ( mirror://gentoo/${PN}-dccserver-0.6.patch.bz2 )"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="perl dbus tcl python ssl mmx ipv6 libnotify nls spell xchatnogtk xchatdccserver"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ !xchatnogtk? ( >=x11-libs/gtk+-2.10.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( >=dev-lang/python-2.2 )
+ tcl? ( dev-lang/tcl )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ spell? ( app-text/enchant )
+ libnotify? ( x11-libs/libnotify )
+ !<net-irc/xchat-gnome-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+}
+
+src_compile() {
+ # Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+ if [[ ${ARCH} = sparc ]] ; then
+ replace-flags "-O[3-9]" "-O2"
+ fi
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable spell spell static) \
+ $(use_enable !xchatnogtk gtkfe) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ USE_DESTDIR=1 gnome2_src_install || die "make install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "XChat binary has been renamed from xchat-2 to xchat."
+ elog
+
+ if has_version net-irc/xchat-systray
+ then
+ elog "XChat now includes it's own systray icon, you may want to remove net-irc/xchat-systray."
+ elog
+ fi
+}