summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-04-05 15:04:17 +0000
committerChuck Short <zul@gentoo.org>2004-04-05 15:04:17 +0000
commit274e215857e33ddf47f3f00bc44c2a0495ed8602 (patch)
treea177cdfe397ef3ab2f831205990ceee56a4631d8 /net-irc
parentAdded djbfft for a52dec (diff)
downloadgentoo-2-274e215857e33ddf47f3f00bc44c2a0495ed8602.tar.gz
gentoo-2-274e215857e33ddf47f3f00bc44c2a0495ed8602.tar.bz2
gentoo-2-274e215857e33ddf47f3f00bc44c2a0495ed8602.zip
Added patch to fix proxy vulnerabiltiy. Applied patch to affected versions.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/xc208-fixsocks5.diff22
-rw-r--r--net-irc/xchat/xchat-1.8.11.ebuild5
-rw-r--r--net-irc/xchat/xchat-2.0.1.ebuild5
-rw-r--r--net-irc/xchat/xchat-2.0.6-r1.ebuild5
-rw-r--r--net-irc/xchat/xchat-2.0.7.ebuild5
-rw-r--r--net-irc/xchat/xchat-2.0.8.ebuild5
7 files changed, 49 insertions, 6 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 6dbc9f420007..4121abe242b0 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.87 2004/04/05 10:28:04 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.88 2004/04/05 15:04:17 zul Exp $
05 Apr 2004; Guy Martin <gmsoft@gentoo.org> xchat-2.0.7.ebuild:
Marked stable on hppa.
+ 05 Apr 2004; Chuck Short <zul@gentoo.org> xchat-1.8.11.ebuild,
+ xchat-2.0.1.ebuild, xchat-2.0.6-r1.ebuild, xchat-2.0.7.ebuild,
+ xchat-2.0.8.ebuild, files/xc208-fixsocks5.diff:
+ Added patch to fix sock5 vulnerabiltiy for users using a proxy. Applied patch
+ to affected versions.
+
*xchat-2.0.8 (29 Mar 2004)
29 Mar 2004; Chuck Short <zul@gentoo.org> xchat-2.0.8.ebuild:
diff --git a/net-irc/xchat/files/xc208-fixsocks5.diff b/net-irc/xchat/files/xc208-fixsocks5.diff
new file mode 100644
index 000000000000..816801477075
--- /dev/null
+++ b/net-irc/xchat/files/xc208-fixsocks5.diff
@@ -0,0 +1,22 @@
+# Fix broken Socks5 traversal in xchat <= 2.0.8
+diff -ru xchat-2.0.8/src/common/server.c xchat-2.0.9/src/common/server.c
+--- xchat-2.0.8/src/common/server.c 2004-03-16 15:33:47.000000000 +1100
++++ xchat-2.0.8p1/src/common/server.c 2004-04-05 15:33:15.000000000 +1000
+@@ -1054,7 +1054,7 @@
+ struct sock5_connect1 sc1;
+ unsigned char *sc2;
+ unsigned int packetlen, addrlen;
+- unsigned char buf[10];
++ unsigned char buf[260];
+
+ sc1.version = 5;
+ sc1.nmethods = 1;
+@@ -1095,7 +1095,7 @@
+ {
+ if (recv (sok, buf, 1, 0) != 1)
+ return 1;
+- packetlen = buf[0] + 2;
++ packetlen = buf[0] + 2; /* can't exceed 260 */
+ if (recv (sok, buf, packetlen, 0) != packetlen)
+ return 1;
+ }
diff --git a/net-irc/xchat/xchat-1.8.11.ebuild b/net-irc/xchat/xchat-1.8.11.ebuild
index ea69b5f9ee78..d2876ab2d27a 100644
--- a/net-irc/xchat/xchat-1.8.11.ebuild
+++ b/net-irc/xchat/xchat-1.8.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.11.ebuild,v 1.11 2004/01/04 01:34:08 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.11.ebuild,v 1.12 2004/04/05 15:04:17 zul Exp $
inherit eutils
@@ -31,6 +31,9 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/xc1811fixststint.diff
+ # Fix for sock5 vulnerability - see #46856
+ epatch ${FILESDIR}/xc208-fixsocks5.diff
+
use python && ( \
cp configure configure.orig
local mylibs=`/usr/bin/python-config`
diff --git a/net-irc/xchat/xchat-2.0.1.ebuild b/net-irc/xchat/xchat-2.0.1.ebuild
index 4dfe670383c1..af7ce0c67ee3 100644
--- a/net-irc/xchat/xchat-2.0.1.ebuild
+++ b/net-irc/xchat/xchat-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.1.ebuild,v 1.10 2004/01/04 01:34:08 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.1.ebuild,v 1.11 2004/04/05 15:04:17 zul Exp $
IUSE="perl tcltk python ssl gtk mmx ipv6"
@@ -50,6 +50,9 @@ src_compile() {
&& myopts="${myopts} --enable-ipv6" \
|| myopts="${myopts} --disable-ipv6"
+ # Fix for sock5 vulnerabilty - #46856
+ epatch ${FILESDIR}/xc208-fixsocks5.diff
+
econf \
--program-suffix=-2 \
${myopts} || die "Configure failed"
diff --git a/net-irc/xchat/xchat-2.0.6-r1.ebuild b/net-irc/xchat/xchat-2.0.6-r1.ebuild
index 291e1c4b28f6..18eb86cdc7bb 100644
--- a/net-irc/xchat/xchat-2.0.6-r1.ebuild
+++ b/net-irc/xchat/xchat-2.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.6-r1.ebuild,v 1.6 2004/01/08 17:22:06 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.6-r1.ebuild,v 1.7 2004/04/05 15:04:17 zul Exp $
inherit flag-o-matic
@@ -45,6 +45,9 @@ src_compile() {
&& gtkconf="--disable-gtkfe" \
|| gtkconf="--enable-gtkfe"
+ # Fix for sock5 vulnerability - see 46856
+ epatch ${FILESDIR}/xc208-fixsocks5.diff
+
econf \
${gtkconf} \
`use_enable ssl openssl` \
diff --git a/net-irc/xchat/xchat-2.0.7.ebuild b/net-irc/xchat/xchat-2.0.7.ebuild
index 1bf6c7139830..747cc2cf9e71 100644
--- a/net-irc/xchat/xchat-2.0.7.ebuild
+++ b/net-irc/xchat/xchat-2.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.7.ebuild,v 1.8 2004/04/05 10:28:04 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.7.ebuild,v 1.9 2004/04/05 15:04:17 zul Exp $
inherit flag-o-matic
@@ -45,6 +45,9 @@ src_compile() {
&& gtkconf="--disable-gtkfe" \
|| gtkconf="--enable-gtkfe"
+ # Fix for sock5 vulnerability - see #46856
+ epatch ${FILESDIR}/xc208-fixsocks5.diff
+
econf \
${gtkconf} \
`use_enable ssl openssl` \
diff --git a/net-irc/xchat/xchat-2.0.8.ebuild b/net-irc/xchat/xchat-2.0.8.ebuild
index 8cd2f7f7076d..c2c2109acd68 100644
--- a/net-irc/xchat/xchat-2.0.8.ebuild
+++ b/net-irc/xchat/xchat-2.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.8.ebuild,v 1.1 2004/03/29 12:31:32 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.8.ebuild,v 1.2 2004/04/05 15:04:17 zul Exp $
inherit flag-o-matic
@@ -45,6 +45,9 @@ src_compile() {
&& gtkconf="--disable-gtkfe" \
|| gtkconf="--enable-gtkfe"
+ # fix for sock5 vulnerability - see #46856
+ epatch ${FILESDIR}/xc208-fixsocks5.diff
+
econf \
${gtkconf} \
`use_enable ssl openssl` \