summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:45:25 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:45:25 +0000
commiteb9f33801c28b545735c6250b77e0fe619eab976 (patch)
tree1141ddf6dd7e36da63c1fc19aba28b766e862db0 /net-im/ekg2
parentImport the live ebuild. (diff)
downloadgentoo-2-eb9f33801c28b545735c6250b77e0fe619eab976.tar.gz
gentoo-2-eb9f33801c28b545735c6250b77e0fe619eab976.tar.bz2
gentoo-2-eb9f33801c28b545735c6250b77e0fe619eab976.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'net-im/ekg2')
-rw-r--r--net-im/ekg2/ChangeLog7
-rw-r--r--net-im/ekg2/ekg2-9999.ebuild112
-rw-r--r--net-im/ekg2/metadata.xml33
3 files changed, 140 insertions, 12 deletions
diff --git a/net-im/ekg2/ChangeLog b/net-im/ekg2/ChangeLog
index 88f0916e1b4b..0c91ec700f39 100644
--- a/net-im/ekg2/ChangeLog
+++ b/net-im/ekg2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/ekg2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg2/ChangeLog,v 1.48 2012/11/30 23:10:30 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg2/ChangeLog,v 1.49 2012/12/15 12:45:25 mgorny Exp $
+
+*ekg2-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +ekg2-9999.ebuild, metadata.xml:
+ Import the live ebuild.
30 Nov 2012; Michał Górny <mgorny@gentoo.org> ekg2-0.3.1-r1.ebuild:
EAPI bump, use the new prune_libtool_files function and python-single-r1.
diff --git a/net-im/ekg2/ekg2-9999.ebuild b/net-im/ekg2/ekg2-9999.ebuild
new file mode 100644
index 000000000000..85eac6aadfcf
--- /dev/null
+++ b/net-im/ekg2/ekg2-9999.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg2/ekg2-9999.ebuild,v 1.4 2012/12/15 12:45:24 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="git://github.com/leafnode/${PN}.git
+ http://github.com/leafnode/${PN}.git"
+
+inherit git-2
+#endif
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+inherit autotools-utils python-single-r1
+
+DESCRIPTION="Text-based, multi-protocol instant messenger"
+HOMEPAGE="http://www.ekg2.org"
+SRC_URI="http://pl.ekg2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gadu gpm gpg gtk inotify minimal ncurses nls nntp openssl
+ perl python readline rss spell sqlite sqlite2 ssl xmpp unicode zlib"
+
+RDEPEND="dev-libs/glib:2
+ gadu? ( net-libs/libgadu )
+ gpg? ( app-crypt/gpgme )
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( virtual/libintl )
+ openssl? ( dev-libs/openssl )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline )
+ rss? ( dev-libs/expat )
+ ssl? ( net-libs/gnutls )
+ xmpp? ( dev-libs/expat )
+ zlib? ( sys-libs/zlib )
+
+ ncurses? ( sys-libs/ncurses[unicode=]
+ gpm? ( sys-libs/gpm )
+ spell? ( app-text/aspell ) )
+ sqlite? (
+ !sqlite2? ( dev-db/sqlite:3 )
+ sqlite2? ( dev-db/sqlite:0 ) )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+DOCS=(
+ AUTHORS README.md docs/README docs/TODO
+ docs/events.txt docs/mouse.txt docs/sim.txt docs/voip.txt
+ docs/themes.txt docs/themes-en.txt
+ docs/ui-ncurses.txt docs/ui-ncurses-en.txt
+)
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+pkg_pretend() {
+ if ! use gtk && ! use ncurses && ! use readline; then
+ ewarn 'ekg2 is being compiled without any frontend, you should consider'
+ ewarn 'enabling at least one of following USEflags:'
+ ewarn ' gtk, ncurses, readline.'
+ fi
+}
+
+src_configure() {
+ myeconfargs=(
+ # direct plugin references
+ $(use_enable gadu gg)
+ $(use_enable gpg)
+ $(use_enable gtk)
+ $(use_enable ncurses)
+ $(use_enable nntp)
+ $(use_enable openssl sim)
+ $(use_enable perl)
+ $(use_enable python)
+ $(use_enable readline)
+ $(use_enable rss)
+ $(use_enable sqlite logsqlite)
+ $(use_enable xmpp jabber)
+
+ $(use_enable !minimal autoresponder)
+ $(use_enable !minimal jogger)
+ $(use_enable !minimal mail)
+ $(use_enable !minimal polchat)
+ $(use_enable !minimal rivchat)
+ $(use_enable !minimal sms)
+
+ # sqlite switch
+ $(use_with !sqlite2 sqlite3)
+ $(use_with sqlite2 sqlite)
+
+ # optional deps
+ $(use_with gpm)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ $(use_with ssl gnutls)
+ $(use_with zlib)
+
+ # other magic
+ $(use_enable nls)
+ --with-perl-module-build-flags='INSTALLDIRS=vendor'
+ --enable-fast-configure
+ )
+ autotools-utils_src_configure
+}
diff --git a/net-im/ekg2/metadata.xml b/net-im/ekg2/metadata.xml
index 7d53758e26a3..efc06e026c94 100644
--- a/net-im/ekg2/metadata.xml
+++ b/net-im/ekg2/metadata.xml
@@ -7,24 +7,35 @@
</maintainer>
<use>
- <flag name='gadu'>Enable Gadu-Gadu protocol support (requires
- <pkg>net-libs/libgadu</pkg>).</flag>
- <flag name='gif'>GIF token support for Gadu-Gadu protocol.</flag>
+ <!-- 0.3* flags -->
+ <flag name='gif' restrict='=net-im/ekg2-0.3*'>
+ GIF token support for Gadu-Gadu protocol.</flag>
<flag name='gnutls'>Enable SSL/TLS support through GnuTLS
for the plugins supporting it. If 'ssl' is enabled too, GnuTLS will
be preferred where possible (and OpenSSL will be used
elsewhere).</flag>
- <flag name='gpg'>Enable jabber message encryption through
- <pkg>app-crypt/gpgme</pkg>.</flag>
- <flag name='inotify'>Enable inotify-based filesystem moniotoring support
- for xmsg&amp;mail plugins.</flag>
<flag name='jpeg'>JPEG token support for Gadu-Gadu protocol.</flag>
- <flag name='ssl'>Enable the complete SSL/TLS support through OpenSSL.
+ <flag name='ssl' restrict='=net-im/ekg2-0.3*'>
+ Enable the complete SSL/TLS support through OpenSSL.
This also enables the 'sim' plugin which relies on OpenSSL.</flag>
- <flag name='oracle'>Support logging messages into Oracle database.</flag>
- <flag name='sqlite3'>Support logging messages into SQLite3 database.
+ <flag name='sqlite3' restrict='&lt;=net-im/ekg2-0.3.1-r1'>
+ Support logging messages into SQLite3 database.
If 'sqlite' is set too, SQLite3 will be used.</flag>
- <flag name='sqlite'>Support logging messages into SQLite2 database.
+ <flag name='sqlite' restrict='&lt;=net-im/ekg2-0.3.1-r1'>
+ Support logging messages into SQLite2 database.
If 'sqlite3' is set too, it will be used instead.</flag>
+ <flag name='oracle'>Support logging messages into Oracle database.</flag>
+
+ <!-- common and modern flags -->
+ <flag name='gadu'>Enable Gadu-Gadu protocol support (requires
+ <pkg>net-libs/libgadu</pkg>).</flag>
+ <flag name='gpg'>Enable jabber message encryption through
+ <pkg>app-crypt/gpgme</pkg>.</flag>
+ <flag name='inotify'>Enable inotify-based filesystem moniotoring support
+ for xmsg&amp;mail plugins.</flag>
+ <flag name='minimal'>Disable building extra plugins with no additional
+ deps.</flag>
+ <flag name='openssl'>Support encryption in sim plugin, using OpenSSL.</flag>
+ <flag name='sqlite2'>Prefer SQLite2 over SQLite3 (if USE=sqlite is set).</flag>
</use>
</pkgmetadata>