summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-11-06 21:47:25 +0000
committerJon Portnoy <avenj@gentoo.org>2004-11-06 21:47:25 +0000
commit974af53f500c21ae373ba6da9435721ea0e651d5 (patch)
tree448bee09090c2373e82ef2d9f034f44648982046 /net-dns
parentStable on ppc, bug #70227. (Manifest recommit) (diff)
downloadgentoo-2-974af53f500c21ae373ba6da9435721ea0e651d5.tar.gz
gentoo-2-974af53f500c21ae373ba6da9435721ea0e651d5.tar.bz2
gentoo-2-974af53f500c21ae373ba6da9435721ea0e651d5.zip
Patch to fix GCC 3.4 build problems in dnsmasq-2.16, see bug 68589
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/ChangeLog7
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.16.ebuild5
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-2.16-gcc34.diff38
3 files changed, 48 insertions, 2 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 3860d2342e24..c4a59791feb0 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.55 2004/10/22 17:33:25 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.56 2004/11/06 21:47:25 avenj Exp $
+
+ 06 Nov 2004; Jon Portnoy <avenj@gentoo.org> dnsmasq-2.16.ebuild,
+ files/dnsmasq-2.16-gcc34.diff :
+ Patch to fix GCC 3.4 compilation errors. Written by upstream and
+ submitted by Holger Hoffstatte in bug #68598.
*dnsmasq-2.16 (22 Oct 2004)
diff --git a/net-dns/dnsmasq/dnsmasq-2.16.ebuild b/net-dns/dnsmasq/dnsmasq-2.16.ebuild
index 42eeaaf40135..e05c81432199 100644
--- a/net-dns/dnsmasq/dnsmasq-2.16.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.16.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.16.ebuild,v 1.1 2004/10/22 17:33:25 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.16.ebuild,v 1.2 2004/11/06 21:47:25 avenj Exp $
+
+inherit eutils
MY_P="${P/_/}"
MY_PV="${PV/_rc*/}"
@@ -19,6 +21,7 @@ DEPEND="virtual/libc
S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
+ epatch ${FILESDIR}/dnsmasq-2.16-gcc34.diff
emake || die
}
diff --git a/net-dns/dnsmasq/files/dnsmasq-2.16-gcc34.diff b/net-dns/dnsmasq/files/dnsmasq-2.16-gcc34.diff
new file mode 100644
index 000000000000..ef3dd144a05d
--- /dev/null
+++ b/net-dns/dnsmasq/files/dnsmasq-2.16-gcc34.diff
@@ -0,0 +1,38 @@
+--- dnsmasq-2.16.orig/src/cache.c
++++ dnsmasq-2.16/src/cache.c
+@@ -17,7 +17,7 @@
+ static int cache_inserted, cache_live_freed, insert_error;
+ static union bigname *big_free;
+ static int bignames_left, log_queries, cache_size, hash_size;
+-static int index;
++static int uid;
+
+ static void cache_free(struct crec *crecp);
+ static void cache_unlink(struct crec *crecp);
+@@ -36,7 +36,7 @@
+ cache_size = size;
+ big_free = NULL;
+ bignames_left = size/10;
+- index = 0;
++ uid = 0;
+
+ cache_inserted = cache_live_freed = 0;
+
+@@ -48,7 +48,7 @@
+ {
+ cache_link(crecp);
+ crecp->flags = 0;
+- crecp->uid = index++;
++ crecp->uid = uid++;
+ }
+ }
+
+@@ -85,7 +85,7 @@
+ {
+ crecp->flags &= ~F_FORWARD;
+ crecp->flags &= ~F_REVERSE;
+- crecp->uid = index++; /* invalidate CNAMES pointing to this. */
++ crecp->uid = uid++; /* invalidate CNAMES pointing to this. */
+
+ if (cache_tail)
+ cache_tail->next = crecp;