summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-06-29 05:22:40 +0000
committerMichael Orlitzky <mjo@gentoo.org>2015-06-29 05:22:40 +0000
commit5bceb02284ca8e3a13d0cb5c786cb2b17471d6ef (patch)
treedd548aed0aa877e0a6413083014b0ae3fc33ee35 /net-dns
parentRemove two now-unused init/conf files. (diff)
downloadgentoo-2-5bceb02284ca8e3a13d0cb5c786cb2b17471d6ef.tar.gz
gentoo-2-5bceb02284ca8e3a13d0cb5c786cb2b17471d6ef.tar.bz2
gentoo-2-5bceb02284ca8e3a13d0cb5c786cb2b17471d6ef.zip
Fix comment in conf file and revbump to push it out, bug #553296.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x6F48D3DA05C2DADB!)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/rbldnsd/ChangeLog8
-rw-r--r--net-dns/rbldnsd/files/confd-0.997a4
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.997a-r2.ebuild67
3 files changed, 76 insertions, 3 deletions
diff --git a/net-dns/rbldnsd/ChangeLog b/net-dns/rbldnsd/ChangeLog
index 1af342f0b320..b81639ac881e 100644
--- a/net-dns/rbldnsd/ChangeLog
+++ b/net-dns/rbldnsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/rbldnsd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/ChangeLog,v 1.34 2015/06/29 05:11:30 mjo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/ChangeLog,v 1.35 2015/06/29 05:22:40 mjo Exp $
+
+*rbldnsd-0.997a-r2 (29 Jun 2015)
+
+ 29 Jun 2015; Michael Orlitzky <mjo@gentoo.org> +rbldnsd-0.997a-r2.ebuild,
+ files/confd-0.997a:
+ Fix comment in conf file and revbump to push it out, bug #553296.
29 Jun 2015; Michael Orlitzky <mjo@gentoo.org> -files/confd-0.997,
-files/initd-0.997:
diff --git a/net-dns/rbldnsd/files/confd-0.997a b/net-dns/rbldnsd/files/confd-0.997a
index 0fb7685001e0..e7abb81fbc78 100644
--- a/net-dns/rbldnsd/files/confd-0.997a
+++ b/net-dns/rbldnsd/files/confd-0.997a
@@ -1,5 +1,5 @@
# A whitespace-separated list of addresses on which to listen. The
-# syntax is "host:port", where the port defaults to 53.
+# syntax is "host/port", where the port defaults to 53.
#
# Note that by default the rbldnsd init script does not require any
# interfaces other than lo to be "up" (see bug #439092). So if you
@@ -10,7 +10,7 @@
# rc_need="net.lan0"
#
# LISTEN="127.0.0.1
-# 192.168.0.1"
+# 192.168.0.1/5353"
#
LISTEN="localhost"
diff --git a/net-dns/rbldnsd/rbldnsd-0.997a-r2.ebuild b/net-dns/rbldnsd/rbldnsd-0.997a-r2.ebuild
new file mode 100644
index 000000000000..c041b6bff693
--- /dev/null
+++ b/net-dns/rbldnsd/rbldnsd-0.997a-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/rbldnsd/rbldnsd-0.997a-r2.ebuild,v 1.1 2015/06/29 05:22:40 mjo Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils toolchain-funcs user python-single-r1
+
+DESCRIPTION="DNS server designed to serve blacklist zones"
+HOMEPAGE="http://www.corpit.ru/mjt/rbldnsd.html"
+SRC_URI="http://www.corpit.ru/mjt/rbldnsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 test zlib"
+
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS}
+ dev-python/pydns:2[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-robust-ipv6-test-support.patch"
+ epatch "${FILESDIR}/${P}-format-security-compile-fix.patch"
+}
+
+src_configure() {
+ # The ./configure file is handwritten and doesn't support a `make
+ # install` target, so there are no --prefix options. The econf
+ # function appends those automatically, so we can't use it.
+ ./configure \
+ $(use_enable ipv6) \
+ $(use_enable zlib) \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_test() {
+ emake check \
+ CC="$(tc-getCC)" \
+ PYTHON="${PYTHON}"
+}
+
+src_install() {
+ dosbin rbldnsd
+ doman rbldnsd.8
+ keepdir /var/db/rbldnsd
+ dodoc CHANGES* TODO NEWS README*
+ newinitd "${FILESDIR}"/initd-${PV} rbldnsd
+ newconfd "${FILESDIR}"/confd-${PV} rbldnsd
+}
+
+pkg_postinst() {
+ enewgroup rbldns
+ enewuser rbldns -1 -1 /var/db/rbldnsd rbldns
+ chown rbldns:rbldns /var/db/rbldnsd
+}