summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-09-20 22:22:43 +0000
committerJon Portnoy <avenj@gentoo.org>2004-09-20 22:22:43 +0000
commitc830db5b73ea342d649140402ec124e65858ef2d (patch)
treee360ece761e05aeb27ba34186350687ed0355b18 /net-dns/dnsmasq/dnsmasq-2.15.ebuild
parentLicense fix. (Manifest recommit) (diff)
downloadgentoo-2-c830db5b73ea342d649140402ec124e65858ef2d.tar.gz
gentoo-2-c830db5b73ea342d649140402ec124e65858ef2d.tar.bz2
gentoo-2-c830db5b73ea342d649140402ec124e65858ef2d.zip
Version bump
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.15.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.15.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.15.ebuild b/net-dns/dnsmasq/dnsmasq-2.15.ebuild
new file mode 100644
index 000000000000..55b2d5f91409
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.15.ebuild,v 1.1 2004/09/20 22:22:43 avenj Exp $
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~arm ~amd64 ~ia64 ~s390"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR=${D} \
+ install || die
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dnsmasq-init dnsmasq
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+}