summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-12-04 11:24:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-12-04 11:24:35 +0000
commit8cfee6cd7e9721c11b6cfc94e11b2a7b148f5a21 (patch)
tree23bc8b6fcc153f1de038399dc8424ca28771f488 /net-analyzer/traffic-vis
parentMerge the ebuild from my overlay. Fix USE=doc, run tests since they work for me. (diff)
downloadgentoo-2-8cfee6cd7e9721c11b6cfc94e11b2a7b148f5a21.tar.gz
gentoo-2-8cfee6cd7e9721c11b6cfc94e11b2a7b148f5a21.tar.bz2
gentoo-2-8cfee6cd7e9721c11b6cfc94e11b2a7b148f5a21.zip
Fix QA problems by Agostino Sarubbo (ago). Stable on amd64. Bug #391471
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/traffic-vis')
-rw-r--r--net-analyzer/traffic-vis/ChangeLog6
-rw-r--r--net-analyzer/traffic-vis/files/traffic-vis.init.d6
-rw-r--r--net-analyzer/traffic-vis/traffic-vis-0.35-r2.ebuild23
3 files changed, 20 insertions, 15 deletions
diff --git a/net-analyzer/traffic-vis/ChangeLog b/net-analyzer/traffic-vis/ChangeLog
index bb2ef3cf5b86..643d377ed5a4 100644
--- a/net-analyzer/traffic-vis/ChangeLog
+++ b/net-analyzer/traffic-vis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/traffic-vis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traffic-vis/ChangeLog,v 1.20 2011/07/08 11:09:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traffic-vis/ChangeLog,v 1.21 2011/12/04 11:24:35 hwoarang Exp $
+
+ 04 Dec 2011; Markos Chandras <hwoarang@gentoo.org> traffic-vis-0.35-r2.ebuild,
+ files/traffic-vis.init.d:
+ Fix QA problems by Agostino Sarubbo (ago). Stable on amd64. Bug #391471
08 Jul 2011; Samuli Suominen <ssuominen@gentoo.org>
traffic-vis-0.35-r1.ebuild, traffic-vis-0.35-r2.ebuild:
diff --git a/net-analyzer/traffic-vis/files/traffic-vis.init.d b/net-analyzer/traffic-vis/files/traffic-vis.init.d
index e71922dc4807..27684dfd39be 100644
--- a/net-analyzer/traffic-vis/files/traffic-vis.init.d
+++ b/net-analyzer/traffic-vis/files/traffic-vis.init.d
@@ -1,9 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traffic-vis/files/traffic-vis.init.d,v 1.3 2004/07/14 23:13:45 agriffis Exp $
-
-opts="depend start stop"
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traffic-vis/files/traffic-vis.init.d,v 1.4 2011/12/04 11:24:35 hwoarang Exp $
depend() {
need net
diff --git a/net-analyzer/traffic-vis/traffic-vis-0.35-r2.ebuild b/net-analyzer/traffic-vis/traffic-vis-0.35-r2.ebuild
index 2170856faec6..74559ce0e403 100644
--- a/net-analyzer/traffic-vis/traffic-vis-0.35-r2.ebuild
+++ b/net-analyzer/traffic-vis/traffic-vis-0.35-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traffic-vis/traffic-vis-0.35-r2.ebuild,v 1.3 2011/07/08 11:09:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traffic-vis/traffic-vis-0.35-r2.ebuild,v 1.4 2011/12/04 11:24:35 hwoarang Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI="http://www.mindrot.org/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc ~x86"
IUSE="gif"
DEPEND="net-libs/libpcap
@@ -21,6 +21,8 @@ DEPEND="net-libs/libpcap
dev-lang/perl )
=dev-libs/glib-1.2*"
+RDEPEND="${DEPEND}"
+
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
epatch "${FILESDIR}"/${P}-libpcap-header-fix.patch
@@ -29,13 +31,14 @@ src_prepare() {
sed -i frontends/traffic-togif \
-e "s:/usr/sbin/traffic-tops:/usr/bin/traffic-tops:g" \
|| die "sed frontends/traffic-togif"
-
+ # drop DEBUG flags
+ sed -i -e "/^DEBUGFLAGS/d" Makefile || die
tc-export CC
}
src_install() {
- dosbin collector/traffic-collector
- doman collector/traffic-collector.8
+ dosbin collector/traffic-collector || die
+ doman collector/traffic-collector.8 || die
for mybin in $(use gif && echo frontends/traffic-togif) \
frontends/traffic-tohtml \
@@ -45,12 +48,12 @@ src_install() {
utils/traffic-exclude \
utils/traffic-resolve ; do
- dobin ${mybin}
- doman ${mybin}.8
+ dobin ${mybin} || die
+ doman ${mybin}.8 || die
done
- newinitd "${FILESDIR}"/traffic-vis.init.d traffic-vis
- newconfd "${FILESDIR}"/traffic-vis.conf.d traffic-vis
+ newinitd "${FILESDIR}"/traffic-vis.init.d traffic-vis || die
+ newconfd "${FILESDIR}"/traffic-vis.conf.d traffic-vis || die
- dodoc TODO README BUGS CHANGELOG
+ dodoc TODO README BUGS CHANGELOG || die
}