summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-03-04 16:43:41 +0000
committerMichael Januszewski <spock@gentoo.org>2008-03-04 16:43:41 +0000
commitea1c9dfa9f4671dd8506744b6dda996254386b7e (patch)
treef3f7128ec930fc1a49dfc6de72a8dfd6e9e7605b /net-analyzer/nmap
parentAdded new version 0.17.9 (diff)
downloadgentoo-2-ea1c9dfa9f4671dd8506744b6dda996254386b7e.tar.gz
gentoo-2-ea1c9dfa9f4671dd8506744b6dda996254386b7e.tar.bz2
gentoo-2-ea1c9dfa9f4671dd8506744b6dda996254386b7e.zip
Fix bug #212159.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog5
-rw-r--r--net-analyzer/nmap/nmap-4.53.ebuild14
2 files changed, 16 insertions, 3 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index bcdba1623d50..a0f9b6983eed 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.159 2008/02/21 12:38:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.160 2008/03/04 16:43:41 spock Exp $
+
+ 04 Mar 2008; Michał Januszewski <spock@gentoo.org> nmap-4.53.ebuild:
+ Fix bug #212159.
21 Feb 2008; Raúl Porcel <armin76@gentoo.org> nmap-4.53.ebuild:
alpha/ia64/sparc/x86 stable
diff --git a/net-analyzer/nmap/nmap-4.53.ebuild b/net-analyzer/nmap/nmap-4.53.ebuild
index f436ee647014..7cd0894a9bca 100644
--- a/net-analyzer/nmap/nmap-4.53.ebuild
+++ b/net-analyzer/nmap/nmap-4.53.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.53.ebuild,v 1.3 2008/02/21 12:38:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.53.ebuild,v 1.4 2008/03/04 16:43:41 spock Exp $
inherit eutils flag-o-matic
@@ -33,10 +33,20 @@ pkg_setup() {
}
src_compile() {
+ local myconf=""
+
+ if use lua ; then
+ if has_version dev-lang/lua && built_with_use dev-lang/lua deprecated ; then
+ myconf="--with-liblua"
+ else
+ myconf="--with-liblua=included"
+ fi
+ fi
+
econf \
--with-libdnet=included \
+ "${myconf}" \
$(use_with gtk zenmap) \
- $(use_with lua liblua) \
$(use_with ssl openssl) || die
emake -j1 || die
}