summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-26 19:56:59 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-26 19:56:59 +0000
commit7f75d518083bd7ed74b42dfe28f39de7d65e5a4b (patch)
treeba30c29bf7c07ab0652b332386621242f672a4bc /net-analyzer/nessus-core
parent Split out the "nessus" ebuild to the individual nessues components ... (diff)
downloadgentoo-2-7f75d518083bd7ed74b42dfe28f39de7d65e5a4b.tar.gz
gentoo-2-7f75d518083bd7ed74b42dfe28f39de7d65e5a4b.tar.bz2
gentoo-2-7f75d518083bd7ed74b42dfe28f39de7d65e5a4b.zip
Split out the "nessus" ebuild to the individual nessues components to allow pieces to build and install properly. "nessus" is still an installable ebuild, it just pulls in the individual components. nessus-core is the third of those components.
Diffstat (limited to 'net-analyzer/nessus-core')
-rw-r--r--net-analyzer/nessus-core/files/digest-nessus-core-1.2.31
-rw-r--r--net-analyzer/nessus-core/nessus-core-1.2.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/nessus-core/files/digest-nessus-core-1.2.3 b/net-analyzer/nessus-core/files/digest-nessus-core-1.2.3
new file mode 100644
index 000000000000..038eea3e3526
--- /dev/null
+++ b/net-analyzer/nessus-core/files/digest-nessus-core-1.2.3
@@ -0,0 +1 @@
+MD5 fa1187cc27b8d116f6a2fa575e5dda29 nessus-core-1.2.3.tar.gz 590074
diff --git a/net-analyzer/nessus-core/nessus-core-1.2.3.ebuild b/net-analyzer/nessus-core/nessus-core-1.2.3.ebuild
new file mode 100644
index 000000000000..639706c870f1
--- /dev/null
+++ b/net-analyzer/nessus-core/nessus-core-1.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2000-2002 Achim Gottinger
+# Distributed under the GPL by Gentoo Technologies, Inc.
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-1.2.3.ebuild,v 1.1 2002/07/26 19:56:59 raker Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A remote security scanner for Linux (nessus-core)"
+HOMEPAGE="http://www.nessus.org/"
+
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-1.2.3/src/${P}.tar.gz"
+
+DEPEND="=net-analyzer/libnasl-1.2.3
+ X? ( x11-base/xfree )
+ gtk? ( x11-libs/gtk-1.2* )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+src_compile() {
+
+ use X && myconf="--with-x" || myconf="--without-x"
+
+ use gtk && myconf="--enable-gtk" || myconf="--disable-gtk"
+
+ econf || die "configure failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/state \
+ mandir=${D}/usr/share/man \
+ install || die "Install failed nessus-core"
+
+ cp ${ROOT}/config/nessusd.conf ${D}/etc/nessus/
+
+ cd ${S}
+ docinto nessus-core
+ dodoc README* UPGRADE_README CHANGES
+ dodoc doc/*.txt doc/ntp/*
+
+ insinto /etc/init.d
+ insopts -m 755
+ newins ${FILESDIR}/nessusd-r6 nessusd
+}