summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-25 07:39:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-25 07:39:51 +0000
commit6309ca062912e8f9ea167f7dbb1435b8823e6335 (patch)
tree2f3d2f0220910e04221ae939b91af7f4911d9950 /media-sound/mp3check
parentversion bump (diff)
downloadgentoo-2-6309ca062912e8f9ea167f7dbb1435b8823e6335.tar.gz
gentoo-2-6309ca062912e8f9ea167f7dbb1435b8823e6335.tar.bz2
gentoo-2-6309ca062912e8f9ea167f7dbb1435b8823e6335.zip
old
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound/mp3check')
-rw-r--r--media-sound/mp3check/ChangeLog8
-rw-r--r--media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff45
-rw-r--r--media-sound/mp3check/mp3check-0.8.0.ebuild27
3 files changed, 6 insertions, 74 deletions
diff --git a/media-sound/mp3check/ChangeLog b/media-sound/mp3check/ChangeLog
index 070f8d73acee..79f862ba5918 100644
--- a/media-sound/mp3check/ChangeLog
+++ b/media-sound/mp3check/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mp3check
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3check/ChangeLog,v 1.16 2012/02/05 15:10:38 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3check/ChangeLog,v 1.17 2013/02/25 07:39:51 ssuominen Exp $
+
+ 25 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> -mp3check-0.8.0.ebuild,
+ -files/mp3check-0.8.0-gcc34.diff:
+ old
05 Feb 2012; Raúl Porcel <armin76@gentoo.org> mp3check-0.8.0.ebuild,
mp3check-0.8.4.ebuild:
diff --git a/media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff b/media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff
deleted file mode 100644
index 5ce41b4abb31..000000000000
--- a/media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -ur mp3check-0.8.0/tmap.h mp3check-0.8.0.gcc34/tmap.h
---- mp3check-0.8.0/tmap.h 2002-12-03 23:00:57.000000000 +0100
-+++ mp3check-0.8.0.gcc34/tmap.h 2004-09-15 19:20:24.727493932 +0200
-@@ -54,7 +54,7 @@
- // new functionality
-
- /// return whether an element with key is contained or not
-- bool contains(const K& key) const { return find(key) != end(); }
-+ bool contains(const K& key) const { return find(key) != this->end(); }
- /// access element read only (const)
- // g++ 2.95.2 does not allow this:
- // const T& operator[](const K& key) const { const_iterator i = find(key); if(i != end()) return i->second; else throw TNotFoundException(); } // throw(TNotFoundException)
-diff -ur mp3check-0.8.0/tstring.cc mp3check-0.8.0.gcc34/tstring.cc
---- mp3check-0.8.0/tstring.cc 2003-01-27 22:21:17.000000000 +0100
-+++ mp3check-0.8.0.gcc34/tstring.cc 2004-09-15 19:31:52.383825721 +0200
-@@ -714,7 +714,7 @@
-
- void tstring::replaceUnprintable(bool only_ascii) {
- for(size_t i = 0; i < rep->len; i++) {
-- unsigned char& c = (unsigned char)(*rep)[i];
-+ unsigned char& c = (unsigned char&)(*rep)[i];
- if(!isprint(c)) {
- if(c < ' ') {
- c = '!';
-diff -ur mp3check-0.8.0/tvector.h mp3check-0.8.0.gcc34/tvector.h
---- mp3check-0.8.0/tvector.h 2002-12-03 23:00:57.000000000 +0100
-+++ mp3check-0.8.0.gcc34/tvector.h 2004-09-15 19:22:32.756649251 +0200
-@@ -60,13 +60,13 @@
- /// append an element to the end
- const tvector& operator += (const T& a) { push_back(a); return *this; }
- /// append another tvector to the end
-- const tvector& operator += (const tvector& a) { insert(end(), a.begin(), a.end()); return *this; }
-+ const tvector& operator += (const tvector& a) { insert(this->end(), a.begin(), a.end()); return *this; }
- /// direct read only access, safe
-- const T& operator[](size_t i) const { if(i < size()) return tvector_base<T>::operator[](i); else throw TZeroBasedIndexOutOfRangeException(i, size()); } // throw(TZeroBasedIndexOutOfRangeException);
-+ const T& operator[](size_t i) const { if(i < this->size()) return tvector_base<T>::operator[](i); else throw TZeroBasedIndexOutOfRangeException(i, this->size()); } // throw(TZeroBasedIndexOutOfRangeException);
- /// direct read/write access, automatically create new elements
-- T& operator[](size_t i) { if(i >= size()) operator+=(tvector(i - size() + 1)); return tvector_base<T>::operator[](i); }
-+ T& operator[](size_t i) { if(i >= this->size()) operator+=(tvector(i - this->size() + 1)); return tvector_base<T>::operator[](i); }
- /// clear vector
-- void clear() { erase(begin(), end()); }
-+ void clear() { erase(this->begin(), this->end()); }
- };
-
-
diff --git a/media-sound/mp3check/mp3check-0.8.0.ebuild b/media-sound/mp3check/mp3check-0.8.0.ebuild
deleted file mode 100644
index 1661a09479c4..000000000000
--- a/media-sound/mp3check/mp3check-0.8.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3check/mp3check-0.8.0.ebuild,v 1.9 2012/02/05 15:10:38 armin76 Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings."
-HOMEPAGE="http://jo.ath.cx/soft/mp3check/mp3check.html"
-SRC_URI="http://jo.ath.cx/soft/mp3check/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc34.diff
-}
-
-src_install() {
- einstall || die "einstall failed"
- dodoc ChangeLog FAQ HISTORY THANKS TODO
-}