summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-10-08 00:25:26 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-10-08 00:25:26 +0000
commit69ae857b452d87c03b5148af3dc712abf93079ba (patch)
treeda156bbfc5df22e58b6620cd01dcb5e7fe63f285 /media-sound/lastfm-ripper
parentDisable borked fpx support, bug 145628. (diff)
downloadgentoo-2-69ae857b452d87c03b5148af3dc712abf93079ba.tar.gz
gentoo-2-69ae857b452d87c03b5148af3dc712abf93079ba.tar.bz2
gentoo-2-69ae857b452d87c03b5148af3dc712abf93079ba.zip
Bumped to 1.2.1-r1 to fix slash issue, #150424. Patch provided by Octavio Ruiz (Ta^3) <tacvbo@tacvbo.net>. Removed 1.2.1
(Portage version: 2.1.1)
Diffstat (limited to 'media-sound/lastfm-ripper')
-rw-r--r--media-sound/lastfm-ripper/ChangeLog10
-rw-r--r--media-sound/lastfm-ripper/files/HandleSlashCharFix.patch10
-rw-r--r--media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r13
-rw-r--r--media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r1.ebuild30
4 files changed, 52 insertions, 1 deletions
diff --git a/media-sound/lastfm-ripper/ChangeLog b/media-sound/lastfm-ripper/ChangeLog
index 09012925e0df..d95077c8b237 100644
--- a/media-sound/lastfm-ripper/ChangeLog
+++ b/media-sound/lastfm-ripper/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/lastfm-ripper
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-ripper/ChangeLog,v 1.2 2006/07/06 07:59:21 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-ripper/ChangeLog,v 1.3 2006/10/08 00:25:26 pclouds Exp $
+
+*lastfm-ripper-1.2.1-r1 (08 Oct 2006)
+
+ 08 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
+ +files/HandleSlashCharFix.patch, -lastfm-ripper-1.2.1.ebuild,
+ +lastfm-ripper-1.2.1-r1.ebuild:
+ Bumped to 1.2.1-r1 to fix slash issue, #150424. Patch provided by Octavio
+ Ruiz (Ta^3) <tacvbo@tacvbo.net>. Removed 1.2.1
06 Jul 2006; Simon Stelling <blubb@gentoo.org> lastfm-ripper-1.2.1.ebuild:
added ~amd64 keyword
diff --git a/media-sound/lastfm-ripper/files/HandleSlashCharFix.patch b/media-sound/lastfm-ripper/files/HandleSlashCharFix.patch
new file mode 100644
index 000000000000..7b6f283179fd
--- /dev/null
+++ b/media-sound/lastfm-ripper/files/HandleSlashCharFix.patch
@@ -0,0 +1,10 @@
+--- /usr/bin/last.fm-ripper 2006-09-26 21:29:59.000000000 -0500
++++ last.fm-ripper 2006-10-07 18:36:12.000000000 -0500
+@@ -300,6 +300,7 @@
+ if ($track_info{'artist'} ne '')
+ {
+ my $mp3_file_name = "$track_info{'artist'}-$track_info{'album'}-$track_info{'track'}.mp3";
++ $mp3_file_name =~ s/\//_/g;
+ my $mp3_path = $output_directory."/".$mp3_file_name;
+ open(MP3,">$mp3_path");
+ print MP3 $mp3_data,substr($buffer,0,$length);
diff --git a/media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r1 b/media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r1
new file mode 100644
index 000000000000..ad8a1ec5f94a
--- /dev/null
+++ b/media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r1
@@ -0,0 +1,3 @@
+MD5 e719e44ceb8b5ea6ac49c872a0d18872 last.fm-ripper-1.2.1.tar.gz 5659
+RMD160 ca93737fd4d56f6587a85cf0b2aaa796e632819a last.fm-ripper-1.2.1.tar.gz 5659
+SHA256 a63f4f6f3eb795b47c71328ec4e3ee99aca2d9a15ee4914163a60cb84c6ce6bd last.fm-ripper-1.2.1.tar.gz 5659
diff --git a/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r1.ebuild b/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..f185e95bd08b
--- /dev/null
+++ b/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r1.ebuild,v 1.1 2006/10/08 00:25:26 pclouds Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="save last.fm radio to mp3 files"
+HOMEPAGE="http://search.cpan.org/src/JOCHEN/last.fm-ripper-1.2/README"
+SRC_URI="mirror://cpan/authors/id/J/JO/JOCHEN/last.fm-ripper-${PV}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="amazon tagwriting minimal"
+
+DEPEND="perl-core/Getopt-Long
+ perl-core/Digest-MD5
+ !minimal? ( dev-perl/Term-ReadPassword )
+ tagwriting? ( dev-perl/MP3-Tag )
+ amazon? ( dev-perl/MP3-Tag dev-perl/Net-Amazon )"
+
+S="${WORKDIR}/last.fm-ripper-${PV}"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/UnescapedVariableFix.patch
+ epatch ${FILESDIR}/CoverOutputDirectoryFix.patch
+ epatch ${FILESDIR}/HandleSlashCharFix.patch
+}