summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-23 18:48:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-23 18:48:02 +0000
commitec30c9ff3b291d2026931f894999aa0029411568 (patch)
treeabab36b192e957db18927716174c7551901a0565 /media-sound/audacity
parentRemove virtual/libc (diff)
downloadgentoo-2-ec30c9ff3b291d2026931f894999aa0029411568.tar.gz
gentoo-2-ec30c9ff3b291d2026931f894999aa0029411568.tar.bz2
gentoo-2-ec30c9ff3b291d2026931f894999aa0029411568.zip
Fix build without flac, bug #285567. Thanks to Richard Ash for the patch.
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/ChangeLog6
-rw-r--r--media-sound/audacity/audacity-1.3.9.ebuild3
-rw-r--r--media-sound/audacity/files/audacity-1.3.9-noflac.patch49
3 files changed, 56 insertions, 2 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 4df8299ba7df..3799a5b81fbf 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/audacity
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.130 2009/09/22 11:02:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.131 2009/09/23 18:48:02 aballier Exp $
+
+ 23 Sep 2009; Alexis Ballier <aballier@gentoo.org> audacity-1.3.9.ebuild,
+ +files/audacity-1.3.9-noflac.patch:
+ Fix build without flac, bug #285567. Thanks to Richard Ash for the patch.
22 Sep 2009; Markus Meier <maekke@gentoo.org> audacity-1.3.8.ebuild:
amd64/x86 stable, bug #285898
diff --git a/media-sound/audacity/audacity-1.3.9.ebuild b/media-sound/audacity/audacity-1.3.9.ebuild
index 205ade28eb09..a634b18b95f2 100644
--- a/media-sound/audacity/audacity-1.3.9.ebuild
+++ b/media-sound/audacity/audacity-1.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.9.ebuild,v 1.1 2009/09/15 20:12:54 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.9.ebuild,v 1.2 2009/09/23 18:48:02 aballier Exp $
EAPI=2
@@ -50,6 +50,7 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}/${PN}-1.3.8-automagic.patch"
epatch "${FILESDIR}/${PN}-1.3.8-gsocket-conflict.patch"
+ epatch "${FILESDIR}/${P}-noflac.patch"
AT_M4DIR="${S}/m4" eautoreconf
}
diff --git a/media-sound/audacity/files/audacity-1.3.9-noflac.patch b/media-sound/audacity/files/audacity-1.3.9-noflac.patch
new file mode 100644
index 000000000000..200282d3386a
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.9-noflac.patch
@@ -0,0 +1,49 @@
+Index: m4/audacity_checklib_libflac.m4
+===================================================================
+RCS file: /cvsroot/audacity/audacity-src/m4/audacity_checklib_libflac.m4,v
+retrieving revision 1.2
+diff -u -r1.2 audacity_checklib_libflac.m4
+--- m4/audacity_checklib_libflac.m4 20 Jan 2009 21:23:58 -0000 1.2
++++ m4/audacity_checklib_libflac.m4 16 Sep 2009 20:15:47 -0000
+@@ -2,7 +2,7 @@
+ dnl
+ dnl Please increment the serial number below whenever you alter this macro
+ dnl for the benefit of automatic macro update systems
+-# audacity_checklib_libflac.m4 serial 1
++# audacity_checklib_libflac.m4 serial 2
+
+ AC_DEFUN([AUDACITY_CHECKLIB_LIBFLAC], [
+
+@@ -33,6 +33,8 @@
+ LIBFLAC_SYSTEM_AVAILABLE="yes"
+ LIBFLAC_SYSTEM_LIBS="-lFLAC++ -lFLAC"
+ LIBFLAC_SYSTEM_CPPSYMBOLS="USE_LIBFLAC"
++ # this file shouldn't be built at if no libflac is available
++ LIBFLAC_SYSTEM_OPTOBJS="ondemand/ODDecodeFlacTask.o"
+ AC_MSG_NOTICE([FLAC libraries are available as system libraries])
+ else
+ LIBFLAC_SYSTEM_AVAILABLE="no"
+@@ -58,6 +60,8 @@
+ LIBFLAC_LOCAL_CXXFLAGS="$LIBFLAC_LOCAL_CXXFLAGS -I\$(top_srcdir)/lib-src/libflac/include"
+
+ LIBFLAC_LOCAL_CPPSYMBOLS="USE_LIBFLAC"
++ # this file shouldn't be built at if no libflac is available
++ LIBFLAC_LOCAL_OPTOBJS="ondemand/ODDecodeFlacTask.o"
+ LIBFLAC_LOCAL_CONFIG_SUBDIRS="lib-src/libflac"
+
+ AC_MSG_NOTICE([FLAC libraries are available in this source tree])
+Index: src/Makefile.in
+===================================================================
+RCS file: /cvsroot/audacity/audacity-src/src/Makefile.in,v
+retrieving revision 1.167
+diff -u -r1.167 Makefile.in
+--- src/Makefile.in 17 Aug 2009 18:32:24 -0000 1.167
++++ src/Makefile.in 16 Sep 2009 20:15:47 -0000
+@@ -194,7 +194,6 @@
+ import/ImportRaw.o \
+ import/RawAudioGuess.o \
+ ondemand/ODComputeSummaryTask.o \
+- ondemand/ODDecodeFlacTask.o \
+ ondemand/ODDecodeTask.o \
+ ondemand/ODManager.o \
+ ondemand/ODTask.o \