summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-18 18:07:15 +0000
committerMax Kalika <max@gentoo.org>2003-08-18 18:07:15 +0000
commit526f87a364defb5717b00f056ada15a52f702a81 (patch)
tree0906d9b2dc1b89b82405b6442d1f53e257220d8c /media-plugins/mythweather
parentManifest fix. (diff)
downloadgentoo-2-526f87a364defb5717b00f056ada15a52f702a81.tar.gz
gentoo-2-526f87a364defb5717b00f056ada15a52f702a81.tar.bz2
gentoo-2-526f87a364defb5717b00f056ada15a52f702a81.zip
Bump version to 0.11.
Diffstat (limited to 'media-plugins/mythweather')
-rw-r--r--media-plugins/mythweather/ChangeLog7
-rw-r--r--media-plugins/mythweather/Manifest4
-rw-r--r--media-plugins/mythweather/files/digest-mythweather-0.111
-rw-r--r--media-plugins/mythweather/mythweather-0.11.ebuild40
4 files changed, 50 insertions, 2 deletions
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
index 2ac3111030ad..1a8619dafd51 100644
--- a/media-plugins/mythweather/ChangeLog
+++ b/media-plugins/mythweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythweather
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.3 2003/08/08 05:18:14 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.4 2003/08/18 18:07:04 max Exp $
+
+*mythweather-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythweather-0.11.ebuild:
+ Bump version to 0.11. Change make install to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythweather-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
index 11c52c5e2297..f3f6340b5a8c 100644
--- a/media-plugins/mythweather/Manifest
+++ b/media-plugins/mythweather/Manifest
@@ -1,3 +1,5 @@
+MD5 4b853f569971fb1d6a9377987bde8394 mythweather-0.11.ebuild 973
MD5 11893933c13d93476fb961b975275cb9 mythweather-0.10.ebuild 1006
-MD5 fbb41082d39afd5ef5ece2acfc1be605 ChangeLog 1187
+MD5 633be5b82eec8d60f3cf1c5ddb5f56b6 ChangeLog 1346
MD5 09666f4a410bc5eda6781edd029505f7 files/digest-mythweather-0.10 69
+MD5 6a31e4f0a87c61e3e7f0eb55dca2f03b files/digest-mythweather-0.11 69
diff --git a/media-plugins/mythweather/files/digest-mythweather-0.11 b/media-plugins/mythweather/files/digest-mythweather-0.11
new file mode 100644
index 000000000000..0f0b4fe72b99
--- /dev/null
+++ b/media-plugins/mythweather/files/digest-mythweather-0.11
@@ -0,0 +1 @@
+MD5 22ec089fb144ef2c316b028c67d266af mythweather-0.11.tar.bz2 814175
diff --git a/media-plugins/mythweather/mythweather-0.11.ebuild b/media-plugins/mythweather/mythweather-0.11.ebuild
new file mode 100644
index 000000000000..5d6ca031daa6
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.11.ebuild,v 1.1 2003/08/18 18:07:05 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}