summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-27 19:38:18 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-27 19:38:18 +0000
commit0fcd32ecb9006f7638fba4da5038ec065bc79a46 (patch)
tree6e8e1047071e254f33be137ca0d0faabede69979 /media-libs
parentPPC stable profile update (Manifest recommit) (diff)
downloadgentoo-2-0fcd32ecb9006f7638fba4da5038ec065bc79a46.tar.gz
gentoo-2-0fcd32ecb9006f7638fba4da5038ec065bc79a46.tar.bz2
gentoo-2-0fcd32ecb9006f7638fba4da5038ec065bc79a46.zip
gcc 3.4.0 fix
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog7
-rw-r--r--media-libs/xine-lib/files/xine-lib-gcc34.patch11
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc3-r3.ebuild6
3 files changed, 22 insertions, 2 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index adc19369bb62..5c5949211a5e 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.108 2004/04/26 14:41:58 tseng Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.109 2004/04/27 19:38:18 lv Exp $
+
+ 27 Apr 2004; Travis Tilley <lv@gentoo.org> +files/xine-lib-gcc34.patch,
+ xine-lib-1_rc3-r3.ebuild:
+ added a patch that removes an attempt to inline ff_h263_round_chroma so that
+ xine-lib will compile using gcc 3.4
26 Apr 2004; Brandon Hale <tseng@gentoo.org> xine-lib-1_rc3-r1.ebuild,
xine-lib-1_rc3-r3.ebuild:
diff --git a/media-libs/xine-lib/files/xine-lib-gcc34.patch b/media-libs/xine-lib/files/xine-lib-gcc34.patch
new file mode 100644
index 000000000000..29103c40a080
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-gcc34.patch
@@ -0,0 +1,11 @@
+--- src/libffmpeg/libavcodec/mpegvideo.h.old 2004-04-27 15:11:22.072712048 -0400
++++ src/libffmpeg/libavcodec/mpegvideo.h 2004-04-27 15:11:45.477154032 -0400
+@@ -892,7 +892,7 @@
+ int ff_h263_resync(MpegEncContext *s);
+ int ff_h263_get_gob_height(MpegEncContext *s);
+ int ff_mpeg4_set_direct_mv(MpegEncContext *s, int mx, int my);
+-inline int ff_h263_round_chroma(int x);
++int ff_h263_round_chroma(int x);
+
+
+ /* rv10.c */
diff --git a/media-libs/xine-lib/xine-lib-1_rc3-r3.ebuild b/media-libs/xine-lib/xine-lib-1_rc3-r3.ebuild
index 449911940d50..b81c8e816b59 100644
--- a/media-libs/xine-lib/xine-lib-1_rc3-r3.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc3-r3.ebuild,v 1.8 2004/04/26 14:41:58 tseng Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc3-r3.ebuild,v 1.9 2004/04/27 19:38:18 lv Exp $
inherit eutils flag-o-matic gcc libtool
@@ -64,6 +64,10 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.6.patch
[ ${ARCH} = "sparc" ] && epatch ${FILESDIR}/${P}-configure-sparc.patch
+ # always_inline means inline-or-fail, so it's no suprise that xine-lib
+ # fails to compile with gcc 3.4 when this one inline fails
+ epatch ${FILESDIR}/xine-lib-gcc34.patch
+
elibtoolize #40317
}