summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-28 19:30:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-28 19:30:44 +0000
commit1cb78997b700c8967076e3cac635f41e9aa239a4 (patch)
tree1eec90e59793c5e154946ddaa33dcc678dc93e45 /media-libs/vo-aacenc
parentkeyword ~amd64-fbsd, bug #477750 (diff)
downloadgentoo-2-1cb78997b700c8967076e3cac635f41e9aa239a4.tar.gz
gentoo-2-1cb78997b700c8967076e3cac635f41e9aa239a4.tar.bz2
gentoo-2-1cb78997b700c8967076e3cac635f41e9aa239a4.zip
version bump
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/vo-aacenc')
-rw-r--r--media-libs/vo-aacenc/ChangeLog7
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/media-libs/vo-aacenc/ChangeLog b/media-libs/vo-aacenc/ChangeLog
index 11d131e010b3..c93b7d44d4c8 100644
--- a/media-libs/vo-aacenc/ChangeLog
+++ b/media-libs/vo-aacenc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/vo-aacenc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-aacenc/ChangeLog,v 1.35 2013/07/28 19:25:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-aacenc/ChangeLog,v 1.36 2013/07/28 19:30:44 aballier Exp $
+
+*vo-aacenc-0.1.3 (28 Jul 2013)
+
+ 28 Jul 2013; Alexis Ballier <aballier@gentoo.org> +vo-aacenc-0.1.3.ebuild:
+ version bump
28 Jul 2013; Alexis Ballier <aballier@gentoo.org> vo-aacenc-9999.ebuild:
Go multilib
diff --git a/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
new file mode 100644
index 000000000000..976e385d405a
--- /dev/null
+++ b/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-aacenc/vo-aacenc-0.1.3.ebuild,v 1.1 2013/07/28 19:30:44 aballier Exp $
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+ AUTOTOOLS_AUTORECONF=yes
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="VisualOn AAC encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="examples static-libs neon"
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+src_configure() {
+ local myeconfargs=(
+ "$(use_enable examples example)"
+ "$(use_enable neon armv7neon)"
+ )
+ autotools-multilib_src_configure
+}