summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-04-11 11:50:14 +0000
committerMichael Januszewski <spock@gentoo.org>2007-04-11 11:50:14 +0000
commitea3a4d4ac7b60ce8ddbd78d89551cc6e80958dee (patch)
tree83c410192baa3156467d8cfeaa106f33bad95e0e /media-gfx
parentupdate HOMEPAGE to something nice (diff)
downloadgentoo-2-ea3a4d4ac7b60ce8ddbd78d89551cc6e80958dee.tar.gz
gentoo-2-ea3a4d4ac7b60ce8ddbd78d89551cc6e80958dee.tar.bz2
gentoo-2-ea3a4d4ac7b60ce8ddbd78d89551cc6e80958dee.zip
Fix the ebuild to handle multilib properly.
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/splashutils/ChangeLog6
-rw-r--r--media-gfx/splashutils/splashutils-1.4.ebuild6
2 files changed, 9 insertions, 3 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 009d6bfb6be8..0ed7975381c6 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.82 2007/04/09 11:17:49 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.83 2007/04/11 11:50:14 spock Exp $
+
+ 11 Apr 2007; Michał Januszewski <spock@gentoo.org>
+ splashutils-1.4.ebuild:
+ Fix the ebuild to handle multilib properly.
09 Apr 2007; Michał Januszewski <spock@gentoo.org>
-files/splashutils-1.3-initrd-chvt.patch,
diff --git a/media-gfx/splashutils/splashutils-1.4.ebuild b/media-gfx/splashutils/splashutils-1.4.ebuild
index 767a7a14ff1b..f2b8ab66ab48 100644
--- a/media-gfx/splashutils/splashutils-1.4.ebuild
+++ b/media-gfx/splashutils/splashutils-1.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.4.ebuild,v 1.2 2007/04/06 09:02:01 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.4.ebuild,v 1.3 2007/04/11 11:50:14 spock Exp $
-inherit eutils multilib toolchain-funcs
+inherit eutils multilib flag-o-matic toolchain-funcs
MISCSPLASH="miscsplashutils-0.1.5"
GENTOOSPLASH="splashutils-gentoo-1.0.0"
@@ -116,6 +116,7 @@ src_compile() {
cd ${S}
./configure \
+ --with-fifo=$(get_libdir)/splash/cache/.splash \
$(use_with png) \
$(use_with mng) \
$(use_with gpm) \
@@ -129,6 +130,7 @@ src_compile() {
if has_version ">=sys-apps/baselayout-1.13.99"; then
cd ${SG}
+ append-flags "-DLIBDIR=\\\"$(get_libdir)\\\""
emake || die "failed to build the splash plugin"
fi
}