summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-03-01 21:11:41 +0000
committerChris Reffett <creffett@gentoo.org>2013-03-01 21:11:41 +0000
commit36e66d0a089a65631bc52fbf18ad5dbcdcd2157c (patch)
treeafc048f48cdaa199ada99d155594cabd76363cc7 /media-gfx
parentAdd missing patch, reported by Andrei Frunza. (diff)
downloadgentoo-2-36e66d0a089a65631bc52fbf18ad5dbcdcd2157c.tar.gz
gentoo-2-36e66d0a089a65631bc52fbf18ad5dbcdcd2157c.tar.bz2
gentoo-2-36e66d0a089a65631bc52fbf18ad5dbcdcd2157c.zip
Version bump to 4.4, fixes bug 456276
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/kphotoalbum/ChangeLog7
-rw-r--r--media-gfx/kphotoalbum/kphotoalbum-4.4.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-gfx/kphotoalbum/ChangeLog b/media-gfx/kphotoalbum/ChangeLog
index 558fb8fe0ce6..b3080a67d08b 100644
--- a/media-gfx/kphotoalbum/ChangeLog
+++ b/media-gfx/kphotoalbum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/kphotoalbum
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/kphotoalbum/ChangeLog,v 1.56 2013/02/09 23:42:18 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/kphotoalbum/ChangeLog,v 1.57 2013/03/01 21:11:41 creffett Exp $
+
+*kphotoalbum-4.4 (01 Mar 2013)
+
+ 01 Mar 2013; Chris Reffett <creffett@gentoo.org> +kphotoalbum-4.4.ebuild:
+ Version bump to 4.4, fixes bug 456276
09 Feb 2013; Andreas K. Huettel <dilfridge@gentoo.org>
kphotoalbum-4.2.ebuild:
diff --git a/media-gfx/kphotoalbum/kphotoalbum-4.4.ebuild b/media-gfx/kphotoalbum/kphotoalbum-4.4.ebuild
new file mode 100644
index 000000000000..f80bec699387
--- /dev/null
+++ b/media-gfx/kphotoalbum/kphotoalbum-4.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/kphotoalbum/kphotoalbum-4.4.ebuild,v 1.1 2013/03/01 21:11:41 creffett Exp $
+
+EAPI=4
+
+KDE_LINGUAS="ar be bg bs ca ca@valencia cs da de el en_GB eo es et eu fi fr ga gl
+hi hne hr hu is it ja km lt mai nb nds nl nn pa pl pt pt_BR ro ru se sk sv tr ug uk
+vi zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="KDE Photo Album is a tool for indexing, searching, and viewing images."
+HOMEPAGE="http://www.kphotoalbum.org/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug +exif +geolocation +kipi +raw +semantic-desktop"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ >=x11-libs/qt-sql-4.4:4[sqlite]
+ virtual/jpeg
+ exif? ( >=media-gfx/exiv2-0.17 )
+ geolocation? ( $(add_kdebase_dep marble) )
+ kipi? ( $(add_kdebase_dep libkipi '' 4.9.58) )
+ raw? ( $(add_kdebase_dep libkdcraw '' 4.9.58) )
+"
+RDEPEND="${DEPEND}
+ semantic-desktop? ( $(add_kdebase_dep nepomuk) )
+"
+
+DOCS=( ChangeLog README TODO )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with exif Exiv2)
+ $(cmake-utils_use_with geolocation Marble)
+ $(cmake-utils_use_with kipi)
+ $(cmake-utils_use_with raw Kdcraw)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+
+ kde4-base_src_configure
+}