summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2013-05-24 23:40:52 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2013-05-24 23:40:52 +0000
commitecba292b7b6958f32e5545c6102a704e85c09fc5 (patch)
tree513e6a6dfa5e7444f943964e740d36a46f5d71b7 /mail-mta/opensmtpd
parentremove redundant second argument for use_enable (diff)
downloadgentoo-2-ecba292b7b6958f32e5545c6102a704e85c09fc5.tar.gz
gentoo-2-ecba292b7b6958f32e5545c6102a704e85c09fc5.tar.bz2
gentoo-2-ecba292b7b6958f32e5545c6102a704e85c09fc5.zip
Stabilize released version and add testing snapshot.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'mail-mta/opensmtpd')
-rw-r--r--mail-mta/opensmtpd/ChangeLog8
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.3.2.201305241932_p1.ebuild86
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.3.2_p1-r1.ebuild4
3 files changed, 95 insertions, 3 deletions
diff --git a/mail-mta/opensmtpd/ChangeLog b/mail-mta/opensmtpd/ChangeLog
index c406ea5755d7..05e27f2771e9 100644
--- a/mail-mta/opensmtpd/ChangeLog
+++ b/mail-mta/opensmtpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-mta/opensmtpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.15 2013/05/19 14:34:21 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.16 2013/05/24 23:40:52 zx2c4 Exp $
+
+*opensmtpd-5.3.2.201305241932_p1 (24 May 2013)
+
+ 24 May 2013; Jason A. Donenfeld <zx2c4@gentoo.org>
+ +opensmtpd-5.3.2.201305241932_p1.ebuild, opensmtpd-5.3.2_p1-r1.ebuild:
+ Stabilize released version and add testing snapshot.
*opensmtpd-5.3.2_p1-r1 (19 May 2013)
diff --git a/mail-mta/opensmtpd/opensmtpd-5.3.2.201305241932_p1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.3.2.201305241932_p1.ebuild
new file mode 100644
index 000000000000..266e5b4a48dc
--- /dev/null
+++ b/mail-mta/opensmtpd/opensmtpd-5.3.2.201305241932_p1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.2.201305241932_p1.ebuild,v 1.1 2013/05/24 23:40:52 zx2c4 Exp $
+
+EAPI=5
+
+inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools versionator
+
+DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
+HOMEPAGE="http://www.opensmtpd.org/"
+MY_DP="${P}"
+MY_P="${P}"
+if [ $(get_last_version_component_index) -eq 4 ]; then
+ MY_DP="${PN}-$(get_version_component_range 4-)"
+ MY_P="${PN}-${PV/.$(get_version_component_range 4)}"
+fi
+SRC_URI="http://www.opensmtpd.org/archives/${MY_DP/_}.tar.gz"
+
+LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam sqlite"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ pam? ( virtual/pam )
+ sys-libs/db
+ sqlite? ( dev-db/sqlite:3 )
+ dev-libs/libevent
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp[mta]
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp[mta]
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P/_}
+
+#XXX: HACK TEMP WORKAROUND:
+S=${WORKDIR}/"opensmtpd-5.3.1p1"
+
+src_prepare() {
+ epatch "${FILESDIR}"/build-warnings.patch
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+ AR="$(which "$AR")" econf \
+ --with-privsep-user=smtpd \
+ --with-filter-user=smtpf \
+ --with-queue-user=smtpq \
+ --with-privsep-path=/var/empty \
+ --with-sock-dir=/var/run \
+ --sysconfdir=/etc/opensmtpd \
+ $(use_with sqlite experimental-sqlite) \
+ $(use_with pam)
+ #--with-lookup-user=smtpl will be available in the release after 5.3p1
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/smtpd.initd smtpd
+ use pam && newpamd "${FILESDIR}"/smtpd.pam smtpd
+}
+
+pkg_preinst() {
+ enewgroup smtpd 25
+ enewuser smtpd 25 -1 /var/empty smtpd
+ enewgroup smtpf 251
+ enewuser smtpf 251 -1 /var/empty smtpf
+ enewgroup smtpq 252
+ enewuser smtpq 252 -1 /var/empty smtpq
+
+ # For release after 5.3p1:
+ #enewgroup smtpl 253
+ #enewuser smtpl 253 -1 /var/empty smtpl
+}
diff --git a/mail-mta/opensmtpd/opensmtpd-5.3.2_p1-r1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.3.2_p1-r1.ebuild
index 349803b022cf..b9c735e8fab6 100644
--- a/mail-mta/opensmtpd/opensmtpd-5.3.2_p1-r1.ebuild
+++ b/mail-mta/opensmtpd/opensmtpd-5.3.2_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.2_p1-r1.ebuild,v 1.1 2013/05/19 14:34:21 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.2_p1-r1.ebuild,v 1.2 2013/05/24 23:40:52 zx2c4 Exp $
EAPI=5
@@ -18,7 +18,7 @@ SRC_URI="http://www.opensmtpd.org/archives/${MY_DP/_}.tar.gz"
LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="pam sqlite"
DEPEND="dev-libs/openssl