summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2013-05-16 03:51:54 +0000
committerChristian Faulhammer <fauli@gentoo.org>2013-05-16 03:51:54 +0000
commit5ae90ef3fa4f72fe261911d652ef565fb561aad0 (patch)
treeb9db2a49a601c4e53375c3d04e48d08be2f7acfe /mail-client/claws-mail
parentversion bump (diff)
downloadgentoo-2-5ae90ef3fa4f72fe261911d652ef565fb561aad0.tar.gz
gentoo-2-5ae90ef3fa4f72fe261911d652ef565fb561aad0.tar.bz2
gentoo-2-5ae90ef3fa4f72fe261911d652ef565fb561aad0.zip
fix segfault with NNTP as reported by Alexander Tsoy on bug 469838
(Portage version: 2.1.11.62/cvs/Linux i686, RepoMan options: --force, signed Manifest commit with key 2B859DE3)
Diffstat (limited to 'mail-client/claws-mail')
-rw-r--r--mail-client/claws-mail/ChangeLog8
-rw-r--r--mail-client/claws-mail/claws-mail-3.9.1-r1.ebuild208
-rw-r--r--mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch36
3 files changed, 251 insertions, 1 deletions
diff --git a/mail-client/claws-mail/ChangeLog b/mail-client/claws-mail/ChangeLog
index 73097b2a0f13..b5b40cde351a 100644
--- a/mail-client/claws-mail/ChangeLog
+++ b/mail-client/claws-mail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.237 2013/05/14 18:21:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.238 2013/05/16 03:51:53 fauli Exp $
+
+*claws-mail-3.9.1-r1 (16 May 2013)
+
+ 16 May 2013; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-3.9.1-r1.ebuild, +files/claws-mail-3.9.1_fix-nntp-segfault.patch:
+ fix segfault with NNTP as reported by Alexander Tsoy on bug 469838
14 May 2013; Markus Meier <maekke@gentoo.org> claws-mail-3.9.1.ebuild:
add ~arm, bug #468984
diff --git a/mail-client/claws-mail/claws-mail-3.9.1-r1.ebuild b/mail-client/claws-mail/claws-mail-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..42accb28157d
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-3.9.1-r1.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-3.9.1-r1.ebuild,v 1.1 2013/05/16 03:51:53 fauli Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{5,6,7} )
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib gnome2-utils eutils python-single-r1
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org/"
+
+SRC_URI="mirror://sourceforge/sylpheed-claws/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
+
+IUSE="archive bogofilter calendar clamav dbus debug doc gdata gtk3 +imap ipv6 ldap +libcanberra +libindicate +libnotify networkmanager nntp +notification pda pdf perl +pgp python rss session smime spamassassin spam-report spell +gnutls startup-notification valgrind webkit xface"
+REQUIRED_USE="networkmanager? ( dbus )
+ smime? ( pgp )
+ libcanberra? ( notification )
+ libindicate? ( notification )
+ libnotify? ( notification )"
+
+# Plugins are all integrated or dropped since 3.9.1
+PLUGINBLOCK="!!mail-client/claws-mail-acpi-notifier
+ !!mail-client/claws-mail-archive
+ !!mail-client/claws-mail-att-remover
+ !!mail-client/claws-mail-attachwarner
+ !!mail-client/claws-mail-clamd
+ !!mail-client/claws-mail-fancy
+ !!mail-client/claws-mail-fetchinfo
+ !mail-client/claws-mail-gdata
+ !!mail-client/claws-mail-geolocation
+ !!mail-client/claws-mail-gtkhtml
+ !!mail-client/claws-mail-mailmbox
+ !!mail-client/claws-mail-newmail
+ !!mail-client/claws-mail-notification
+ !!mail-client/claws-mail-perl
+ !!mail-client/claws-mail-python
+ !!mail-client/claws-mail-rssyl
+ !!mail-client/claws-mail-spam-report
+ !!mail-client/claws-mail-tnef-parse
+ !!mail-client/claws-mail-vcalendar
+ !!mail-client/claws-mail-address_keeper
+ !!mail-client/claws-mail-pdf-viewer"
+
+COMMONDEPEND=">=sys-devel/gettext-0.12.1
+ gdata? ( >=dev-libs/libgdata-0.6.4 )
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( >=x11-libs/gtk+-2.20:2 )
+ pda? ( >=app-pda/jpilot-0.99 )
+ gnutls? ( >=net-libs/gnutls-2.2.0 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ pgp? ( >=app-crypt/gpgme-0.4.5 )
+ valgrind? ( dev-util/valgrind )
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ spell? ( >=app-text/enchant-1.0.0 )
+ imap? ( >=net-libs/libetpan-0.57 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ startup-notification? ( x11-libs/startup-notification )
+ session? ( x11-libs/libSM
+ x11-libs/libICE )
+ archive? ( app-arch/libarchive
+ >=net-misc/curl-7.9.7 )
+ bogofilter? ( mail-filter/bogofilter )
+ notification? (
+ libnotify? ( x11-libs/libnotify )
+ libcanberra? ( media-libs/libcanberra[gtk] )
+ libindicate? ( dev-libs/libindicate:3[gtk] )
+ dev-libs/glib
+ )
+ smime? ( >=app-crypt/gpgme-0.4.5 )
+ calendar? ( >=net-misc/curl-7.9.7 )
+ pdf? ( app-text/poppler:=[cairo] )
+ spam-report? ( >=net-misc/curl-7.9.7 )
+ webkit? ( >=net-libs/webkit-gtk-1.0:2
+ || ( >=net-libs/libsoup-2.42:2.4
+ >=net-libs/libsoup-gnome-2.26:2.4 )
+ )"
+
+DEPEND="${PLUGINBLOCK}
+ ${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+ virtual/pkgconfig"
+
+RDEPEND="${COMMONDEPEND}
+ pdf? ( app-text/ghostscript-gpl )
+ clamav? ( app-antivirus/clamav )
+ networkmanager? ( net-misc/networkmanager )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.10.3 )
+ rss? ( net-misc/curl
+ dev-libs/libxml2 )
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+PATCHES=( "${FILESDIR}/${P}_libsoup-check-fix.patch" "${FILESDIR}/${P}_fix-nntp-segfault.patch")
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug crash-dialog)
+ $(use_enable valgrind valgrind)
+ $(use_enable doc manual)
+ $(use_enable gtk3)
+ $(use_enable ipv6)
+ $(use_enable ldap)
+ $(use_enable dbus dbus)
+ $(use_enable networkmanager)
+ $(use_enable pda jpilot)
+ $(use_enable session libsm)
+ $(use_enable spell enchant)
+ $(use_enable gnutls)
+ $(use_enable startup-notification)
+ $(use_enable xface compface)
+ $(use_enable archive archive-plugin)
+ $(use_enable bogofilter bogofilter-plugin)
+ $(use_enable calendar vcalendar-plugin)
+ $(use_enable clamav clamd-plugin)
+ $(use_enable gdata gdata-plugin)
+ $(use_enable notification notification-plugin)
+ $(use_enable pdf pdf_viewer-plugin)
+ $(use_enable perl perl-plugin)
+ $(use_enable pgp pgpmime-plugin)
+ $(use_enable pgp pgpinline-plugin)
+ $(use_enable pgp pgpcore-plugin)
+ $(use_enable python python-plugin)
+ $(use_enable rss rssyl-plugin)
+ $(use_enable spamassassin spamassassin-plugin)
+ $(use_enable smime smime-plugin)
+ $(use_enable spam-report spam_report-plugin)
+ $(use_enable webkit fancy-plugin)
+ --enable-new-addrbook
+ --enable-nls
+ --enable-acpi_notifier-plugin
+ --enable-address_keeper-plugin
+ --enable-att_remover-plugin
+ --enable-attachwarner-plugin
+ --enable-fetchinfo-plugin
+ --enable-mailmbox-plugin
+ --enable-newmail-plugin
+ --enable-tnef_parse-plugin
+ --disable-generic-umpc
+ --disable-maemo
+ --disable-bsfilter-plugin
+ --disable-geolocation-plugin
+ )
+
+ # libetpan is needed if user wants nntp or imap functionality
+ if use imap || use nntp; then
+ myeconfargs+=( --enable-libetpan )
+ else
+ myeconfargs+=( --disable-libetpan )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog* INSTALL* NEWS README* TODO* )
+ autotools-utils_src_install
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png || die
+ local res resdir
+ for res in 64x64 128x128 ; do
+ resdir="/usr/share/icons/hicolor/${res}/apps"
+ insinto ${resdir}
+ newins ${PN}-${res}.png ${PN}.png || die
+ done
+
+ docinto tools
+ dodoc tools/README*
+
+ domenu ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh || die
+ doexe tb2claws-mail update-po uudec uuooffice || die
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ ewarn "When upgrading from version 3.9.0 or below some changes have happened:"
+ ewarn "- There are no individual plugins in mail-client/claws-mail-* anymore, but they are integrated mostly controlled through USE flags"
+ ewarn "- Plugins with no special dependencies are just built and can be loaded through the interface"
+ ewarn "- The gtkhtml2, dillo and trayicon plugins have been dropped entirely"
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch b/mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch
new file mode 100644
index 000000000000..0abc3725a70b
--- /dev/null
+++ b/mail-client/claws-mail/files/claws-mail-3.9.1_fix-nntp-segfault.patch
@@ -0,0 +1,36 @@
+claws-mail 3.9.1 reproducible segfaults on exit when compiled with NNTP support.
+
+Apparently the pointer returned by account_get_list() is truncated to an integer due to a missing function definition:
+
+(gdb) r
+Starting program: /usr/local/bin/claws-mail
+[New LWP 101084]
+[New Thread 80ac06400 (LWP 101084)]
+
+Program received signal SIGSEGV, Segmentation fault.
+[Switching to Thread 80ac06400 (LWP 101084)]
+0x00000000005331f9 in nntp_disconnect_all (have_connectivity=1) at news.c:1418
+1418 for (list = account_get_list(); list != NULL; list = list->next) {
+(gdb) where
+#0 0x00000000005331f9 in nntp_disconnect_all (have_connectivity=1) at news.c:1418
+#1 0x0000000000669cf3 in nntp_main_done (have_connectivity=1) at nntp-thread.c:163
+#2 0x00000000004e59aa in exit_claws (mainwin=0x80acf23c0) at main.c:1811
+#3 0x00000000004e2627 in main (argc=1, argv=0x7fffffffd8b0) at main.c:1739
+(gdb) p list
+$1 = (GList *) 0xb836a00
+
+
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=469838
+Upstream bug: http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2924
+Upstream fix: http://git.claws-mail.org/?p=claws.git;a=patch;h=8891f6e23e51b38c54c7b717fa0922cb101b76a2
+
+--- a/src/news.c
++++ b/src/news.c
+@@ -56,6 +56,7 @@
+ #include "remotefolder.h"
+ #include "alertpanel.h"
+ #include "inc.h"
++#include "account.h"
+ #ifdef USE_GNUTLS
+ # include "ssl.h"
+ #endif