summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2011-04-08 12:13:53 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2011-04-08 12:13:53 +0000
commitd55a81af74ec138e32302c4b67087d56eec51b72 (patch)
tree73586aae48c576add23d261be966ed644f73ec6e /gnome-extra
parentDrop m68k, ppc, ppc64 KEYWORDS to unmask Module-Build (#357599) (diff)
downloadgentoo-2-d55a81af74ec138e32302c4b67087d56eec51b72.tar.gz
gentoo-2-d55a81af74ec138e32302c4b67087d56eec51b72.tar.bz2
gentoo-2-d55a81af74ec138e32302c4b67087d56eec51b72.zip
Added patch to honor CFLAGS (bug #361377); added USE flag to pull in python-dbus if dbus support is requested
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gdesklets-core/ChangeLog10
-rw-r--r--gnome-extra/gdesklets-core/files/gdesklets-core-0.36.3-CFLAGS.patch37
-rw-r--r--gnome-extra/gdesklets-core/gdesklets-core-0.36.3-r3.ebuild126
-rw-r--r--gnome-extra/gdesklets-core/metadata.xml3
4 files changed, 175 insertions, 1 deletions
diff --git a/gnome-extra/gdesklets-core/ChangeLog b/gnome-extra/gdesklets-core/ChangeLog
index dfea5de8d1e3..d53de310d3ac 100644
--- a/gnome-extra/gdesklets-core/ChangeLog
+++ b/gnome-extra/gdesklets-core/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/gdesklets-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gdesklets-core/ChangeLog,v 1.140 2011/02/03 02:40:46 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gdesklets-core/ChangeLog,v 1.141 2011/04/08 12:13:53 nixphoeni Exp $
+
+*gdesklets-core-0.36.3-r3 (08 Apr 2011)
+
+ 08 Apr 2011; Joe Sapp <nixphoeni@gentoo.org>
+ +gdesklets-core-0.36.3-r3.ebuild, +files/gdesklets-core-0.36.3-CFLAGS.patch:
+ Added patch to honor CFLAGS (bug #361377); added USE flag to pull in
+ python-dbus if dbus support is requested; added blurb about dbus USE flag
+ to metadata
*gdesklets-core-0.36.3-r2 (03 Feb 2011)
diff --git a/gnome-extra/gdesklets-core/files/gdesklets-core-0.36.3-CFLAGS.patch b/gnome-extra/gdesklets-core/files/gdesklets-core-0.36.3-CFLAGS.patch
new file mode 100644
index 000000000000..3abfb08b8ec0
--- /dev/null
+++ b/gnome-extra/gdesklets-core/files/gdesklets-core-0.36.3-CFLAGS.patch
@@ -0,0 +1,37 @@
+=== modified file 'configure.ac'
+--- configure.ac 2011-02-15 10:13:11 +0000
++++ configure.ac 2011-04-08 01:27:57 +0000
+@@ -9,6 +9,7 @@
+ AC_CONFIG_MACRO_DIR([macros])
+ AC_CONFIG_FILES([Makefile])
+ AM_MAINTAINER_MODE
++: ${CFLAGS="-Os -g"}
+
+ dnl Required programs
+ AC_PROG_CC
+@@ -21,14 +22,12 @@
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+
+-CFLAGS="-Os -g"
+-
+ AC_ARG_ENABLE(debug,AS_HELP_STRING([--enable-debug],[Maximum debugging]),
+ set_debug="$enableval",[set_debug=no])
+ AC_MSG_CHECKING(for more debugging including macro expansion)
+ if test "$GCC" = "yes" -a "$set_debug" != "no"; then
+ AC_MSG_RESULT(yes)
+- CFLAGS="-O0 -g3"
++ CFLAGS="$CFLAGS -O0 -g3"
+ else
+ AC_MSG_RESULT(no)
+ fi
+@@ -39,7 +38,7 @@
+ AC_MSG_CHECKING(for more warnings, including -Werror)
+ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
+ AC_MSG_RESULT(yes)
+- CFLAGS="\
++ CFLAGS="$CFLAGS \
+ -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes \
+ -Wmissing-declarations -Wredundant-decls -Wunreachable-code \
+ -Wpointer-arith -Wcast-align -Wsign-compare -ansi \
+
diff --git a/gnome-extra/gdesklets-core/gdesklets-core-0.36.3-r3.ebuild b/gnome-extra/gdesklets-core/gdesklets-core-0.36.3-r3.ebuild
new file mode 100644
index 000000000000..85592237c0dd
--- /dev/null
+++ b/gnome-extra/gdesklets-core/gdesklets-core-0.36.3-r3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gdesklets-core/gdesklets-core-0.36.3-r3.ebuild,v 1.1 2011/04/08 12:13:53 nixphoeni Exp $
+
+EAPI=2
+# desklets don't run with USE=debug
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+
+inherit gnome2 python eutils autotools multilib bash-completion
+
+MY_PN="${PN/-core}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="GNOME Desktop Applets: Core library for desktop applets"
+SRC_URI="http://gdesklets.de/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://gdesklets.de"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="dbus"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# is libgsf needed for runtime or just compiling?
+RDEPEND=">=dev-libs/glib-2.4
+ >=gnome-base/librsvg-2.8
+ >=gnome-base/libgtop-2.8.2
+ >=dev-python/pygtk-2.10
+ >=dev-python/libbonobo-python-2.6
+ >=dev-python/gconf-python-2.6
+ >=dev-python/pygobject-2.6
+ >=dev-python/pyorbit-2.0.1
+ || ( >=dev-python/gnome-vfs-python-2.6 >=dev-python/libgnome-python-2.6 )
+ >=dev-libs/expat-1.95.8
+ >=dev-python/pyxml-0.8.3-r1
+ dbus? ( dev-python/dbus-python )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+CONVERT_SHEBANGS="ctrlinfo gdesklets gdesklets-daemon gdesklets-logview \
+ gdesklets-shell test-control.py contrib/gdesklets-migration-tool"
+
+pkg_setup() {
+
+ python_set_active_version 2
+
+}
+
+src_prepare() {
+
+ epatch "${FILESDIR}/${P}-.in-files.patch"
+ epatch "${FILESDIR}/${P}-CFLAGS.patch"
+ gnome2_src_prepare
+
+ # Postpone pyc compiling until pkg_postinst
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ eautoreconf
+ intltoolize --force || die
+
+ python_convert_shebangs 2 ${CONVERT_SHEBANGS}
+
+}
+
+src_install() {
+
+ gnome2_src_install
+
+ # Install bash completion script
+ BASHCOMPLETION_NAME="gDesklets" \
+ dobashcompletion "contrib/bash/gdesklets"
+
+ # Install the gdesklets-control-getid script
+ insinto "/usr/$(get_libdir)/gdesklets"
+ insopts -m0555
+ doins "${FILESDIR}/gdesklets-control-getid"
+
+}
+
+pkg_postinst() {
+
+ gnome2_pkg_postinst
+ python_need_rebuild
+ # Compile pyc files on target system
+ python_mod_optimize "/usr/$(get_libdir)/gdesklets"
+
+ echo
+ elog "gDesklets Displays are required before the library"
+ elog "will be usable. Core Displays (Calendar, Clock, Quote-of-the-Day,"
+ elog "and the 15pieces game) are already installed in"
+ elog " ${ROOT}usr/$(get_libdir)/gdesklets/Displays"
+ elog "Additional Displays can be found in -"
+ elog " x11-plugins/desklet-* ,"
+ elog "at http://www.gdesklets.de, or at http://archive.gdesklets.info"
+ elog
+ elog "Next you'll need to start gDesklets using"
+ elog " ${ROOT}usr/bin/gdesklets start"
+ elog "If you're using GNOME this can be done conveniently through"
+ elog "Applications->Accessories->gDesklets or automatically each login"
+ elog "under System->Preferences->Sessions"
+ elog
+ elog "If you're updating from a version less than 0.35_rc1,"
+ elog "you can migrate your desklet configurations by"
+ elog "running"
+ elog " ${ROOT}usr/$(get_libdir)/gdesklets/contrib/gdesklets-migration-tool"
+ elog "after the first time you run gDesklets"
+ elog
+
+ BASHCOMPLETION_NAME="gDesklets" bash-completion_pkg_postinst
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+ # Cleanup after our cavalier python compilation
+ # The function takes care of ${ROOT} for us
+ python_mod_cleanup "/usr/$(get_libdir)/gdesklets"
+
+}
diff --git a/gnome-extra/gdesklets-core/metadata.xml b/gnome-extra/gdesklets-core/metadata.xml
index 7b6febd0160e..653d59246ee1 100644
--- a/gnome-extra/gdesklets-core/metadata.xml
+++ b/gnome-extra/gdesklets-core/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<bugs-to>https://bugs.launchpad.net/gdesklets</bugs-to>
</upstream>
+ <use>
+ <flag name='dbus'>Enable gDesklets Controls to use DBus</flag>
+ </use>
</pkgmetadata>