summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-13 22:15:50 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-13 22:15:50 +0000
commitfa7f0406f413e5946db13750ea8713e7fe5b44f1 (patch)
tree3457b92f2413f333155670cd76a813f1bc93abca /games-simulation
parentMasking app-accessibility/gnome-mousetrap for removal (bug #389979) (diff)
downloadgentoo-2-fa7f0406f413e5946db13750ea8713e7fe5b44f1.tar.gz
gentoo-2-fa7f0406f413e5946db13750ea8713e7fe5b44f1.tar.bz2
gentoo-2-fa7f0406f413e5946db13750ea8713e7fe5b44f1.zip
fix sci-mathematics/cgal[gmp] problem (thanks rinus, bug 390309)
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/crrcsim/ChangeLog6
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.11.ebuild5
-rw-r--r--games-simulation/crrcsim/files/crrcsim-buildsystem.patch23
-rw-r--r--games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch11
4 files changed, 20 insertions, 25 deletions
diff --git a/games-simulation/crrcsim/ChangeLog b/games-simulation/crrcsim/ChangeLog
index ab3a5f673fc3..e6cbc3cf7fc4 100644
--- a/games-simulation/crrcsim/ChangeLog
+++ b/games-simulation/crrcsim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/crrcsim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.2 2011/11/12 01:54:08 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.3 2011/11/13 22:15:50 xmw Exp $
+
+ 13 Nov 2011; Michael Weber <xmw@gentoo.org> crrcsim-0.9.11.ebuild,
+ +files/crrcsim-cgal_gmp.patch, files/crrcsim-buildsystem.patch:
+ fix sci-mathematics/cgal[gmp] problem (thanks rinus, bug 390309)
12 Nov 2011; Michael Weber <xmw@gentoo.org> crrcsim-0.9.11.ebuild:
Add dep on sci-mathematics/cgal, fix --docdir, clean up
diff --git a/games-simulation/crrcsim/crrcsim-0.9.11.ebuild b/games-simulation/crrcsim/crrcsim-0.9.11.ebuild
index 5aab180b2666..82a71b0aa07a 100644
--- a/games-simulation/crrcsim/crrcsim-0.9.11.ebuild
+++ b/games-simulation/crrcsim/crrcsim-0.9.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/crrcsim-0.9.11.ebuild,v 1.2 2011/11/12 01:54:08 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/crrcsim-0.9.11.ebuild,v 1.3 2011/11/13 22:15:50 xmw Exp $
EAPI=3
@@ -23,6 +23,9 @@ DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${PN}-buildsystem.patch
+ if built_with_use --missing false sci-mathematics/cgal gmp ; then
+ epatch "${FILESDIR}"/${PN}-cgal_gmp.patch
+ fi
eautoreconf
}
diff --git a/games-simulation/crrcsim/files/crrcsim-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
index 824add723a53..774a19379ef8 100644
--- a/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
+++ b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
@@ -13,26 +13,3 @@
if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
dnl Check for Portaudio 18
-@@ -116,9 +120,11 @@
- fi
- AC_SUBST(PA_LIBS)
-
-+AC_ARG_WITH([sdl], AS_HELP_STRING([--without-sdl], [Build without sdl library (default: test)]))
- dnl Search for SDL 1.2.5 or newer
- SDL_VERSION=1.2.5
- sdl_mousewheel="yes (SDL >= 1.2.5)"
-+AS_IF([test "x$with_foo" != "xno"], [
- AM_PATH_SDL($SDL_VERSION,:,AC_MSG_NOTICE([*** SDL version $SDL_VERSION or newer not found! See if at least 1.2.0 is present...]))
- if test "x$no_sdl" = "xyes"
- then
-@@ -129,6 +135,10 @@
- AC_DEFINE([SDL_WITHOUT_MOUSEWHEEL], [1], [SDL < 1.2.5 did not feature mousewheel button macros])
- sdl_mousewheel="no (SDL < 1.2.5)"
- fi
-+])
-+AS_IF([test "x$with_foo" != "xyes"], [
-+ AC_DEFINE([SDL_WITHOUT_MOUSEWHEEL], [1], [SDL disabled])
-+])
- AC_SUBST(SDL_LIBS)
- AC_SUBST(SDL_CFLAGS)
-
diff --git a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
new file mode 100644
index 000000000000..10d6bff6b769
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
@@ -0,0 +1,11 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -229,7 +229,7 @@
+ has_CGAL="yes (found CGAL v3)"
+ fi
+ CGAL_CFLAGS=-frounding-math
+- CGAL_LIBS=-lCGAL
++ CGAL_LIBS="-lCGAL -lgmp"
+ AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
+ else
+ has_CGAL="no (CGAL not found)"