summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-05 22:38:41 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-05 22:38:41 +0000
commit20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4 (patch)
tree94f16fc0e3fcb59a23cd9fcb00a8904ff06b6a6c /games-fps
parentadd support for existing installs/ultimate quake by UncleOwen #111615 (diff)
downloadgentoo-2-20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4.tar.gz
gentoo-2-20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4.tar.bz2
gentoo-2-20ef5f509dfb42b8f53fd65c7c2d862b40b0fea4.zip
quake-data -> quake1 #111622
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild28
-rw-r--r--games-fps/industri/industri-1.01.ebuild11
-rw-r--r--games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild10
-rw-r--r--games-fps/quake1-ctf/quake1-ctf-4.0.ebuild8
-rw-r--r--games-fps/quake1-killer/quake1-killer-2.2z.ebuild10
5 files changed, 33 insertions, 34 deletions
diff --git a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
index f3c5f523b0d9..4c0095051052 100644
--- a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
+++ b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.10 2005/09/26 18:02:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.11 2005/11/05 22:33:53 vapier Exp $
inherit eutils games
@@ -25,32 +25,32 @@ S=${WORKDIR}/WinQuake
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mv GLQUAKE.H glquake.h
mv GL_DRAW.C gl_draw.c
mv GL_RMAIN.C gl_rmain.c
- epatch ${FILESDIR}/stupid-dosformat.patch
+ epatch "${FILESDIR}"/stupid-dosformat.patch
mv Makefile{.linuxi386,}
- epatch ${FILESDIR}/makefile-path-fixes.patch
- epatch ${FILESDIR}/fix-sys_printf.patch
- epatch ${FILESDIR}/makefile-cflags.patch
- epatch ${FILESDIR}/gentoo-paths.patch
- edos2unix console.c ${WORKDIR}/${P}-SDL.patch
- epatch ${WORKDIR}/${P}-SDL.patch
- epatch ${FILESDIR}/${P}-amd64.patch
+ epatch "${FILESDIR}"/makefile-path-fixes.patch
+ epatch "${FILESDIR}"/fix-sys_printf.patch
+ epatch "${FILESDIR}"/makefile-cflags.patch
+ epatch "${FILESDIR}"/gentoo-paths.patch
+ edos2unix console.c "${WORKDIR}"/${P}-SDL.patch
+ epatch "${WORKDIR}"/${P}-SDL.patch
+ epatch "${FILESDIR}"/${P}-amd64.patch
}
src_compile() {
make \
OPTFLAGS="${CFLAGS}" \
- GENTOO_DATADIR=${GAMES_DATADIR}/quake-data \
+ GENTOO_DATADIR=${GAMES_DATADIR}/quake1 \
build_release \
|| die "failed to build WinQuake"
}
src_install() {
- newgamesbin release*/bin/glquake.sdl anaglyph-stereo-quake
- dodoc ${WORKDIR}/readme.id.txt
- dohtml ${WORKDIR}/3dquake.html
+ newgamesbin release*/bin/glquake.sdl anaglyph-stereo-quake || die
+ dodoc "${WORKDIR}"/readme.id.txt
+ dohtml "${WORKDIR}"/3dquake.html
prepgamesdirs
}
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
index d064d6096038..0d1b80127c23 100644
--- a/games-fps/industri/industri-1.01.ebuild
+++ b/games-fps/industri/industri-1.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.9 2005/09/16 01:17:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.10 2005/11/05 22:35:19 vapier Exp $
inherit toolchain-funcs games
@@ -43,7 +43,10 @@ src_unpack() {
}
src_compile() {
- emake -C linux MASTER_DIR="${GAMES_DATADIR}"/quake-data build_release \
+ emake \
+ -C linux \
+ MASTER_DIR="${GAMES_DATADIR}"/quake1 \
+ build_release \
|| die "emake failed"
}
@@ -55,7 +58,7 @@ src_install() {
dodoc linux/README
cd "${WORKDIR}"/industri
dodoc *.txt && rm *.txt
- insinto "${GAMES_DATADIR}"/quake-data/industri
+ insinto "${GAMES_DATADIR}"/quake1/industri
doins *
prepgamesdirs
}
@@ -63,5 +66,5 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
einfo "Please setup your quake pak files before playing in"
- einfo "${GAMES_DATADIR}/quake-data"
+ einfo "${GAMES_DATADIR}/quake1"
}
diff --git a/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild b/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild
index c70c25b776e0..980f97038802 100644
--- a/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild
+++ b/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild,v 1.6 2005/09/26 18:11:08 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/nprquake-sdl/nprquake-sdl-1-r1.ebuild,v 1.7 2005/11/05 22:36:21 vapier Exp $
inherit eutils games
@@ -15,18 +15,18 @@ IUSE=""
DEPEND="media-libs/libsdl"
-S="${WORKDIR}/NPRQuake-SDL"
+S=${WORKDIR}/NPRQuake-SDL
src_unpack() {
unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/${PV}-gentoo.patch"
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
}
src_compile() {
make \
GENTOO_LIBDIR="${GAMES_LIBDIR}/${PN}" \
- GENTOO_DATADIR="${GAMES_DATADIR}/quake-data" \
+ GENTOO_DATADIR="${GAMES_DATADIR}/quake1" \
OPTFLAGS="${CFLAGS}" \
release \
|| die
diff --git a/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild b/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild
index 7602b571c3dc..0408301b0a04 100644
--- a/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild
+++ b/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild,v 1.2 2005/09/26 18:08:17 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild,v 1.3 2005/11/05 22:37:14 vapier Exp $
inherit eutils games
@@ -46,9 +46,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_DATADIR}/quake-data
- dodir "${dir}"
- insinto "${dir}"
- doins -r *
+ insinto "${GAMES_DATADIR}/quake1"
+ doins -r * || die
prepgamesdirs
}
diff --git a/games-fps/quake1-killer/quake1-killer-2.2z.ebuild b/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
index 042f32b03402..6863e9807425 100644
--- a/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
+++ b/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-killer/quake1-killer-2.2z.ebuild,v 1.2 2005/09/26 18:05:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-killer/quake1-killer-2.2z.ebuild,v 1.3 2005/11/05 22:38:41 vapier Exp $
-inherit eutils games
+inherit games
DESCRIPTION="The Killer Quake Patch"
HOMEPAGE="http://kqp.mpog.com/ http://www.planetquake.com/qca/reviews/patch143.htm"
@@ -25,9 +25,7 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_DATADIR}/quake-data/killer
- dodir "${dir}"
- insinto "${dir}"
- doins -r *
+ insinto "${GAMES_DATADIR}/quake-data/killer"
+ doins -r * || die
prepgamesdirs
}