summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-15 01:24:16 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-15 01:24:16 +0000
commitf190e6b40f5e7954d8cd6e8c3811a38505a97d92 (patch)
tree2bda1b3d57a458e222a3c284ab8ebda719e82d20 /games-fps/ut2003-bonuspack-epic
parent"Q.A.: Path variable quoting. (diff)
downloadgentoo-2-f190e6b40f5e7954d8cd6e8c3811a38505a97d92.tar.gz
gentoo-2-f190e6b40f5e7954d8cd6e8c3811a38505a97d92.tar.bz2
gentoo-2-f190e6b40f5e7954d8cd6e8c3811a38505a97d92.zip
Fix quoting.
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-fps/ut2003-bonuspack-epic')
-rw-r--r--games-fps/ut2003-bonuspack-epic/ChangeLog8
-rw-r--r--games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild27
2 files changed, 19 insertions, 16 deletions
diff --git a/games-fps/ut2003-bonuspack-epic/ChangeLog b/games-fps/ut2003-bonuspack-epic/ChangeLog
index 3f1803b1206a..f4a08d0e9e5f 100644
--- a/games-fps/ut2003-bonuspack-epic/ChangeLog
+++ b/games-fps/ut2003-bonuspack-epic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/ut2003-bonuspack-epic
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-bonuspack-epic/ChangeLog,v 1.16 2007/03/12 15:30:37 genone Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-bonuspack-epic/ChangeLog,v 1.17 2008/02/15 01:24:16 wolf31o2 Exp $
+
+ 15 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org>
+ ut2003-bonuspack-epic-1.ebuild:
+ Fix quoting.
12 Mar 2007; Marius Mauch <genone@gentoo.org>
ut2003-bonuspack-epic-1.ebuild:
diff --git a/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
index ae2fef02d15e..75cde69fd1fc 100644
--- a/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
+++ b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild,v 1.14 2007/03/12 15:30:37 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild,v 1.15 2008/02/15 01:24:16 wolf31o2 Exp $
inherit games
@@ -25,25 +25,24 @@ dir=${GAMES_PREFIX_OPT}/ut2003
Ddir=${D}/${dir}
src_unpack() {
- unzip ${DISTDIR}/${A} || die "unpacking"
+ unzip -qq "${DISTDIR}"/${A} || die "unpacking"
# This is done since the files are the same
- rm ${S}/Textures/LastManStanding.utx
+ rm -f "${S}"/Textures/LastManStanding.utx
}
src_install() {
- dodir ${dir}
- insinto ${dir}/Help
- newins ${S}/Help/BonusPackReadme.txt EpicBonusPack.README || die "README"
+ insinto "${dir}"/Help
+ newins "${S}"/Help/BonusPackReadme.txt EpicBonusPack.README || die "README"
- exeinto ${dir}
- doexe ${FILESDIR}/epic-installer
- dodir ${dir}/System
+ exeinto "${dir}"
+ doexe "${FILESDIR}"/epic-installer
+ dodir "${dir}"/System
- cp -r ${S}/{Maps,Sounds,StaticMeshes,Textures} ${Ddir} \
+ cp -r "${S}"/{Maps,Sounds,StaticMeshes,Textures} "${Ddir}" \
|| die "Copying Maps/Sounds/Textures"
- cp ${S}/System/{*.{det,est,frt,int,itt,kot,tmt,u},User.ini} ${Ddir}/System \
- || die "Copying System files"
- cp -v ${S}/System/Manifest.ini ${Ddir}/System/Manifest.ini.epic \
+ cp "${S}"/System/{*.{det,est,frt,int,itt,kot,tmt,u},User.ini} \
+ "${Ddir}"/System || die "Copying System files"
+ cp -v "${S}"/System/Manifest.ini "${Ddir}"/System/Manifest.ini.epic \
|| die "Copying Manifest"
prepgamesdirs